aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2016-11-14 14:19:30 +0800
committerlinimon <linimon@FreeBSD.org>2016-11-14 14:19:30 +0800
commit97b80848bf043210b091dc38d4519d44093e5411 (patch)
tree333ba32b8c0901805cda594834688be62eb2aaab /games
parent9063df9f39e6704397fbcf803f350b2a82c2a928 (diff)
downloadfreebsd-ports-graphics-97b80848bf043210b091dc38d4519d44093e5411.tar.gz
freebsd-ports-graphics-97b80848bf043210b091dc38d4519d44093e5411.tar.zst
freebsd-ports-graphics-97b80848bf043210b091dc38d4519d44093e5411.zip
Mark as broken on various tier-2 archs.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'games')
-rw-r--r--games/cataclysm-dda/Makefile2
-rw-r--r--games/crafty-tablebase-no-pawn/Makefile3
-rw-r--r--games/crafty-tablebase-pawn/Makefile3
-rw-r--r--games/exult/Makefile2
-rw-r--r--games/fkiss/Makefile2
-rw-r--r--games/flightgear-data/Makefile4
-rw-r--r--games/gtkradiant/Makefile2
-rw-r--r--games/nazghul/Makefile2
-rw-r--r--games/netradiant/Makefile2
-rw-r--r--games/spacejunk/Makefile5
-rw-r--r--games/ufoai-data/Makefile4
-rw-r--r--games/xgalaga/Makefile2
-rw-r--r--games/xqf/Makefile2
13 files changed, 33 insertions, 2 deletions
diff --git a/games/cataclysm-dda/Makefile b/games/cataclysm-dda/Makefile
index e2f6a066279..4cfcc122033 100644
--- a/games/cataclysm-dda/Makefile
+++ b/games/cataclysm-dda/Makefile
@@ -59,6 +59,8 @@ SOUND_IMPLIES= SDL
SOUND_FILES= cataclysmthemeREV6.ogg Dark_Days_Ahead_demo_2.ogg
+BROKEN_aarch64= Fails to compile: error: comparison of integers of different signs: wchar_t and const int
+
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 36
diff --git a/games/crafty-tablebase-no-pawn/Makefile b/games/crafty-tablebase-no-pawn/Makefile
index dfcb90f2c04..5620e4c6e0f 100644
--- a/games/crafty-tablebase-no-pawn/Makefile
+++ b/games/crafty-tablebase-no-pawn/Makefile
@@ -49,6 +49,9 @@ RUN_DEPENDS= crafty:games/crafty
NO_BUILD= yes
+BROKEN_aarch64= Fails to install: runaway process
+BROKEN_mips64= Fails to install: runaway process
+
.if !defined(WITH_TBDIR)
WITH_TBDIR= ${PREFIX}/lib/crafty/TB
.endif
diff --git a/games/crafty-tablebase-pawn/Makefile b/games/crafty-tablebase-pawn/Makefile
index d5798b2c65b..3402264aa13 100644
--- a/games/crafty-tablebase-pawn/Makefile
+++ b/games/crafty-tablebase-pawn/Makefile
@@ -41,6 +41,9 @@ RUN_DEPENDS= crafty:games/crafty
NO_BUILD= yes
NO_ARCH= yes
+BROKEN_aarch64= Fails to install: runaway process
+BROKEN_mips64= Fails to install: runaway process
+
.if !defined(WITH_TBDIR)
WITH_TBDIR= ${PREFIX}/lib/crafty/TB
.endif
diff --git a/games/exult/Makefile b/games/exult/Makefile
index 0c23025d1eb..2101ac973d8 100644
--- a/games/exult/Makefile
+++ b/games/exult/Makefile
@@ -59,4 +59,6 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
+BROKEN_aarch64= Fails to compile: error: constant expression evaluates to -1 which cannot be narrowed to type char
+
.include <bsd.port.mk>
diff --git a/games/fkiss/Makefile b/games/fkiss/Makefile
index 55e383b928f..03ce9746409 100644
--- a/games/fkiss/Makefile
+++ b/games/fkiss/Makefile
@@ -39,6 +39,8 @@ ESOUND_LDFLAGS= `pkgconf --libs-only-L esound `
ESOUND_CONFIGURE_ENV_OFF= ac_cv_lib_esd_esd_open_sound=no \
ac_cv_header_esd_h=no
+BROKEN_aarch64= Fails to compile: error: passing char * to parameter of incompatible type __builtin_va_list
+
post-patch:
@${REINPLACE_CMD} -e 's|= @X_LIBS@|= @LDFLAGS@ @X_LIBS@|g' \
${WRKSRC}/Makefile.in
diff --git a/games/flightgear-data/Makefile b/games/flightgear-data/Makefile
index 5ed4ffebf0e..a75dde8037a 100644
--- a/games/flightgear-data/Makefile
+++ b/games/flightgear-data/Makefile
@@ -20,6 +20,10 @@ DATADIR= ${PREFIX}/share/flightgear
PLIST= ${WRKDIR}/pkg-plist
PLIST_DIRS= %%DATADIR%%
+BROKEN_aarch64= Fails to install: runaway process
+BROKEN_armv64= Fails to install: runaway process
+BROKEN_mips64= Fails to install: runaway process
+
post-patch:
@${RM} ${WRKSRC}/COPYING
diff --git a/games/gtkradiant/Makefile b/games/gtkradiant/Makefile
index 154fc837a8a..1717a3d3ca8 100644
--- a/games/gtkradiant/Makefile
+++ b/games/gtkradiant/Makefile
@@ -30,6 +30,8 @@ WRKSRC= ${WRKDIR}/GPL/GtkRadiant
SUB_FILES= ${PORTNAME}
+BROKEN_aarch64= Fails to link: error: ldd command returned with exit code 256
+
post-patch:
@${GREP} -Rl 'defined[[:blank:]]*([[:blank:]]*__linux__[[:blank:]]*) || defined[[:blank:]]*([[:blank:]]*__APPLE__[[:blank:]]*)' ${WRKSRC} | \
${XARGS} ${REINPLACE_CMD} -e \
diff --git a/games/nazghul/Makefile b/games/nazghul/Makefile
index b8ca1ca9238..d47d1dee7f2 100644
--- a/games/nazghul/Makefile
+++ b/games/nazghul/Makefile
@@ -18,6 +18,8 @@ USE_SDL= sdl image mixer
GNU_CONFIGURE= yes
USES= gmake
+BROKEN_aarch64= Fails to compile: error: no matching function for call to cmdwin_vpush
+
post-patch:
${REINPLACE_CMD} -i "" 's|malloc.h|stdlib.h|g' ${WRKSRC}/src/scheme.c
diff --git a/games/netradiant/Makefile b/games/netradiant/Makefile
index 9413c2c466f..0fda9057213 100644
--- a/games/netradiant/Makefile
+++ b/games/netradiant/Makefile
@@ -32,6 +32,8 @@ SUB_FILES= ${PORTNAME}
SUB_LIST= ARCH=${ARCH}
PLIST_SUB:= ${SUB_LIST}
+BROKEN_aarch64= Fails to link: ldd: install/modules/archivepak.so: not a FreeBSD ELF shared object
+
post-patch:
# Add missing checks for __FreeBSD__
@${FIND} ${WRKSRC}/tools -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} \
diff --git a/games/spacejunk/Makefile b/games/spacejunk/Makefile
index ca47a9a0f8c..75375418dfb 100644
--- a/games/spacejunk/Makefile
+++ b/games/spacejunk/Makefile
@@ -13,8 +13,6 @@ COMMENT= Video game about traveling in 2D planetary systems
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_sparc64= Doesn't compile on sparc64
-
GNU_CONFIGURE= yes
USE_SDL= sdl mixer image
@@ -36,6 +34,9 @@ DESKTOP_ENTRIES="Spacejunk" \
OPTIONS_DEFINE= DOCS
+BROKEN_aarch64= Fails to compile: error: _compile_time_assert__ declared as an array with a negative size
+BROKEN_sparc64= Doesn't compile on sparc64
+
post-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/gem-uta.c \
${WRKSRC}/libinfo/gem-uta.c
diff --git a/games/ufoai-data/Makefile b/games/ufoai-data/Makefile
index d3774e3099f..ec1efafcef7 100644
--- a/games/ufoai-data/Makefile
+++ b/games/ufoai-data/Makefile
@@ -26,6 +26,10 @@ NO_ARCH= yes
DATADIR= share/${PKGNAMEPREFIX:S/-//}
PLIST= ${WRKDIR}/pkg-plist
+BROKEN_aarch64= Fails to install: runaway process
+BROKEN_armv6= Fails to install: runaway process
+BROKEN_mips64= Fails to install: runaway process
+
post-extract:
@cd ${WRKSRC}/base && \
${FIND} * -type f -exec ${UNZIP_CMD} "{}" -d ${WRKSRC}/base \;
diff --git a/games/xgalaga/Makefile b/games/xgalaga/Makefile
index e3b9acf5767..38980b72190 100644
--- a/games/xgalaga/Makefile
+++ b/games/xgalaga/Makefile
@@ -26,6 +26,8 @@ OPTIONS_SUB= yes
SOUND_CONFIGURE_OFF= --without-sound
+BROKEN_aarch64= Fails to configure: machine arm64-unknown not recognized
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/xgalaga
diff --git a/games/xqf/Makefile b/games/xqf/Makefile
index ce379a3697a..6e3134a6d14 100644
--- a/games/xqf/Makefile
+++ b/games/xqf/Makefile
@@ -35,6 +35,8 @@ GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
BZIP2_CONFIGURE_ENABLE= bzip2
+BROKEN_aarch64= Fails to linkld: final link failed: Bad value
+
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/xqfdocs.html ${STAGEDIR}${DOCSDIR}