aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-12 10:01:38 +0800
committermarino <marino@FreeBSD.org>2016-09-12 10:01:38 +0800
commitd5681fd0212396b60b1accbc14cc1e39b131ea4a (patch)
treeb0915083d45c45897502ebe27df374bba63ed78b /games
parentb9f3ba3d31e8604a3391eeb2363f632eaca2e229 (diff)
downloadfreebsd-ports-graphics-d5681fd0212396b60b1accbc14cc1e39b131ea4a.tar.gz
freebsd-ports-graphics-d5681fd0212396b60b1accbc14cc1e39b131ea4a.tar.zst
freebsd-ports-graphics-d5681fd0212396b60b1accbc14cc1e39b131ea4a.zip
games/tinymux: Fix SSL flags and handle no SHA0 cases (LibreSSL)
Diffstat (limited to 'games')
-rw-r--r--games/tinymux/Makefile7
-rw-r--r--games/tinymux/files/patch-player.cpp20
2 files changed, 23 insertions, 4 deletions
diff --git a/games/tinymux/Makefile b/games/tinymux/Makefile
index 0688d24f345..dea434e43fc 100644
--- a/games/tinymux/Makefile
+++ b/games/tinymux/Makefile
@@ -20,9 +20,6 @@ USES= gmake
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lcrypto
-
PATCHLEVEL= 12
PORTDOCS= *
@@ -49,7 +46,9 @@ MEMORY_BASED_CONFIGURE_ENABLE= memorybased
REALITY_LVLS_CONFIGURE_ENABLE= realitylvls
SELFCHECK_CONFIGURE_ENABLE= selfcheck
SSL_CONFIGURE_ENABLE= ssl
-SSL_USE= OPENSSL=yes
+SSL_USES= ssl
+SSL_CPPFLAGS= -I${OPENSSLINC}
+SSL_LDFLAGS= -L${OPENSSLLIB} -lcrypto
WOD_REALMS_CONFIGURE_ENABLE= wodrealms
SUB_FILES= ${PORTNAME} pkg-deinstall pkg-message
diff --git a/games/tinymux/files/patch-player.cpp b/games/tinymux/files/patch-player.cpp
new file mode 100644
index 00000000000..691ae109cb7
--- /dev/null
+++ b/games/tinymux/files/patch-player.cpp
@@ -0,0 +1,20 @@
+--- player.cpp.orig 2012-07-12 05:25:51 UTC
++++ player.cpp
+@@ -422,7 +422,7 @@ void ChangePassword(dbref player, const
+ s_Pass(player, pEncodedPassword);
+ }
+
+-#ifdef UNIX_DIGEST
++#if defined(UNIX_DIGEST) && !defined(OPENSSL_NO_SHA0)
+ const UTF8 *p6h_xx_crypt(const UTF8 *szPassword)
+ {
+ // Calculate SHA-0 Hash.
+@@ -598,7 +598,7 @@ const UTF8 *mux_crypt(const UTF8 *szPass
+ case CRYPT_CLEARTEXT:
+ return szPassword;
+
+-#ifdef UNIX_DIGEST
++#if defined(UNIX_DIGEST) && !defined(OPENSSL_NO_SHA0)
+ case CRYPT_P6H_XX:
+ return p6h_xx_crypt(szPassword);
+ #endif