aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-02-05 06:22:30 +0800
committermarino <marino@FreeBSD.org>2016-02-05 06:22:30 +0800
commita6e2c4ed73f3595c0e642922d6bf013c723952cb (patch)
treee3856ac05246f990c8369f826f3efb0ab7c71904 /games
parent45c28ae3c12f12f61314ae80326e262892c84c1e (diff)
downloadfreebsd-ports-graphics-a6e2c4ed73f3595c0e642922d6bf013c723952cb.tar.gz
freebsd-ports-graphics-a6e2c4ed73f3595c0e642922d6bf013c723952cb.tar.zst
freebsd-ports-graphics-a6e2c4ed73f3595c0e642922d6bf013c723952cb.zip
games/tetrinet: document ncurses rqmt (USES+=ncurses), respect LDFLAGS
approved by: infrastructure blanket
Diffstat (limited to 'games')
-rw-r--r--games/tetrinet/Makefile1
-rw-r--r--games/tetrinet/files/patch-Makefile11
2 files changed, 12 insertions, 0 deletions
diff --git a/games/tetrinet/Makefile b/games/tetrinet/Makefile
index 3fdb7753dab..204258857b9 100644
--- a/games/tetrinet/Makefile
+++ b/games/tetrinet/Makefile
@@ -9,6 +9,7 @@ MASTER_SITES= http://tetrinet.or.cz/download/
MAINTAINER= johans@FreeBSD.org
COMMENT= Console tetrinet client
+USES= ncurses
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DHAVE_IPV6 -fno-builtin-log"
PLIST_FILES= bin/tetrinet bin/tetrinet-server
diff --git a/games/tetrinet/files/patch-Makefile b/games/tetrinet/files/patch-Makefile
new file mode 100644
index 00000000000..b35be95c44d
--- /dev/null
+++ b/games/tetrinet/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2003-10-05 18:39:24 UTC
++++ Makefile
+@@ -30,7 +30,7 @@ binonly:
+ ########
+
+ tetrinet: $(OBJS)
+- $(CC) -o $@ $(OBJS) -lncurses
++ $(CC) -o $@ $(OBJS) $(LDFLAGS) -lncurses
+
+ tetrinet-server: server.c sockets.c tetrinet.c tetris.c server.h sockets.h tetrinet.h tetris.h
+ $(CC) $(CFLAGS) -o $@ -DSERVER_ONLY server.c sockets.c tetrinet.c tetris.c