aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-11-28 11:09:27 +0800
committeryuri <yuri@FreeBSD.org>2017-11-28 11:09:27 +0800
commit808cb0fb18ab3089e9c8ed2b0c364dd78ee36947 (patch)
treefcb170564f0c06d8c2dccb65f1e8697b9edac632 /graphics
parent9abd8355636cf453f5a70543b3d5cce59fee6f4e (diff)
downloadfreebsd-ports-graphics-808cb0fb18ab3089e9c8ed2b0c364dd78ee36947.tar.gz
freebsd-ports-graphics-808cb0fb18ab3089e9c8ed2b0c364dd78ee36947.tar.zst
freebsd-ports-graphics-808cb0fb18ab3089e9c8ed2b0c364dd78ee36947.zip
New port: graphics/py-gizeh: Simple vector graphics in Python
Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13263
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-gizeh/Makefile22
-rw-r--r--graphics/py-gizeh/distinfo3
-rw-r--r--graphics/py-gizeh/pkg-descr5
4 files changed, 31 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index d5574218cf9..cc49e2f6190 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -862,6 +862,7 @@
SUBDIR += py-gd
SUBDIR += py-gdal
SUBDIR += py-gimp
+ SUBDIR += py-gizeh
SUBDIR += py-glewpy
SUBDIR += py-goocanvas
SUBDIR += py-gphoto2
diff --git a/graphics/py-gizeh/Makefile b/graphics/py-gizeh/Makefile
new file mode 100644
index 00000000000..18eda196cec
--- /dev/null
+++ b/graphics/py-gizeh/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= gizeh
+DISTVERSION= 0.1.10
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Simple vector graphics in Python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENCE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairocffi>0:graphics/py-cairocffi \
+ ${PYNUMPY}
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-gizeh/distinfo b/graphics/py-gizeh/distinfo
new file mode 100644
index 00000000000..f23c11da676
--- /dev/null
+++ b/graphics/py-gizeh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1511749579
+SHA256 (gizeh-0.1.10.tar.gz) = 495780b00020ecb9bd70cf81461d131174020abdc3bf7447ccf137ea081a06ac
+SIZE (gizeh-0.1.10.tar.gz) = 16393
diff --git a/graphics/py-gizeh/pkg-descr b/graphics/py-gizeh/pkg-descr
new file mode 100644
index 00000000000..af1fbf3c1e4
--- /dev/null
+++ b/graphics/py-gizeh/pkg-descr
@@ -0,0 +1,5 @@
+Cairo graphics made easy for use from the Python language.
+You can draw beautiful vector graphics consisting of gradient-filled
+circles, ellipses, polygons.
+
+WWW: https://github.com/Zulko/gizeh