aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-02-12 14:19:14 +0800
committertcberner <tcberner@FreeBSD.org>2018-02-12 14:19:14 +0800
commit93fafb059707bcfda17fbe2a06868b47b3d3d05e (patch)
tree61f1ae23c9c4db6ed67cc0ca2cfa0b18ffd099d6 /graphics
parent9c787da601ac6270df75e85fb2ff87d8479abfbf (diff)
downloadfreebsd-ports-graphics-93fafb059707bcfda17fbe2a06868b47b3d3d05e.tar.gz
freebsd-ports-graphics-93fafb059707bcfda17fbe2a06868b47b3d3d05e.tar.zst
freebsd-ports-graphics-93fafb059707bcfda17fbe2a06868b47b3d3d05e.zip
Update graphics/osgearth to 2.9
PR: 225790 Submitted by: lbartoletti <lbartoletti@tuxfamily.org> (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/osgearth/Makefile14
-rw-r--r--graphics/osgearth/distinfo6
-rw-r--r--graphics/osgearth/files/patch-src_osgEarth_Endian16
-rw-r--r--graphics/osgearth/pkg-plist264
4 files changed, 160 insertions, 140 deletions
diff --git a/graphics/osgearth/Makefile b/graphics/osgearth/Makefile
index 1619cb25be7..fdfeece5e8c 100644
--- a/graphics/osgearth/Makefile
+++ b/graphics/osgearth/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= osgearth
-PORTVERSION= 2.8
+PORTVERSION= 2.9
DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= graphics geography
@@ -12,10 +12,14 @@ COMMENT= C++ terrain rendering toolkit for OpenSceneGraph
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BUILD_DEPENDS= minizip:archivers/minizip
LIB_DEPENDS= libosg.so:graphics/osg \
libgdal.so:graphics/gdal \
- libcurl.so:ftp/curl
+ libcurl.so:ftp/curl \
+ libgeos.so:graphics/geos \
+ libleveldb.so:databases/leveldb \
+ libPocoUtil.so:devel/poco \
+ libprotoc.so:devel/protobuf \
+ librocksdb.so:databases/rocksdb
USES= cmake pkgconfig sqlite
@@ -27,9 +31,7 @@ USE_GL+= gl glu
PLIST_SUB= OSGVERSION=3.4.0
CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH:PATH=${LOCALBASE}/include \
- -DMINIZIP_INCLUDE_DIR=${LOCALBASE}/include/minizip \
-DCMAKE_LIBRARY_PATH:PATH=${LOCALBASE}/lib \
- -DLIB_POSTFIX:STRING="" \
- -DOSGEARTH_USE_QT:BOOL=FALSE
+ -DLIB_POSTFIX:STRING=""
.include <bsd.port.mk>
diff --git a/graphics/osgearth/distinfo b/graphics/osgearth/distinfo
index 1f58281ddf0..dae737a1444 100644
--- a/graphics/osgearth/distinfo
+++ b/graphics/osgearth/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1503080754
-SHA256 (gwaldron-osgearth-osgearth-2.8_GH0.tar.gz) = 78120338ead2976018cc877e93342403bafe1b032f2f8b7de3915ba6c5c2486a
-SIZE (gwaldron-osgearth-osgearth-2.8_GH0.tar.gz) = 77472117
+TIMESTAMP = 1518100553
+SHA256 (gwaldron-osgearth-osgearth-2.9_GH0.tar.gz) = 22aeef42bb700c1e669d9ba57ce4155c0668caf86cc738750a6b9d34c1eaf2a4
+SIZE (gwaldron-osgearth-osgearth-2.9_GH0.tar.gz) = 85149312
diff --git a/graphics/osgearth/files/patch-src_osgEarth_Endian b/graphics/osgearth/files/patch-src_osgEarth_Endian
new file mode 100644
index 00000000000..995db50fae7
--- /dev/null
+++ b/graphics/osgearth/files/patch-src_osgEarth_Endian
@@ -0,0 +1,16 @@
+--- src/osgEarth/Endian.orig 2018-02-08 18:33:50 UTC
++++ src/osgEarth/Endian
+@@ -62,11 +62,11 @@
+ # define __LITTLE_ENDIAN LITTLE_ENDIAN
+ # define __PDP_ENDIAN PDP_ENDIAN
+
+-#elif defined(__OpenBSD__)
++#elif defined(__OpenBSD__) || defined(__FreeBSD__)
+
+ # include <sys/endian.h>
+
+-#elif defined(__NetBSD__) || defined(__FreeBSD__) || defined(__DragonFly__)
++#elif defined(__NetBSD__) || defined(__DragonFly__)
+
+ # include <sys/endian.h>
+
diff --git a/graphics/osgearth/pkg-plist b/graphics/osgearth/pkg-plist
index 67d2bfbf30a..f16ab9037f0 100644
--- a/graphics/osgearth/pkg-plist
+++ b/graphics/osgearth/pkg-plist
@@ -1,47 +1,45 @@
+bin/osgEarth_tests
bin/osgearth_3pv
bin/osgearth_annotation
bin/osgearth_atlas
-bin/osgearth_backfill
bin/osgearth_boundarygen
bin/osgearth_cache
bin/osgearth_cache_test
bin/osgearth_city
-bin/osgearth_clamp
bin/osgearth_clipplane
bin/osgearth_colorfilter
bin/osgearth_computerangecallback
bin/osgearth_controls
bin/osgearth_conv
-bin/osgearth_createtile
bin/osgearth_datetime
-bin/osgearth_deformation
bin/osgearth_elevation
bin/osgearth_ephemeris
-bin/osgearth_featureeditor
bin/osgearth_featurefilter
bin/osgearth_featureinfo
bin/osgearth_featurequery
bin/osgearth_features
-bin/osgearth_fog
bin/osgearth_graticule
bin/osgearth_horizon
+bin/osgearth_htm
bin/osgearth_http
bin/osgearth_imageoverlay
+bin/osgearth_infinitescroll
+bin/osgearth_lights
bin/osgearth_los
bin/osgearth_manip
bin/osgearth_map
bin/osgearth_measure
bin/osgearth_minimap
bin/osgearth_mrt
+bin/osgearth_noisegen
bin/osgearth_occlusionculling
bin/osgearth_overlayviewer
bin/osgearth_package
-bin/osgearth_pagingtest
bin/osgearth_pick
bin/osgearth_sequencecontrol
+bin/osgearth_server
bin/osgearth_shadercomp
bin/osgearth_shadergen
-bin/osgearth_sharedlayer
bin/osgearth_skyview
bin/osgearth_splat
bin/osgearth_srstest
@@ -53,11 +51,9 @@ bin/osgearth_toc
bin/osgearth_tracks
bin/osgearth_transform
bin/osgearth_version
+bin/osgearth_video
bin/osgearth_viewer
bin/osgearth_wfs
-bin/osgearth_xfbtest
-include/osgEarth/AlphaEffect
-include/osgEarth/AutoScale
include/osgEarth/Bounds
include/osgEarth/Cache
include/osgEarth/CacheBin
@@ -78,37 +74,42 @@ include/osgEarth/CullingUtils
include/osgEarth/DateTime
include/osgEarth/DateTimeRange
include/osgEarth/DepthOffset
-include/osgEarth/DPLineSegmentIntersector
include/osgEarth/DrapeableNode
include/osgEarth/DrapingCullSet
include/osgEarth/DrapingTechnique
include/osgEarth/DrawInstanced
include/osgEarth/ECEF
-include/osgEarth/ElevationLayer
include/osgEarth/ElevationLOD
+include/osgEarth/ElevationLayer
+include/osgEarth/ElevationPool
include/osgEarth/ElevationQuery
+include/osgEarth/Endian
include/osgEarth/Export
include/osgEarth/Extension
include/osgEarth/FadeEffect
include/osgEarth/FileUtils
+include/osgEarth/GLSLChunker
include/osgEarth/GeoCommon
include/osgEarth/GeoData
-include/osgEarth/Geoid
include/osgEarth/GeoMath
-include/osgEarth/GeometryClamper
include/osgEarth/GeoTransform
-include/osgEarth/GLSLChunker
+include/osgEarth/Geoid
+include/osgEarth/GeometryClamper
+include/osgEarth/HTTPClient
include/osgEarth/HeightFieldUtils
include/osgEarth/Horizon
-include/osgEarth/HTTPClient
+include/osgEarth/IOTypes
include/osgEarth/ImageLayer
include/osgEarth/ImageMosaic
include/osgEarth/ImageToHeightFieldConverter
include/osgEarth/ImageUtils
include/osgEarth/IntersectionPicker
-include/osgEarth/IOTypes
include/osgEarth/JsonUtils
+include/osgEarth/LandCover
+include/osgEarth/LandCoverLayer
include/osgEarth/Layer
+include/osgEarth/LayerListener
+include/osgEarth/Lighting
include/osgEarth/LineFunctor
include/osgEarth/LocalTangentPlane
include/osgEarth/Locators
@@ -126,34 +127,38 @@ include/osgEarth/MaskNode
include/osgEarth/MaskSource
include/osgEarth/MemCache
include/osgEarth/Memory
+include/osgEarth/MetaTile
+include/osgEarth/Metrics
include/osgEarth/ModelLayer
include/osgEarth/ModelSource
include/osgEarth/NativeProgramAdapter
include/osgEarth/NodeUtils
include/osgEarth/Notify
include/osgEarth/ObjectIndex
-include/osgEarth/optional
include/osgEarth/OverlayDecorator
-include/osgEarth/OverlayNode
+include/osgEarth/PagedNode
+include/osgEarth/PatchLayer
include/osgEarth/PhongLightingEffect
include/osgEarth/Picker
+include/osgEarth/PluginLoader
include/osgEarth/PrimitiveIntersector
include/osgEarth/Profile
include/osgEarth/Profiler
include/osgEarth/Progress
-include/osgEarth/QuadTree
include/osgEarth/Random
include/osgEarth/Registry
include/osgEarth/ResourceReleaser
include/osgEarth/Revisioning
+include/osgEarth/SceneGraphCallback
include/osgEarth/ScreenSpaceLayout
include/osgEarth/ShaderFactory
include/osgEarth/ShaderGenerator
include/osgEarth/ShaderLoader
-include/osgEarth/Shaders
include/osgEarth/ShaderUtils
+include/osgEarth/Shaders
include/osgEarth/Shadowing
include/osgEarth/SharedSARepo
+include/osgEarth/SimplexNoise
include/osgEarth/SpatialReference
include/osgEarth/StateSetCache
include/osgEarth/StateSetLOD
@@ -166,33 +171,37 @@ include/osgEarth/TerrainEngineNode
include/osgEarth/TerrainEngineRequirements
include/osgEarth/TerrainLayer
include/osgEarth/TerrainOptions
+include/osgEarth/TerrainResources
include/osgEarth/TerrainTileModel
include/osgEarth/TerrainTileModelFactory
include/osgEarth/TerrainTileNode
include/osgEarth/Tessellator
-include/osgEarth/TextureCompositor
include/osgEarth/ThreadingUtils
include/osgEarth/TileHandler
include/osgEarth/TileKey
include/osgEarth/TileKeyDataStore
-include/osgEarth/TilePatchCallback
+include/osgEarth/TileRasterizer
include/osgEarth/TileSource
include/osgEarth/TileVisitor
include/osgEarth/TimeControl
-include/osgEarth/tinystr.h
-include/osgEarth/tinyxml.h
include/osgEarth/TraversalData
-include/osgEarth/Units
include/osgEarth/URI
+include/osgEarth/Units
include/osgEarth/Utils
include/osgEarth/Version
include/osgEarth/VerticalDatum
+include/osgEarth/VideoLayer
include/osgEarth/Viewpoint
include/osgEarth/VirtualProgram
+include/osgEarth/VisibleLayer
+include/osgEarth/WrapperLayer
include/osgEarth/XmlUtils
+include/osgEarth/optional
+include/osgEarth/tinystr.h
+include/osgEarth/tinyxml.h
include/osgEarthAnnotation/AnnotationData
include/osgEarthAnnotation/AnnotationEditing
-include/osgEarthAnnotation/AnnotationExtension
+include/osgEarthAnnotation/AnnotationLayer
include/osgEarthAnnotation/AnnotationNode
include/osgEarthAnnotation/AnnotationRegistry
include/osgEarthAnnotation/AnnotationSettings
@@ -200,7 +209,6 @@ include/osgEarthAnnotation/AnnotationUtils
include/osgEarthAnnotation/BboxDrawable
include/osgEarthAnnotation/CircleNode
include/osgEarthAnnotation/Common
-include/osgEarthAnnotation/Decoration
include/osgEarthAnnotation/Draggers
include/osgEarthAnnotation/EllipseNode
include/osgEarthAnnotation/Export
@@ -208,7 +216,6 @@ include/osgEarthAnnotation/FeatureEditing
include/osgEarthAnnotation/FeatureNode
include/osgEarthAnnotation/GeoPositionNode
include/osgEarthAnnotation/GeoPositionNodeAutoScaler
-include/osgEarthAnnotation/HighlightDecoration
include/osgEarthAnnotation/ImageOverlay
include/osgEarthAnnotation/ImageOverlayEditor
include/osgEarthAnnotation/LabelNode
@@ -216,16 +223,15 @@ include/osgEarthAnnotation/LocalGeometryNode
include/osgEarthAnnotation/ModelNode
include/osgEarthAnnotation/PlaceNode
include/osgEarthAnnotation/RectangleNode
-include/osgEarthAnnotation/ScaleDecoration
include/osgEarthAnnotation/TrackNode
include/osgEarthDrivers/agglite/AGGLiteOptions
include/osgEarthDrivers/arcgis/ArcGISOptions
include/osgEarthDrivers/bing/BingOptions
include/osgEarthDrivers/cache_filesystem/FileSystemCache
+include/osgEarthDrivers/cache_leveldb/LevelDBCacheOptions
+include/osgEarthDrivers/cache_rocksdb/RocksDBCacheOptions
+include/osgEarthDrivers/colorramp/ColorRampOptions
include/osgEarthDrivers/debug/DebugOptions
-include/osgEarthDrivers/engine_byo/BYOTerrainEngineNode
-include/osgEarthDrivers/engine_byo/BYOTerrainEngineOptions
-include/osgEarthDrivers/engine_byo/Common
include/osgEarthDrivers/engine_mp/Common
include/osgEarthDrivers/engine_mp/DynamicLODScaleCallback
include/osgEarthDrivers/engine_mp/FileLocationCallback
@@ -245,28 +251,35 @@ include/osgEarthDrivers/engine_mp/TileNode
include/osgEarthDrivers/engine_mp/TileNodeRegistry
include/osgEarthDrivers/engine_mp/TilePagedLOD
include/osgEarthDrivers/engine_rex/Common
+include/osgEarthDrivers/engine_rex/DrawState
+include/osgEarthDrivers/engine_rex/DrawTileCommand
include/osgEarthDrivers/engine_rex/EngineContext
include/osgEarthDrivers/engine_rex/GeometryPool
-include/osgEarthDrivers/engine_rex/Loader
+include/osgEarthDrivers/engine_rex/LayerDrawable
include/osgEarthDrivers/engine_rex/LoadTileData
+include/osgEarthDrivers/engine_rex/Loader
include/osgEarthDrivers/engine_rex/MaskGenerator
-include/osgEarthDrivers/engine_rex/MPTexture
include/osgEarthDrivers/engine_rex/RenderBindings
include/osgEarthDrivers/engine_rex/RexTerrainEngineNode
include/osgEarthDrivers/engine_rex/RexTerrainEngineOptions
include/osgEarthDrivers/engine_rex/SelectionInfo
include/osgEarthDrivers/engine_rex/Shaders
include/osgEarthDrivers/engine_rex/SurfaceNode
+include/osgEarthDrivers/engine_rex/TerrainCuller
+include/osgEarthDrivers/engine_rex/TerrainRenderData
include/osgEarthDrivers/engine_rex/TileDrawable
include/osgEarthDrivers/engine_rex/TileNode
include/osgEarthDrivers/engine_rex/TileNodeRegistry
+include/osgEarthDrivers/engine_rex/TileRenderModel
include/osgEarthDrivers/engine_rex/Unloader
include/osgEarthDrivers/feature_elevation/FeatureElevationOptions
+include/osgEarthDrivers/feature_mapnikvectortiles/MVTFeatureOptions
include/osgEarthDrivers/feature_ogr/FeatureCursorOGR
include/osgEarthDrivers/feature_ogr/OGRFeatureOptions
include/osgEarthDrivers/feature_raster/RasterFeatureOptions
include/osgEarthDrivers/feature_tfs/TFSFeatureOptions
include/osgEarthDrivers/feature_wfs/WFSFeatureOptions
+include/osgEarthDrivers/feature_xyz/XYZFeatureOptions
include/osgEarthDrivers/featurefilter_intersect/IntersectFeatureFilterOptions
include/osgEarthDrivers/featurefilter_join/JoinFeatureFilterOptions
include/osgEarthDrivers/gdal/GDALOptions
@@ -277,29 +290,21 @@ include/osgEarthDrivers/mbtiles/MBTilesOptions
include/osgEarthDrivers/model_feature_geom/FeatureGeomModelOptions
include/osgEarthDrivers/model_simple/SimpleModelOptions
include/osgEarthDrivers/ocean_simple/SimpleOceanOptions
-include/osgEarthDrivers/osg/ColorRampOptions
include/osgEarthDrivers/osg/OSGOptions
-include/osgEarthDrivers/quadkey/QuadKeyOptions
-include/osgEarthDrivers/refresh/RefreshOptions
-include/osgEarthDrivers/scriptengine_javascript/duk_config.h
-include/osgEarthDrivers/scriptengine_javascript/duktape.h
include/osgEarthDrivers/scriptengine_javascript/DuktapeEngine
include/osgEarthDrivers/scriptengine_javascript/JSGeometry
+include/osgEarthDrivers/scriptengine_javascript/duk_config.h
+include/osgEarthDrivers/scriptengine_javascript/duktape.h
include/osgEarthDrivers/sky_gl/GLSkyOptions
include/osgEarthDrivers/sky_simple/SimpleSkyOptions
include/osgEarthDrivers/skyview/SkyViewOptions
-include/osgEarthDrivers/splat_mask/SplatMaskOptions
-include/osgEarthDrivers/template_matclass/TemplateMatClassOptions
-include/osgEarthDrivers/tilecache/TileCacheOptions
include/osgEarthDrivers/tileindex/TileIndexOptions
-include/osgEarthDrivers/tileservice/TileServiceOptions
include/osgEarthDrivers/tms/TMSOptions
include/osgEarthDrivers/vpb/VPBOptions
include/osgEarthDrivers/wcs/WCSOptions
include/osgEarthDrivers/wms/TileService
include/osgEarthDrivers/wms/WMSOptions
include/osgEarthDrivers/xyz/XYZOptions
-include/osgEarthDrivers/yahoo/YahooOptions
include/osgEarthFeatures/AltitudeFilter
include/osgEarthFeatures/BufferFilter
include/osgEarthFeatures/BuildGeometryFilter
@@ -312,22 +317,24 @@ include/osgEarthFeatures/ExtrudeGeometryFilter
include/osgEarthFeatures/Feature
include/osgEarthFeatures/FeatureCursor
include/osgEarthFeatures/FeatureDisplayLayout
-include/osgEarthFeatures/FeatureDrawSet
include/osgEarthFeatures/FeatureIndex
include/osgEarthFeatures/FeatureListSource
+include/osgEarthFeatures/FeatureMaskLayer
include/osgEarthFeatures/FeatureModelGraph
+include/osgEarthFeatures/FeatureModelLayer
include/osgEarthFeatures/FeatureModelSource
include/osgEarthFeatures/FeatureSource
include/osgEarthFeatures/FeatureSourceIndexNode
+include/osgEarthFeatures/FeatureSourceLayer
include/osgEarthFeatures/FeatureTileSource
include/osgEarthFeatures/Filter
include/osgEarthFeatures/FilterContext
+include/osgEarthFeatures/GPULines
include/osgEarthFeatures/GeometryCompiler
include/osgEarthFeatures/GeometryUtils
include/osgEarthFeatures/LabelSource
include/osgEarthFeatures/MVT
include/osgEarthFeatures/OgrUtils
-include/osgEarthFeatures/OptimizerHints
include/osgEarthFeatures/PolygonizeLines
include/osgEarthFeatures/ResampleFilter
include/osgEarthFeatures/ScaleFilter
@@ -336,6 +343,7 @@ include/osgEarthFeatures/Script
include/osgEarthFeatures/ScriptEngine
include/osgEarthFeatures/ScriptFilter
include/osgEarthFeatures/Session
+include/osgEarthFeatures/Shaders
include/osgEarthFeatures/SubstituteModelFilter
include/osgEarthFeatures/TessellateOperator
include/osgEarthFeatures/TextSymbolizer
@@ -343,17 +351,16 @@ include/osgEarthFeatures/TransformFilter
include/osgEarthFeatures/VirtualFeatureSource
include/osgEarthSplat/Coverage
include/osgEarthSplat/Export
-include/osgEarthSplat/LandCover
-include/osgEarthSplat/LandCoverTerrainEffect
-include/osgEarthSplat/LandCoverTilePatchCallback
+include/osgEarthSplat/GroundCover
+include/osgEarthSplat/GroundCoverLayer
include/osgEarthSplat/LandUseTileSource
include/osgEarthSplat/NoiseTextureFactory
+include/osgEarthSplat/RoadSurfaceLayer
include/osgEarthSplat/SplatCatalog
include/osgEarthSplat/SplatCoverageLegend
-include/osgEarthSplat/SplatExtension
+include/osgEarthSplat/SplatLayer
include/osgEarthSplat/SplatOptions
include/osgEarthSplat/SplatShaders
-include/osgEarthSplat/SplatTerrainEffect
include/osgEarthSplat/Surface
include/osgEarthSplat/Zone
include/osgEarthSymbology/AGG.h
@@ -368,10 +375,10 @@ include/osgEarthSymbology/CssUtils
include/osgEarthSymbology/Expression
include/osgEarthSymbology/ExtrusionSymbol
include/osgEarthSymbology/Fill
+include/osgEarthSymbology/GEOS
include/osgEarthSymbology/Geometry
include/osgEarthSymbology/GeometryFactory
include/osgEarthSymbology/GeometryRasterizer
-include/osgEarthSymbology/GEOS
include/osgEarthSymbology/IconResource
include/osgEarthSymbology/IconSymbol
include/osgEarthSymbology/InstanceResource
@@ -406,9 +413,9 @@ include/osgEarthUtil/ArcGIS
include/osgEarthUtil/AtlasBuilder
include/osgEarthUtil/AutoClipPlaneHandler
include/osgEarthUtil/BrightnessContrastColorFilter
+include/osgEarthUtil/CMYKColorFilter
include/osgEarthUtil/ChromaKeyColorFilter
include/osgEarthUtil/ClampCallback
-include/osgEarthUtil/CMYKColorFilter
include/osgEarthUtil/Common
include/osgEarthUtil/ContourMap
include/osgEarthUtil/Controls
@@ -417,123 +424,118 @@ include/osgEarthUtil/EarthManipulator
include/osgEarthUtil/Ephemeris
include/osgEarthUtil/ExampleResources
include/osgEarthUtil/Export
-include/osgEarthUtil/FeatureQueryTool
+include/osgEarthUtil/FlatteningLayer
include/osgEarthUtil/Fog
include/osgEarthUtil/Formatter
+include/osgEarthUtil/FractalElevationLayer
+include/osgEarthUtil/GARSGraticule
+include/osgEarthUtil/GLSLColorFilter
include/osgEarthUtil/GammaColorFilter
include/osgEarthUtil/GeodeticGraticule
-include/osgEarthUtil/GLSLColorFilter
-include/osgEarthUtil/GraticuleExtension
-include/osgEarthUtil/GraticuleNode
-include/osgEarthUtil/GraticuleOptions
-include/osgEarthUtil/GraticuleTerrainEffect
include/osgEarthUtil/HSLColorFilter
include/osgEarthUtil/HTM
+include/osgEarthUtil/LODBlending
include/osgEarthUtil/LatLongFormatter
-include/osgEarthUtil/LinearLineOfSight
include/osgEarthUtil/LineOfSight
-include/osgEarthUtil/LODBlending
+include/osgEarthUtil/LinearLineOfSight
include/osgEarthUtil/LogarithmicDepthBuffer
-include/osgEarthUtil/MeasureTool
include/osgEarthUtil/MGRSFormatter
include/osgEarthUtil/MGRSGraticule
+include/osgEarthUtil/MeasureTool
include/osgEarthUtil/MouseCoordsTool
+include/osgEarthUtil/MultiElevationLayer
include/osgEarthUtil/NightColorFilter
-include/osgEarthUtil/ObjectLocator
include/osgEarthUtil/Ocean
include/osgEarthUtil/PolyhedralLineOfSight
-include/osgEarthUtil/RadialLineOfSight
include/osgEarthUtil/RGBColorFilter
include/osgEarthUtil/RTTPicker
+include/osgEarthUtil/RadialLineOfSight
include/osgEarthUtil/Shaders
include/osgEarthUtil/Shadowing
+include/osgEarthUtil/SimpleOceanLayer
include/osgEarthUtil/SimplePager
-include/osgEarthUtil/SimplexNoise
include/osgEarthUtil/Sky
include/osgEarthUtil/SpatialData
include/osgEarthUtil/StarData
-include/osgEarthUtil/TerrainProfile
include/osgEarthUtil/TFS
include/osgEarthUtil/TFSPackager
-include/osgEarthUtil/TileIndex
-include/osgEarthUtil/TileIndexBuilder
include/osgEarthUtil/TMS
include/osgEarthUtil/TMSBackFiller
include/osgEarthUtil/TMSPackager
+include/osgEarthUtil/TerrainProfile
+include/osgEarthUtil/TileIndex
+include/osgEarthUtil/TileIndexBuilder
+include/osgEarthUtil/TopologyGraph
include/osgEarthUtil/UTMGraticule
+include/osgEarthUtil/UTMLabelingEngine
include/osgEarthUtil/VerticalScale
+include/osgEarthUtil/ViewFitter
include/osgEarthUtil/WFS
include/osgEarthUtil/WMS
lib/libosgEarth.so
lib/libosgEarth.so.0
-lib/libosgEarth.so.2.8.0
+lib/libosgEarth.so.2.9.0
lib/libosgEarthAnnotation.so
lib/libosgEarthAnnotation.so.0
-lib/libosgEarthAnnotation.so.2.8.0
+lib/libosgEarthAnnotation.so.2.9.0
lib/libosgEarthFeatures.so
lib/libosgEarthFeatures.so.0
-lib/libosgEarthFeatures.so.2.8.0
+lib/libosgEarthFeatures.so.2.9.0
lib/libosgEarthSplat.so
lib/libosgEarthSplat.so.0
-lib/libosgEarthSplat.so.2.8.0
+lib/libosgEarthSplat.so.2.9.0
lib/libosgEarthSymbology.so
lib/libosgEarthSymbology.so.0
-lib/libosgEarthSymbology.so.2.8.0
+lib/libosgEarthSymbology.so.2.9.0
lib/libosgEarthUtil.so
lib/libosgEarthUtil.so.0
-lib/libosgEarthUtil.so.2.8.0
-lib/osgPlugins-%%OSGVERSION%%/osgdb_earth.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_kml.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_agglite.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_arcgis_map_cache.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_arcgis.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_bing.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_bumpmap.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_cache_filesystem.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_colorramp.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_debug.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_detail.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_engine_byo.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_engine_mp.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_engine_rex.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_elevation.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_ogr.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_raster.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_tfs.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_wfs.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_featurefilter_intersect.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_featurefilter_join.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_gdal.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_label_annotation.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_mapinspector.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_mask_feature.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_mbtiles.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_model_feature_geom.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_model_simple.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_monitor.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_noise.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_ocean_simple.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_osg.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_quadkey.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_refresh.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_scriptengine_javascript.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_sky_gl.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_sky_simple.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_skyview.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_splat_mask.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_template_matclass.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_terrainshader.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_tilecache.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_tileindex.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_tileservice.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_tms.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_vdatum_egm2008.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_vdatum_egm84.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_vdatum_egm96.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_viewpoints.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_vpb.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_wcs.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_wms.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_xyz.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_yahoo.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_template.so
+lib/libosgEarthUtil.so.2.9.0
+lib/osgdb_earth.so
+lib/osgdb_kml.so
+lib/osgdb_osgearth_agglite.so
+lib/osgdb_osgearth_arcgis.so
+lib/osgdb_osgearth_bing.so
+lib/osgdb_osgearth_bumpmap.so
+lib/osgdb_osgearth_cache_filesystem.so
+lib/osgdb_osgearth_cache_leveldb.so
+lib/osgdb_osgearth_cache_rocksdb.so
+lib/osgdb_osgearth_colorramp.so
+lib/osgdb_osgearth_debug.so
+lib/osgdb_osgearth_detail.so
+lib/osgdb_osgearth_engine_mp.so
+lib/osgdb_osgearth_engine_rex.so
+lib/osgdb_osgearth_feature_elevation.so
+lib/osgdb_osgearth_feature_mapnikvectortiles.so
+lib/osgdb_osgearth_feature_ogr.so
+lib/osgdb_osgearth_feature_raster.so
+lib/osgdb_osgearth_feature_tfs.so
+lib/osgdb_osgearth_feature_wfs.so
+lib/osgdb_osgearth_feature_xyz.so
+lib/osgdb_osgearth_featurefilter_intersect.so
+lib/osgdb_osgearth_featurefilter_join.so
+lib/osgdb_osgearth_gdal.so
+lib/osgdb_osgearth_label_annotation.so
+lib/osgdb_osgearth_mapinspector.so
+lib/osgdb_osgearth_mask_feature.so
+lib/osgdb_osgearth_mbtiles.so
+lib/osgdb_osgearth_model_feature_geom.so
+lib/osgdb_osgearth_model_simple.so
+lib/osgdb_osgearth_monitor.so
+lib/osgdb_osgearth_ocean_simple.so
+lib/osgdb_osgearth_osg.so
+lib/osgdb_osgearth_scriptengine_javascript.so
+lib/osgdb_osgearth_sky_gl.so
+lib/osgdb_osgearth_sky_simple.so
+lib/osgdb_osgearth_skyview.so
+lib/osgdb_osgearth_terrainshader.so
+lib/osgdb_osgearth_tileindex.so
+lib/osgdb_osgearth_tms.so
+lib/osgdb_osgearth_vdatum_egm2008.so
+lib/osgdb_osgearth_vdatum_egm84.so
+lib/osgdb_osgearth_vdatum_egm96.so
+lib/osgdb_osgearth_viewpoints.so
+lib/osgdb_osgearth_vpb.so
+lib/osgdb_osgearth_wcs.so
+lib/osgdb_osgearth_wms.so
+lib/osgdb_osgearth_xyz.so
+lib/osgdb_template.so