aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2018-05-27 01:14:20 +0800
committermiwi <miwi@FreeBSD.org>2018-05-27 01:14:20 +0800
commitbbde7a70fd1a7e3b54401f100611861847d147ab (patch)
tree54e046a9101d8cda1cd7fb662041756f31eb0607 /graphics
parent07b43306b4082d00bdb6b04bb44048506ed4cb89 (diff)
downloadfreebsd-ports-graphics-bbde7a70fd1a7e3b54401f100611861847d147ab.tar.gz
freebsd-ports-graphics-bbde7a70fd1a7e3b54401f100611861847d147ab.tar.zst
freebsd-ports-graphics-bbde7a70fd1a7e3b54401f100611861847d147ab.zip
- Update to 12.4.1
- Changed RUN_DEPENDS (assign to Django 1.11) - Added LICENSE_FILE - Added NO_ARCH - Added DOCS option with the appropriate dependencies - Changed options to reflect the new possibilities with the pluggable engines and key value stores - Updated pkg-descr PR: 228309 Submitted by: freebsd_ports@k-worx.org Approved by: maintainer Sponsored by: iXsystems Inc.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-sorl-thumbnail/Makefile60
-rw-r--r--graphics/py-sorl-thumbnail/distinfo5
-rw-r--r--graphics/py-sorl-thumbnail/files/patch-docs_conf.py17
-rw-r--r--graphics/py-sorl-thumbnail/pkg-descr18
4 files changed, 69 insertions, 31 deletions
diff --git a/graphics/py-sorl-thumbnail/Makefile b/graphics/py-sorl-thumbnail/Makefile
index 705103840e6..38a845a5972 100644
--- a/graphics/py-sorl-thumbnail/Makefile
+++ b/graphics/py-sorl-thumbnail/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= sorl-thumbnail
-PORTVERSION= 3.2.5
-PORTREVISION= 6
+PORTVERSION= 12.4.1
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,33 +11,42 @@ MAINTAINER= ports@caomhin.org
COMMENT= Sorl-thumbnail provides an easy way to generate image thumbnails
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django111>=1.8:www/py-django111@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist distutils
-
-DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}@${FLAVOR}
-
-OPTIONS_DEFINE= DJANGO PDF WORD
-DJANGO_DESC= Enable Django
-PDF_DESC= PDF Thumbnails
-WORD_DESC= Word Document thumbnail handling
-
-OPTIONS_DEFAULT= DJANGO
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDJANGO}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/django/bin/django-admin.py:www/py-django18@${FLAVOR}
-.endif
-
-.if ${PORT_OPTIONS:MPDF}
-RUN_DEPENDS+= ${LOCALBASE}/bin/Magick-config:graphics/ImageMagick
-.endif
-
-.if ${PORT_OPTIONS:MWORD}
-RUN_DEPENDS+= wvVersion:textproc/wv
-.endif
+NO_ARCH= yes
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT= IMAGEMAGICK
+OPTIONS_SINGLE= IMAGELIB
+OPTIONS_GROUP= CACHING
+
+OPTIONS_SINGLE_IMAGELIB= GRAPHICSMAGICK IMAGEMAGICK PILLOW WAND
+OPTIONS_GROUP_CACHING= REDIS
+
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR}
+DOCS_VARS= PYDISTUTILS_BUILD_TARGET+="build_sphinx -a -E"
+
+GRAPHICSMAGICK_RUN_DEPENDS= ${LOCALBASE}/bin/gm:graphics/GraphicsMagick
+IMAGEMAGICK_RUN_DEPENDS= ${LOCALBASE}/bin/convert:graphics/ImageMagick
+PILLOW_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+REDIS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}redis>0:databases/py-redis@${PY_FLAVOR}
+WAND_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Wand>0:graphics/py-wand@${PY_FLAVOR}
+
+GRAPHICSMAGICK_DESC= Use GraphicsMagick for image processing (faster)
+IMAGEMAGICK_DESC= Use ImageMagick for image processing
+PILLOW_DESC= Use internal image processing
+REDIS_DESC= Use REDIS as Key Value Store
+WAND_DESC= Use Wand with ImageMagick
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/build/sphinx/html && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} \
+ "! -name .buildinfo -and ! -name objects.inv")
.include <bsd.port.mk>
diff --git a/graphics/py-sorl-thumbnail/distinfo b/graphics/py-sorl-thumbnail/distinfo
index a1946674bfe..96e71fbecb1 100644
--- a/graphics/py-sorl-thumbnail/distinfo
+++ b/graphics/py-sorl-thumbnail/distinfo
@@ -1,2 +1,3 @@
-SHA256 (sorl-thumbnail-3.2.5.tar.gz) = 8f0378cc08bed75a7e86fc44847e652378d1951af452a47976d2eca8b8276968
-SIZE (sorl-thumbnail-3.2.5.tar.gz) = 19622
+TIMESTAMP = 1526248144
+SHA256 (sorl-thumbnail-12.4.1.tar.gz) = 1cc6d913fe4f1224e479f25a23ec2ad3ca71c3154919a2c9463b07e7fbe11ac2
+SIZE (sorl-thumbnail-12.4.1.tar.gz) = 533008
diff --git a/graphics/py-sorl-thumbnail/files/patch-docs_conf.py b/graphics/py-sorl-thumbnail/files/patch-docs_conf.py
new file mode 100644
index 00000000000..737f09c375c
--- /dev/null
+++ b/graphics/py-sorl-thumbnail/files/patch-docs_conf.py
@@ -0,0 +1,17 @@
+--- docs/conf.py.orig 2017-11-21 00:08:00 UTC
++++ docs/conf.py
+@@ -15,10 +15,13 @@ import os
+ import sphinx
+ import sys
+
++if sys.version_info < (3,):
++ range = xrange
++
+ sys.path.insert(0, os.path.pardir)
+ import sorl
+
+-for j in xrange(0, len(sphinx.__version__)):
++for j in range(0, len(sphinx.__version__)):
+ try:
+ version = float(sphinx.__version__[:-j])
+ break
diff --git a/graphics/py-sorl-thumbnail/pkg-descr b/graphics/py-sorl-thumbnail/pkg-descr
index 3ff228ce9db..ca0800f625d 100644
--- a/graphics/py-sorl-thumbnail/pkg-descr
+++ b/graphics/py-sorl-thumbnail/pkg-descr
@@ -1,6 +1,18 @@
The sorl-thumbnail package provides an easy way to generate image
thumbnails.
-Although not required to use, sorl-thumbnail is heavily integrated with
-the Django framework.
-WWW: http://code.google.com/p/sorl-thumbnail/
+Some of its features:
+- Storage support
+- Pluggable Engine support for Pillow, GraphicsMagick, ImageMagick and Wand
+- Pluggable Key Value Store support (cached db and redis)
+- Pluggable Backend support
+- Admin integration with possibility to delete
+- Dummy generation (placeholders)
+- Flexible, simple syntax, generates no html
+- ImageField for model that deletes thumbnails
+- CSS style cropping options
+- Back smart cropping, and remove borders from the images when cropping
+- Margin calculation for vertical positioning
+- Alternative resolutions versions of a thumbnail
+
+WWW: https://github.com/jazzband/sorl-thumbnail