aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
committermat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
commit60e51bda11dcc0742419f2a459990d0d81cb07d8 (patch)
treea5029ff30555b3a7ee0621f4dd5aacb832fde1d8 /irc
parent3432585b4743642027fc2b3af5eac2780fc2c4cd (diff)
downloadfreebsd-ports-graphics-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.gz
freebsd-ports-graphics-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.zst
freebsd-ports-graphics-60e51bda11dcc0742419f2a459990d0d81cb07d8.zip
Use USES=pathfix where applicable.
PR: 213195 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D8093
Diffstat (limited to 'irc')
-rw-r--r--irc/ctrlproxy/Makefile3
-rw-r--r--irc/ctrlproxy/files/patch-Makefile21
-rw-r--r--irc/znc/Makefile5
3 files changed, 8 insertions, 21 deletions
diff --git a/irc/ctrlproxy/Makefile b/irc/ctrlproxy/Makefile
index 75a9af4be23..edc8e4c2852 100644
--- a/irc/ctrlproxy/Makefile
+++ b/irc/ctrlproxy/Makefile
@@ -16,7 +16,8 @@ LIB_DEPENDS= libgnutls.so:security/gnutls
USE_GNOME= glib20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USES= pkgconfig gmake
+USES= gmake pathfix pkgconfig
+PATHFIX_MAKEFILEIN= Makefile
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/irc/ctrlproxy/files/patch-Makefile b/irc/ctrlproxy/files/patch-Makefile
index ea05159aad6..1ad87530599 100644
--- a/irc/ctrlproxy/files/patch-Makefile
+++ b/irc/ctrlproxy/files/patch-Makefile
@@ -1,7 +1,7 @@
---- Makefile.orig Sun Apr 15 14:17:58 2007
-+++ Makefile Sat Jun 16 12:00:33 2007
-@@ -108,7 +108,7 @@
- ctrlproxy.pc Makefile.settings: configure Makefile.settings.in ctrlproxy.pc.in
+--- Makefile.orig 2008-12-06 17:36:33 UTC
++++ Makefile
+@@ -145,7 +145,7 @@ endif
+ ctrlproxy.pc Makefile.settings config.h: configure Makefile.settings.in ctrlproxy.pc.in
./$<
-install: all install-dirs install-bin install-header install-data install-pkgconfig $(EXTRA_INSTALL_TARGETS)
@@ -9,7 +9,7 @@
install-dirs:
$(INSTALL) -d $(DESTDIR)$(modulesdir)
-@@ -133,7 +133,6 @@
+@@ -177,7 +177,6 @@ doc::
install-doc:: doc
$(INSTALL) -d $(DESTDIR)$(docdir)
@@ -17,14 +17,3 @@
uninstall-doc:
$(MAKE) -C doc uninstall
-@@ -156,8 +154,8 @@
- $(INSTALL) -m 0644 config.admin $(DESTDIR)$(DEFAULT_CONFIG_DIR)/networks/admin
-
- install-pkgconfig:
-- $(INSTALL) -d $(DESTDIR)$(libdir)/pkgconfig
-- $(INSTALL) -m 0644 ctrlproxy.pc $(DESTDIR)$(libdir)/pkgconfig
-+ $(INSTALL) -d $(DESTDIR)$(prefix)/libdata/pkgconfig
-+ $(INSTALL) -m 0644 ctrlproxy.pc $(DESTDIR)$(prefix)/libdata/pkgconfig
-
- uninstall-pkgconfig:
- -rm -f $(DESTDIR)$(libdir)/pkgconfig/ctrlproxy.pc
diff --git a/irc/znc/Makefile b/irc/znc/Makefile
index c10e20418d8..6d7aa0afb3e 100644
--- a/irc/znc/Makefile
+++ b/irc/znc/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
GNU_CONFIGURE= yes
USE_RC_SUBR= znc
-USES= compiler:c++11-lib cpe gmake iconv pkgconfig
+USES= compiler:c++11-lib cpe gmake iconv pathfix pkgconfig
MAKE_ENV= V=1
PORTDOCS= README.md
@@ -66,9 +66,6 @@ pre-configure-PYTHON-on:
post-patch:
@${REINPLACE_CMD} -e \
- 's#$$(libdir)/pkgconfig#${PREFIX}/libdata/pkgconfig#' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e \
's#/usr/local#${LOCALBASE}#' ${WRKSRC}/configure
post-install-DOCS-on: