aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2017-10-26 07:01:36 +0800
committerolgeni <olgeni@FreeBSD.org>2017-10-26 07:01:36 +0800
commit65a4a4162431572eb6a4171903cd41d4dd12557a (patch)
tree1a114544ddbcc80c086b468834d4c233700072d1 /java
parente5bdca3f4e9df53c2b83ea928b190cb1db23c5d1 (diff)
downloadfreebsd-ports-graphics-65a4a4162431572eb6a4171903cd41d4dd12557a.tar.gz
freebsd-ports-graphics-65a4a4162431572eb6a4171903cd41d4dd12557a.tar.zst
freebsd-ports-graphics-65a4a4162431572eb6a4171903cd41d4dd12557a.zip
java/wildfly90: add support for status command and remove pidfile on
shutdown (see r452897).
Diffstat (limited to 'java')
-rw-r--r--java/wildfly90/Makefile1
-rw-r--r--java/wildfly90/files/wildfly90.in4
2 files changed, 5 insertions, 0 deletions
diff --git a/java/wildfly90/Makefile b/java/wildfly90/Makefile
index 89371818925..421a029ea35 100644
--- a/java/wildfly90/Makefile
+++ b/java/wildfly90/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wildfly90
PORTVERSION= 9.0.2
+PORTREVISION= 1
CATEGORIES= java www
MASTER_SITES= http://download.jboss.org/wildfly/${WILDFLY_VERSION}/
DISTNAME= wildfly-${WILDFLY_VERSION}
diff --git a/java/wildfly90/files/wildfly90.in b/java/wildfly90/files/wildfly90.in
index aac767ae97a..bb4ae95e94f 100644
--- a/java/wildfly90/files/wildfly90.in
+++ b/java/wildfly90/files/wildfly90.in
@@ -38,6 +38,7 @@ load_rc_config $name
start_cmd="%%APP_SHORTNAME%%_start"
stop_cmd="%%APP_SHORTNAME%%_stop"
pidfile="%%PID_FILE%%"
+status_cmd="%%APP_SHORTNAME%%_status"
WILDFLY_HOME="%%APP_HOME%%"
#minimal requirements must be set for our javavmwrapper
@@ -51,6 +52,8 @@ export JAVA_VERSION
install -d -o ${%%APP_SHORTNAME%%_user} ${%%APP_SHORTNAME%%_logdir}
fi
+ echo "%%APP_SHORTNAME%%: making sure all writeable dirs belong to proper user/group"
+ chown -R ${%%APP_SHORTNAME%%_user}:${%%APP_SHORTNAME%%_group} ${WILDFLY_HOME}/standalone
echo "Starting %%APP_SHORTNAME%%."
daemon -u ${%%APP_SHORTNAME%%_user} ${WILDFLY_HOME}/bin/standalone.sh ${%%APP_SHORTNAME%%_args} >> ${%%APP_SHORTNAME%%_log_stdout} 2>> ${%%APP_SHORTNAME%%_log_stderr}
@@ -78,6 +81,7 @@ export JAVA_VERSION
sleep ${%%APP_SHORTNAME%%_sleep}
killall ${%%APP_SHORTNAME%%_additional_killall}
fi
+ rm ${pidfile}
fi
}