aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2018-02-22 00:24:53 +0800
committerantoine <antoine@FreeBSD.org>2018-02-22 00:24:53 +0800
commit5db4aaba05347a1df94b5a44e9e3e4d42304b97f (patch)
treeb63cd55e9deac0f11169f04c64d04dd84d68b3b5 /lang
parent7e75acadde63bfc67e55335cd507c6d574875787 (diff)
downloadfreebsd-ports-graphics-5db4aaba05347a1df94b5a44e9e3e4d42304b97f.tar.gz
freebsd-ports-graphics-5db4aaba05347a1df94b5a44e9e3e4d42304b97f.tar.zst
freebsd-ports-graphics-5db4aaba05347a1df94b5a44e9e3e4d42304b97f.zip
Remove dependency on the python metaport
PR: 225752 Submitted by: Yasuhiro KIMURA
Diffstat (limited to 'lang')
-rw-r--r--lang/phantomjs/Makefile4
-rw-r--r--lang/swift/Makefile6
2 files changed, 5 insertions, 5 deletions
diff --git a/lang/phantomjs/Makefile b/lang/phantomjs/Makefile
index c13cbe8ba40..d2e3084e2b2 100644
--- a/lang/phantomjs/Makefile
+++ b/lang/phantomjs/Makefile
@@ -15,8 +15,7 @@ BROKEN_sparc64= does not link on sparc64
NOT_FOR_ARCHS= armv6 armv7
NOT_FOR_ARCHS_REASON= Platform.h: Not supported ARM architecture
-BUILD_DEPENDS= bash:shells/bash \
- python:lang/python
+BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig \
libicui18n.so:devel/icu \
@@ -34,6 +33,7 @@ GH_TUPLE= Vitallium:phantomjs-3rdparty-win:19051aa:msvc2013/src/qt/3rdparty \
RUBY_NO_RUN_DEPENDS= yes
PLIST_FILES= bin/phantomjs
NO_CCACHE= yes
+BINARY_ALIAS= python=${PYTHON_CMD}
OPTIONS_DEFINE= X11
X11_USE= XORG=x11
diff --git a/lang/swift/Makefile b/lang/swift/Makefile
index dd9c5796e1b..4b3ec61a4a0 100644
--- a/lang/swift/Makefile
+++ b/lang/swift/Makefile
@@ -16,7 +16,6 @@ LICENSE_FILE= ${WRKSRC}/swift/LICENSE.txt
BUILD_DEPENDS= cmake:devel/cmake \
bash:shells/bash \
swig3.0:devel/swig30 \
- python:lang/python \
sphinx-build:textproc/py-sphinx \
binutils>=2.25.1:devel/binutils
LIB_DEPENDS= libicudata.so:devel/icu \
@@ -25,7 +24,7 @@ LIB_DEPENDS= libicudata.so:devel/icu \
REL_SNAP= 2017-04-22-a
USE_GITHUB= yes
-BINARY_ALIAS= swig=swig3.0
+BINARY_ALIAS= swig=swig3.0 python=${PYTHON_CMD}
GH_ACCOUNT= apple:DEFAULT,llvm,clang,dispatch,lldb,cmark,llbuild,swiftpm,xctest,xcfound
GH_PROJECT= swift:DEFAULT swift-llvm:llvm swift-clang:clang swift-lldb:lldb \
@@ -39,7 +38,8 @@ GH_SUBDIR= llvm:llvm clang:clang lldb:lldb cmark:cmark llbuild:llbuild \
swift-corelibs-libdispatch:dispatch
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= autoreconf:build compiler:c++14-lang libtool localbase:ldflags iconv libedit ninja perl5 pkgconfig sqlite
+USES= autoreconf:build compiler:c++14-lang libtool localbase:ldflags iconv libedit \
+ ninja perl5 pkgconfig python:build sqlite
USE_GNOME= libxml2
USE_LDCONFIG= yes