aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-11-30 02:46:21 +0800
committermat <mat@FreeBSD.org>2016-11-30 02:46:21 +0800
commita9fb43731f13f4ddbe4e900c6673e591c40399db (patch)
tree81e5478fa11645e21ab75a8faa039b5e6d1918c5 /lang
parent5f6167ba55ac06f0aca86e787e405f1b39aa5d1d (diff)
downloadfreebsd-ports-graphics-a9fb43731f13f4ddbe4e900c6673e591c40399db.tar.gz
freebsd-ports-graphics-a9fb43731f13f4ddbe4e900c6673e591c40399db.tar.zst
freebsd-ports-graphics-a9fb43731f13f4ddbe4e900c6673e591c40399db.zip
Mark some ports as not openssl-devel ready.
Sponsored by: Absolight
Diffstat (limited to 'lang')
-rw-r--r--lang/php56/Makefile.ext4
-rw-r--r--lang/python27/Makefile8
-rw-r--r--lang/python35/Makefile8
-rw-r--r--lang/ruby22/Makefile4
4 files changed, 22 insertions, 2 deletions
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index 41655003897..060cf3093f5 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -527,6 +527,10 @@ USES+= mysql
.include <bsd.port.pre.mk>
+.if ${PHP_MODNAME} == "openssl" && ${SSL_DEFAULT:Mopenssl-devel}
+BROKEN= Does not build with openssl-devel
+.endif
+
.if ${PHP_MODNAME} == "gd"
. if ${PORT_OPTIONS:MT1LIB}
LIB_DEPENDS+= libt1.so:devel/t1lib
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index b6319cd338f..a7b6b0b9dcb 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -125,4 +125,10 @@ post-install:
for i in ${STAGEDIR}${PREFIX}/lib/python2.7/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT:Mopenssl-devel}
+BROKEN= Does not build with openssl-devel
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/python35/Makefile b/lang/python35/Makefile
index 9570c55b270..393f988d234 100644
--- a/lang/python35/Makefile
+++ b/lang/python35/Makefile
@@ -129,4 +129,10 @@ post-install:
for i in ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT:Mopenssl-devel}
+BROKEN= Does not build with openssl-devel
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/ruby22/Makefile b/lang/ruby22/Makefile
index b0c376a8af4..6a837ce8876 100644
--- a/lang/ruby22/Makefile
+++ b/lang/ruby22/Makefile
@@ -79,6 +79,10 @@ CPE_UPDATE= p${RUBY_PATCHLEVEL}
.include <bsd.port.pre.mk>
+.if ${SSL_DEFAULT:Mopenssl-devel}
+BROKEN= Does not build with openssl-devel
+.endif
+
# PORTEPOCH/PORTREVISION hack
.if ${PORTEPOCH} != 0