aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mboxgrep/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-11-02 17:04:20 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-11-02 17:04:20 +0800
commitc6a33f28778e713d9d29784e1a252f70be796ba3 (patch)
tree24bdf4818b9c4ab3066c667182282c05f7aa8c63 /mail/mboxgrep/Makefile
parenta615c654c14635ff2b9d69f4fc5dfa25715fed99 (diff)
downloadfreebsd-ports-graphics-c6a33f28778e713d9d29784e1a252f70be796ba3.tar.gz
freebsd-ports-graphics-c6a33f28778e713d9d29784e1a252f70be796ba3.tar.zst
freebsd-ports-graphics-c6a33f28778e713d9d29784e1a252f70be796ba3.zip
- Add LICENSE
- Switch to USES=localbase - Switch to options helpers
Diffstat (limited to 'mail/mboxgrep/Makefile')
-rw-r--r--mail/mboxgrep/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/mail/mboxgrep/Makefile b/mail/mboxgrep/Makefile
index ea4d26b4b88..5df20188fbc 100644
--- a/mail/mboxgrep/Makefile
+++ b/mail/mboxgrep/Makefile
@@ -10,15 +10,20 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Utility to scan mailboxes for messages matching a regular expression
-USES= ssl
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= localbase ssl
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
+
CFLAGS+= -I${OPENSSLINC}
-LIBS+= -L${OPENSSLLIB} -L${LOCALBASE}/lib
+LIBS+= -L${OPENSSLLIB}
INFO= mboxgrep
-DOCS= ChangeLog NEWS README TODO
+PORTDOCS= ChangeLog NEWS README TODO
+PLIST_FILES= bin/mboxgrep \
+ man/man1/mboxgrep.1.gz
OPTIONS_DEFINE= DOCS PCRE
@@ -31,9 +36,9 @@ post-patch:
-e 's,$$(infodir),$$(DESTDIR)$$(infodir),g' \
${WRKSRC}/src/Makefile.in ${WRKSRC}/doc/Makefile.in
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in ${DOCS}
+.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor