aboutsummaryrefslogtreecommitdiffstats
path: root/mail/sendmail811/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2001-05-29 12:14:05 +0800
committerdinoex <dinoex@FreeBSD.org>2001-05-29 12:14:05 +0800
commit03277ae013aee17071bf908bd8e9407372c3d623 (patch)
treee3de1da27dedeae73e5e522d199043c24f8ca631 /mail/sendmail811/Makefile
parentfb81c56ec8cab626d08a314989ab911f5ab8d42c (diff)
downloadfreebsd-ports-graphics-03277ae013aee17071bf908bd8e9407372c3d623.tar.gz
freebsd-ports-graphics-03277ae013aee17071bf908bd8e9407372c3d623.tar.zst
freebsd-ports-graphics-03277ae013aee17071bf908bd8e9407372c3d623.zip
- Update to Sendmail 8.11.4, possible race condition.
- Added PKGNAMESUFFIX - removed patch for IPV6, fixed in Release
Diffstat (limited to 'mail/sendmail811/Makefile')
-rw-r--r--mail/sendmail811/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/mail/sendmail811/Makefile b/mail/sendmail811/Makefile
index 1dd194ef72c..8bb135a1bf2 100644
--- a/mail/sendmail811/Makefile
+++ b/mail/sendmail811/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sendmail
-PORTVERSION= 8.11.3
+PORTVERSION= 8.11.4
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.sendmail.org/pub/sendmail/
DISTNAME= ${PORTNAME}.${PORTVERSION}
@@ -31,16 +31,20 @@ PLIST= ${WRKDIR}/.PLIST.more
.if defined(SENDMAIL_WITH_TLS)
USE_OPENSSL= yes
+PKGNAMESUFFIX= -tls
.endif
.if defined(SENDMAIL_WITH_SASL)
LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
+PKGNAMESUFFIX= -sasl
.endif
.if defined(SENDMAIL_WITH_SFIO)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsfio.a:${PORTSDIR}/devel/sfio
+PKGNAMESUFFIX= -sfio
.endif
.if defined(SENDMAIL_WITH_LDAP)
LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2
LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap2
+PKGNAMESUFFIX= -ldap
.endif
.if exists(${DESTDIR}/etc/mail/mailer.conf)