aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-11-30 02:46:21 +0800
committermat <mat@FreeBSD.org>2016-11-30 02:46:21 +0800
commita9fb43731f13f4ddbe4e900c6673e591c40399db (patch)
tree81e5478fa11645e21ab75a8faa039b5e6d1918c5 /mail
parent5f6167ba55ac06f0aca86e787e405f1b39aa5d1d (diff)
downloadfreebsd-ports-graphics-a9fb43731f13f4ddbe4e900c6673e591c40399db.tar.gz
freebsd-ports-graphics-a9fb43731f13f4ddbe4e900c6673e591c40399db.tar.zst
freebsd-ports-graphics-a9fb43731f13f4ddbe4e900c6673e591c40399db.zip
Mark some ports as not openssl-devel ready.
Sponsored by: Absolight
Diffstat (limited to 'mail')
-rw-r--r--mail/alpine/Makefile4
-rw-r--r--mail/fetchmail/Makefile8
-rw-r--r--mail/libesmtp/Makefile8
-rw-r--r--mail/panda-cclient/Makefile4
-rw-r--r--mail/spamd/Makefile4
5 files changed, 26 insertions, 2 deletions
diff --git a/mail/alpine/Makefile b/mail/alpine/Makefile
index f55347eb815..0a4069a0360 100644
--- a/mail/alpine/Makefile
+++ b/mail/alpine/Makefile
@@ -77,6 +77,10 @@ USE_OPENSSL= no
.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MSSL} && ${SSL_DEFAULT:Mopenssl-devel}
+BROKEN= Does not build with openssl-devel
+.endif
+
THREADS_CONFIGURE_WITH= pthread
MOUSE_CONFIGURE_ENABLE= mouse
NLS_CONFIGURE_ENABLE= nls
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 962fcb7d499..bb1da69b150 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -92,4 +92,10 @@ post-install-X11-off:
${INSTALL_SCRIPT} ${WRKDIR}/fetchmailconf ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/fetchmailconf.py ${STAGEDIR}${PREFIX}/libexec
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT:Mopenssl-devel}
+BROKEN= Does not build with openssl-devel
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/libesmtp/Makefile b/mail/libesmtp/Makefile
index dd3aa5cb7f6..21fadf29b49 100644
--- a/mail/libesmtp/Makefile
+++ b/mail/libesmtp/Makefile
@@ -41,4 +41,10 @@ post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MOPENSSL} && ${SSL_DEFAULT:Mopenssl-devel}
+BROKEN= Does not build with openssl-devel
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/panda-cclient/Makefile b/mail/panda-cclient/Makefile
index c69db209beb..8af8d8a3022 100644
--- a/mail/panda-cclient/Makefile
+++ b/mail/panda-cclient/Makefile
@@ -35,6 +35,10 @@ PKGMESSAGE= pkg-message-ssl
.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MSSL} && ${SSL_DEFAULT:Mopenssl-devel}
+BROKEN= Does not build with openssl-devel
+.endif
+
USE_LDCONFIG= yes
ALL_TARGET= bsf
.if ! ${PORT_OPTIONS:MSSL}
diff --git a/mail/spamd/Makefile b/mail/spamd/Makefile
index 8ffd128c723..ca21753f12a 100644
--- a/mail/spamd/Makefile
+++ b/mail/spamd/Makefile
@@ -53,6 +53,10 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
+.if ${SSL_DEFAULT:Mopenssl-devel}
+BROKEN= Does not build with openssl-devel
+.endif
+
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}