aboutsummaryrefslogtreecommitdiffstats
path: root/math/tomsfastmath
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-06-19 08:12:03 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-06-19 08:12:03 +0800
commit95e87d91c7aaa05162b54cea2dd46286ff2a29b3 (patch)
treeda0dcacd3b8b6a6390cb35a39756bad9a9d3df15 /math/tomsfastmath
parent55e19a37c9a6024c8f732ec1a1025958aa88a0a8 (diff)
downloadfreebsd-ports-graphics-95e87d91c7aaa05162b54cea2dd46286ff2a29b3.tar.gz
freebsd-ports-graphics-95e87d91c7aaa05162b54cea2dd46286ff2a29b3.tar.zst
freebsd-ports-graphics-95e87d91c7aaa05162b54cea2dd46286ff2a29b3.zip
- Fix build on i386
MFH: 2015Q2
Diffstat (limited to 'math/tomsfastmath')
-rw-r--r--math/tomsfastmath/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/math/tomsfastmath/Makefile b/math/tomsfastmath/Makefile
index 2e699fab7b2..fdaf45f3b73 100644
--- a/math/tomsfastmath/Makefile
+++ b/math/tomsfastmath/Makefile
@@ -11,13 +11,21 @@ COMMENT= Portable fixed precision math library for fast exponentiations
BROKEN_powerpc= internal compiler error at src/mul/fp_mul_comba_48.c:398
-USES= gmake tar:bzip2
+USES= compiler:features gmake tar:bzip2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= makefile
ALL_TARGET= default
PLIST_FILES= include/tfm.h lib/libtfm.a
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == i386
+# on clang:
+# src/mul/fp_mul_comba.c:349:11: error: inline assembly requires more registers than available
+USE_GCC= yes
+.endif
+
# Unbreak against Clang ("cc" is not a register)
post-patch:
@${REINPLACE_CMD} -e 's,"%cc","cc",' \
@@ -25,4 +33,4 @@ post-patch:
${WRKSRC}/src/mul/fp_mul_comba.c \
${WRKSRC}/src/sqr/fp_sqr_comba.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>