aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2017-06-21 23:09:44 +0800
committermatthew <matthew@FreeBSD.org>2017-06-21 23:09:44 +0800
commit25a0b80a9e7b97c603eef781d20397aa5d0ce247 (patch)
treed50a02af57f07a2423d17a3afeed417cc392df01 /misc
parent117e0610cd2257c4a46f8c9eedf2893eb0e636c2 (diff)
downloadfreebsd-ports-graphics-25a0b80a9e7b97c603eef781d20397aa5d0ce247.tar.gz
freebsd-ports-graphics-25a0b80a9e7b97c603eef781d20397aa5d0ce247.tar.zst
freebsd-ports-graphics-25a0b80a9e7b97c603eef781d20397aa5d0ce247.zip
This is a rewrite of the popular tool unclutter, but using the x11-xfixes
extension. This means that this rewrite doesn't use fake windows or pointer grabbing and hence causes less problems with window managers and/or applications. WWW: https://github.com/Airblader/unclutter-xfixes PR: 210302 Submitted by: Oleg Gushchenkov <gor@clogic.com.ua> Differential Revision: https://reviews.freebsd.org/D6785
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/unclutter-xfixes/Makefile34
-rw-r--r--misc/unclutter-xfixes/distinfo3
-rw-r--r--misc/unclutter-xfixes/files/patch-Makefile32
-rw-r--r--misc/unclutter-xfixes/pkg-descr6
5 files changed, 76 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index b932823a605..267a74b745e 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -476,6 +476,7 @@
SUBDIR += uk-postcodes
SUBDIR += umodunpack
SUBDIR += unclutter
+ SUBDIR += unclutter-xfixes
SUBDIR += upclient
SUBDIR += us-zipcodes
SUBDIR += usbids
diff --git a/misc/unclutter-xfixes/Makefile b/misc/unclutter-xfixes/Makefile
new file mode 100644
index 00000000000..20e815ce734
--- /dev/null
+++ b/misc/unclutter-xfixes/Makefile
@@ -0,0 +1,34 @@
+# Created by: Oleg Gushchenkov <gor@clogic.com.ua>
+# $FreeBSD$
+
+PORTNAME= unclutter-xfixes
+PORTVERSION= 1.1
+DISTVERSIONPREFIX= v
+CATEGORIES= misc
+
+MAINTAINER= gor@clogic.com.ua
+COMMENT= Rewrite of unclutter using the x11-xfixes extension
+
+LICENSE= MIT
+
+BUILD_DEPENDS= a2x:textproc/asciidoc
+LIB_DEPENDS= libev.so:devel/libev
+
+CONFLICTS_INSTALL= unclutter-8*
+
+CFLAGS+= -I${LOCALBASE}/include
+
+USE_GITHUB= yes
+GH_ACCOUNT= Airblader
+
+USE_XORG= x11 xi xfixes
+
+USES= gmake pkgconfig
+
+PLIST_FILES= bin/unclutter \
+ man/man1/unclutter.1.gz
+
+MAKE_ENV+= UNCLUTTER_VERSION=${PORTVERSION}
+MAKE_ARGS= CC=${CC}
+
+.include <bsd.port.mk>
diff --git a/misc/unclutter-xfixes/distinfo b/misc/unclutter-xfixes/distinfo
new file mode 100644
index 00000000000..b6da102e49d
--- /dev/null
+++ b/misc/unclutter-xfixes/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1465305813
+SHA256 (Airblader-unclutter-xfixes-v1.1_GH0.tar.gz) = 91635c64a2075cb4e8926d84c09931c957e5f1d824a249cddb7ec109378090ad
+SIZE (Airblader-unclutter-xfixes-v1.1_GH0.tar.gz) = 5812
diff --git a/misc/unclutter-xfixes/files/patch-Makefile b/misc/unclutter-xfixes/files/patch-Makefile
new file mode 100644
index 00000000000..23dbb621eba
--- /dev/null
+++ b/misc/unclutter-xfixes/files/patch-Makefile
@@ -0,0 +1,32 @@
+Index: Makefile
+===================================================================
+--- Makefile.orig 2016-05-16 09:27:55 UTC
++++ Makefile
+@@ -4,9 +4,9 @@ IDIR = include
+ ODIR = obj
+
+ INSTALL = install
+-PREFIX = /usr/bin
+
+-MANDIR = /usr/share/man/man1
++BINDIR = /bin
++MANDIR = /man/man1
+
+ CC = gcc
+ CFLAGS += -I$(IDIR)
+@@ -32,12 +32,12 @@ $(TARGET): $(OBJS)
+ $(CC) $(CFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
+
+ $(ODIR)/%.o: $(SDIR)/%.c $(INCS)
+- $(CC) -D'__VERSION="$(shell git describe --all --long --always)"' $(CFLAGS) -o $@ -c $<
++ $(CC) -D'__VERSION="$(UNCLUTTER_VERSION)"' $(CFLAGS) -o $@ -c $<
+
+ .PHONY: install
+ install: $(TARGET)
+- $(INSTALL) -Dm 0755 $(TARGET) $(DESTDIR)$(PREFIX)/$(TARGET)
+- $(INSTALL) -Dm 0644 man/unclutter-xfixes.1 $(DESTDIR)$(MANDIR)/unclutter.1
++ $(BSD_INSTALL_PROGRAM) $(TARGET) $(DESTDIR)$(PREFIX)$(BINDIR)/$(TARGET)
++ $(BSD_INSTALL_MAN) man/unclutter-xfixes.1 $(DESTDIR)$(PREFIX)$(MANDIR)/$(TARGET).1
+
+ .PHONY: uninstall
+ uninstall:
diff --git a/misc/unclutter-xfixes/pkg-descr b/misc/unclutter-xfixes/pkg-descr
new file mode 100644
index 00000000000..05315001b40
--- /dev/null
+++ b/misc/unclutter-xfixes/pkg-descr
@@ -0,0 +1,6 @@
+This is a rewrite of the popular tool unclutter, but using the x11-xfixes
+extension. This means that this rewrite doesn't use fake windows or
+pointer grabbing and hence causes less problems with window managers
+and/or applications.
+
+WWW: https://github.com/Airblader/unclutter-xfixes