aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-02-09 17:12:48 +0800
committerjbeich <jbeich@FreeBSD.org>2018-02-09 17:12:48 +0800
commit5af7e2ec4c5698bb7edaf8573c1b802d0292c68e (patch)
treec4bc97969afa7cc34b3f9cac4821001e3d6718f1 /misc
parentbb87b278c804c69b1d617a8e56b56f270463c152 (diff)
downloadfreebsd-ports-graphics-5af7e2ec4c5698bb7edaf8573c1b802d0292c68e.tar.gz
freebsd-ports-graphics-5af7e2ec4c5698bb7edaf8573c1b802d0292c68e.tar.zst
freebsd-ports-graphics-5af7e2ec4c5698bb7edaf8573c1b802d0292c68e.zip
devel/icu: drop C++98 compatibility workarounds
Now that both USE_GCC and -CURRENT default to C++14 there's little reason to complicate maintenance. Revert r449685 to usher consumers into post-C++11 world. PR: 222433 222434 222435
Diffstat (limited to 'misc')
-rw-r--r--misc/sword/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index f7679b21a18..a5801afb07a 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sword
PORTVERSION= 1.7.4
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= misc
MASTER_SITES= ftp://ftp.crosswire.org/pub/sword/source/v${PORTVERSION:R}/ \
http://crosswire.org/ftpmirror/pub/sword/source/v${PORTVERSION:R}/
@@ -45,6 +45,8 @@ CONFIGURE_ARGS+= --without-curl
.endif
.if ${PORT_OPTIONS:MCLUCENE}
+USES+= compiler:c++11-lib
+USE_CXXSTD= gnu++11
LIB_DEPENDS+= libclucene-core.so:textproc/clucene \
libicudata.so:devel/icu
CONFIGURE_ARGS+= --with-clucene=${LOCALBASE} --with-icu