aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-06-27 14:11:11 +0800
committermarcus <marcus@FreeBSD.org>2004-06-27 14:11:11 +0800
commit466090afce1b52a88dca1938d26dcb35fc5d886e (patch)
treed3b837a1d656ec194d3b6194cedbc88df07926b3 /multimedia
parentbab43481d32c4e3e2a6e79c8a39ae95ad754cdb2 (diff)
downloadfreebsd-ports-graphics-466090afce1b52a88dca1938d26dcb35fc5d886e.tar.gz
freebsd-ports-graphics-466090afce1b52a88dca1938d26dcb35fc5d886e.tar.zst
freebsd-ports-graphics-466090afce1b52a88dca1938d26dcb35fc5d886e.zip
Update to 0.8.2, and add support for the DTS decoder. The full list of changes
in this version can be found at http://gstreamer.freedesktop.org/releases/gst-plugins/0.8.2.html Approved by: maintainer (implicit)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer-plugins/Makefile22
-rw-r--r--multimedia/gstreamer-plugins/distinfo4
-rw-r--r--multimedia/gstreamer-plugins/files/patch-configure17
-rw-r--r--multimedia/gstreamer-plugins/files/patch-ext_gnomevfs_gstgnomevfssink.c11
-rw-r--r--multimedia/gstreamer-plugins/files/patch-ext_vorbis_vorbisparse.c23
-rw-r--r--multimedia/gstreamer-plugins/files/patch-gst_ffmpegcolorspace_gstffmpegcolorspace.c11
-rw-r--r--multimedia/gstreamer-plugins/files/patch-gst_tcp_gsttcpclientsrc.h11
-rw-r--r--multimedia/gstreamer-plugins/files/patch-sys_oss_gstosselement.c25
-rw-r--r--multimedia/gstreamer-plugins/files/patch-sys_ximage_ximagesink.h10
-rw-r--r--multimedia/gstreamer-plugins/files/patch-sys_xvimage_xvimagesink.h10
-rw-r--r--multimedia/gstreamer-plugins/pkg-plist25
-rw-r--r--multimedia/gstreamer-plugins80/Makefile22
-rw-r--r--multimedia/gstreamer-plugins80/distinfo4
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-configure17
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-ext_gnomevfs_gstgnomevfssink.c11
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-ext_vorbis_vorbisparse.c23
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-gst_ffmpegcolorspace_gstffmpegcolorspace.c11
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-gst_tcp_gsttcpclientsrc.h11
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-sys_oss_gstosselement.c25
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-sys_ximage_ximagesink.h10
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-sys_xvimage_xvimagesink.h10
-rw-r--r--multimedia/gstreamer-plugins80/pkg-plist25
22 files changed, 144 insertions, 194 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index e15b0f6b448..c38577efdb8 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.8.1
-PORTREVISION= 2
+PORTVERSION= 0.8.2
CATEGORIES= multimedia audio
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://gstreamer.freedesktop.org/src/gst-plugins/
@@ -142,6 +141,11 @@ WITH_ARTS=yes
WITH_CDPARANOIA=yes
.endif
+# dts
+.if exists(${LOCALBASE}/lib/libdts_pic.a)
+WITH_DTS=yes
+.endif
+
# esound
.if (${HAVE_GNOME:Mesound}!="")
WITH_ESOUND=yes
@@ -384,6 +388,16 @@ LIB_DEPENDS+= cdda_interface.0:${PORTSDIR}/audio/cdparanoia
PLIST_SUB+= CDPARANOIA=""
.endif
+# dts
+.ifndef(WITH_DTS)
+CONFIGURE_ARGS+= --disable-dts
+PLIST_SUB+= DTS="@comment "
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libdts_pic.a:${PORTSDIR}/multimedia/libdts
+RUN_DEPENDS+= ${LOCALBASE}/lib/libdts_pic.a:${PORTSDIR}/multimedia/libdts
+PLIST_SUB+= DTS=""
+.endif
+
# esound
.ifndef(WITH_ESOUND)
CONFIGURE_ARGS+= --disable-esd \
@@ -817,6 +831,10 @@ pre-everything::
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_CDPARANOIA to enable cdparanoia Audio plugin'
.endif
+.ifndef(WITH_DTS)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_DTS to enable DTS decoding support'
+.endif
.ifndef(WITH_ESOUND)
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_ESOUND to enable esound Audio plugin'
diff --git a/multimedia/gstreamer-plugins/distinfo b/multimedia/gstreamer-plugins/distinfo
index dbd2cea1535..2ab790307c7 100644
--- a/multimedia/gstreamer-plugins/distinfo
+++ b/multimedia/gstreamer-plugins/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gst-plugins-0.8.1.tar.bz2) = c08c21df02857a11875295935d0442a1
-SIZE (gnome2/gst-plugins-0.8.1.tar.bz2) = 1809789
+MD5 (gnome2/gst-plugins-0.8.2.tar.bz2) = 1f46e3aa765659818f309ed5b64c9b88
+SIZE (gnome2/gst-plugins-0.8.2.tar.bz2) = 1978467
diff --git a/multimedia/gstreamer-plugins/files/patch-configure b/multimedia/gstreamer-plugins/files/patch-configure
index e2987f9821a..92b1deb51a6 100644
--- a/multimedia/gstreamer-plugins/files/patch-configure
+++ b/multimedia/gstreamer-plugins/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Tue Mar 16 20:32:36 2004
-+++ configure Tue Mar 16 20:41:00 2004
-@@ -41192,7 +41192,8 @@
+--- configure.orig Wed Jun 23 21:30:24 2004
++++ configure Wed Jun 23 21:30:25 2004
+@@ -46068,7 +46068,8 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
@@ -8,14 +8,5 @@
+#xxx fix the non x case is er niet...
+LIBS="-laudio -lm -lXt $X_LIBS $LIBS"
cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
- /* confdefs.h. */
-@@ -44483,7 +44484,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-ltheora $LIBS"
-+LIBS="-ltheora -logg $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
/* confdefs.h. */
+ _ACEOF
diff --git a/multimedia/gstreamer-plugins/files/patch-ext_gnomevfs_gstgnomevfssink.c b/multimedia/gstreamer-plugins/files/patch-ext_gnomevfs_gstgnomevfssink.c
deleted file mode 100644
index 592acc2e8ce..00000000000
--- a/multimedia/gstreamer-plugins/files/patch-ext_gnomevfs_gstgnomevfssink.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ext/gnomevfs/gstgnomevfssink.c.orig Wed Apr 28 17:16:05 2004
-+++ ext/gnomevfs/gstgnomevfssink.c Wed Apr 28 17:16:20 2004
-@@ -347,7 +347,7 @@
- }
- sink->own_handle = TRUE;
- } else if (!sink->handle) {
-- GST_ELEMENT_ERROR (sink, RESOURCE, FAILED, (_("No filename given")), NULL);
-+ GST_ELEMENT_ERROR (sink, RESOURCE, FAILED, (_("No filename given")), (NULL));
- return FALSE;
- }
-
diff --git a/multimedia/gstreamer-plugins/files/patch-ext_vorbis_vorbisparse.c b/multimedia/gstreamer-plugins/files/patch-ext_vorbis_vorbisparse.c
new file mode 100644
index 00000000000..aeab67f4132
--- /dev/null
+++ b/multimedia/gstreamer-plugins/files/patch-ext_vorbis_vorbisparse.c
@@ -0,0 +1,23 @@
+--- ext/vorbis/vorbisparse.c.orig Wed Jun 23 23:49:17 2004
++++ ext/vorbis/vorbisparse.c Wed Jun 23 23:50:16 2004
+@@ -103,6 +103,9 @@
+ vorbis_parse_set_header_on_caps (GstVorbisParse * parse, GstCaps * caps)
+ {
+ GstBuffer *buf1, *buf2, *buf3;
++ GstStructure *structure;
++ GValue list = { 0 };
++ GValue value = { 0 };
+
+ g_assert (parse);
+ g_assert (parse->streamheader);
+@@ -115,9 +118,7 @@
+ buf3 = parse->streamheader->next->next->data;
+ g_assert (buf3);
+
+- GstStructure *structure = gst_caps_get_structure (caps, 0);
+- GValue list = { 0 };
+- GValue value = { 0 };
++ structure = gst_caps_get_structure (caps, 0);
+
+ /* mark buffers */
+ GST_BUFFER_FLAG_SET (buf1, GST_BUFFER_IN_CAPS);
diff --git a/multimedia/gstreamer-plugins/files/patch-gst_ffmpegcolorspace_gstffmpegcolorspace.c b/multimedia/gstreamer-plugins/files/patch-gst_ffmpegcolorspace_gstffmpegcolorspace.c
deleted file mode 100644
index a6e501c8c66..00000000000
--- a/multimedia/gstreamer-plugins/files/patch-gst_ffmpegcolorspace_gstffmpegcolorspace.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- gst/ffmpegcolorspace/gstffmpegcolorspace.c.orig Wed Apr 28 15:10:45 2004
-+++ gst/ffmpegcolorspace/gstffmpegcolorspace.c Wed Apr 28 15:11:00 2004
-@@ -306,7 +306,7 @@
- g_return_if_fail (GST_IS_FFMPEGCOLORSPACE (space));
-
- if (space->from_pixfmt == PIX_FMT_NB || space->to_pixfmt == PIX_FMT_NB) {
-- GST_ELEMENT_ERROR (space, CORE, NOT_IMPLEMENTED, NULL,
-+ GST_ELEMENT_ERROR (space, CORE, NOT_IMPLEMENTED, (NULL),
- ("attempting to convert colorspaces between unknown formats"));
- gst_buffer_unref (inbuf);
- return;
diff --git a/multimedia/gstreamer-plugins/files/patch-gst_tcp_gsttcpclientsrc.h b/multimedia/gstreamer-plugins/files/patch-gst_tcp_gsttcpclientsrc.h
new file mode 100644
index 00000000000..9d4414eb68d
--- /dev/null
+++ b/multimedia/gstreamer-plugins/files/patch-gst_tcp_gsttcpclientsrc.h
@@ -0,0 +1,11 @@
+--- gst/tcp/gsttcpclientsrc.h.orig Wed Jun 23 23:44:07 2004
++++ gst/tcp/gsttcpclientsrc.h Wed Jun 23 23:44:26 2004
+@@ -29,6 +29,8 @@
+ #endif /* __cplusplus */
+
+ #include <netdb.h> /* sockaddr_in */
++#include <sys/types.h>
++#include <sys/socket.h>
+ #include <netinet/in.h> /* sockaddr_in */
+ #include <unistd.h>
+ #include "gsttcp.h"
diff --git a/multimedia/gstreamer-plugins/files/patch-sys_oss_gstosselement.c b/multimedia/gstreamer-plugins/files/patch-sys_oss_gstosselement.c
deleted file mode 100644
index 3f645e9dfc7..00000000000
--- a/multimedia/gstreamer-plugins/files/patch-sys_oss_gstosselement.c
+++ /dev/null
@@ -1,25 +0,0 @@
-===================================================================
-RCS file: /cvs/gstreamer/gst-plugins/sys/oss/gstosselement.c,v
-retrieving revision 1.35
-retrieving revision 1.36
-diff -u -r1.35 -r1.36
---- sys/oss/gstosselement.c 2004/04/18 20:14:36 1.35
-+++ sys/oss/gstosselement.c 2004/04/29 23:45:03 1.36
-@@ -1168,6 +1168,17 @@
- probe->min = gst_osselement_rate_check_rate (probe, 1000);
- n_checks++;
- probe->max = gst_osselement_rate_check_rate (probe, 100000);
-+ /* a little bug workaround */
-+ {
-+ int max;
-+
-+ max = gst_osselement_rate_check_rate (probe, 48000);
-+ if (max > probe->max) {
-+ GST_ERROR
-+ ("Driver bug recognized (driver does not round rates correctly). Please file a bug report.");
-+ probe->max = max;
-+ }
-+ }
- n_checks++;
- if (probe->min == -1 || probe->max == -1) {
- GST_DEBUG ("unexpected check_rate error");
diff --git a/multimedia/gstreamer-plugins/files/patch-sys_ximage_ximagesink.h b/multimedia/gstreamer-plugins/files/patch-sys_ximage_ximagesink.h
deleted file mode 100644
index 07b125bfee8..00000000000
--- a/multimedia/gstreamer-plugins/files/patch-sys_ximage_ximagesink.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- sys/ximage/ximagesink.h.orig Tue Mar 16 22:51:03 2004
-+++ sys/ximage/ximagesink.h Tue Mar 16 23:06:44 2004
-@@ -23,6 +23,7 @@
- #include <gst/video/videosink.h>
-
- #ifdef HAVE_XSHM
-+#include <sys/types.h>
- #include <sys/ipc.h>
- #include <sys/shm.h>
- #endif /* HAVE_XSHM */
diff --git a/multimedia/gstreamer-plugins/files/patch-sys_xvimage_xvimagesink.h b/multimedia/gstreamer-plugins/files/patch-sys_xvimage_xvimagesink.h
deleted file mode 100644
index ddb0d1f0050..00000000000
--- a/multimedia/gstreamer-plugins/files/patch-sys_xvimage_xvimagesink.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- sys/xvimage/xvimagesink.h.orig Tue Mar 16 22:51:04 2004
-+++ sys/xvimage/xvimagesink.h Tue Mar 16 23:07:39 2004
-@@ -23,6 +23,7 @@
- #include <gst/video/videosink.h>
-
- #ifdef HAVE_XSHM
-+#include <sys/types.h>
- #include <sys/ipc.h>
- #include <sys/shm.h>
- #endif /* HAVE_XSHM */
diff --git a/multimedia/gstreamer-plugins/pkg-plist b/multimedia/gstreamer-plugins/pkg-plist
index 9ac5e4851cb..da2d3a74eeb 100644
--- a/multimedia/gstreamer-plugins/pkg-plist
+++ b/multimedia/gstreamer-plugins/pkg-plist
@@ -1,12 +1,8 @@
bin/gst-launch-ext-%%VERSION%%
bin/gst-visualise-%%VERSION%%
-etc/gconf/gconf.xml.defaults/schemas/system/gstreamer/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/system/gstreamer/%%VERSION%%/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/system/gstreamer/%%VERSION%%/default/%gconf.xml
-etc/gconf/gconf.xml.defaults/system/gstreamer/%gconf.xml
-etc/gconf/gconf.xml.defaults/system/gstreamer/%%VERSION%%/%gconf.xml
-etc/gconf/gconf.xml.defaults/system/gstreamer/%%VERSION%%/default/%gconf.xml
+@unexec GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/gstreamer-%%VERSION%%.schemas > /dev/null || /usr/bin/true
etc/gconf/schemas/gstreamer-%%VERSION%%.schemas
+@exec GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/gstreamer-%%VERSION%%.schemas > /dev/null || /usr/bin/true
include/gstreamer-%%VERSION%%/gst/audio/gstaudiofilter.h
include/gstreamer-%%VERSION%%/gst/audio/audioclock.h
include/gstreamer-%%VERSION%%/gst/audio/audio.h
@@ -19,6 +15,7 @@ include/gstreamer-%%VERSION%%/gst/idct/idct.h
include/gstreamer-%%VERSION%%/gst/media-info/media-info.h
include/gstreamer-%%VERSION%%/gst/mixer/mixer-enumtypes.h
include/gstreamer-%%VERSION%%/gst/mixer/mixer.h
+include/gstreamer-%%VERSION%%/gst/mixer/mixeroptions.h
include/gstreamer-%%VERSION%%/gst/mixer/mixertrack.h
include/gstreamer-%%VERSION%%/gst/navigation/navigation.h
include/gstreamer-%%VERSION%%/gst/play/play-enumtypes.h
@@ -42,10 +39,12 @@ include/gstreamer-%%VERSION%%/gst/xwindowlistener/xwindowlistener.h
lib/gstreamer-%%VERSION%%/libgstac3parse.so
lib/gstreamer-%%VERSION%%/libgstadder.so
lib/gstreamer-%%VERSION%%/libgstalaw.so
+lib/gstreamer-%%VERSION%%/libgstalpha.so
%%ARTS%%lib/gstreamer-%%VERSION%%/libgstartsdsink.so
lib/gstreamer-%%VERSION%%/libgstasf.so
lib/gstreamer-%%VERSION%%/libgstaudioconvert.so
lib/gstreamer-%%VERSION%%/libgstaudiofilter.so
+lib/gstreamer-%%VERSION%%/libgstaudiorate.so
lib/gstreamer-%%VERSION%%/libgstaudio.so
%%LIBAUDIOFILE%%lib/gstreamer-%%VERSION%%/libgstaudiofile.so
lib/gstreamer-%%VERSION%%/libgstaudioscale.so
@@ -60,6 +59,7 @@ lib/gstreamer-%%VERSION%%/libgstchart.so
lib/gstreamer-%%VERSION%%/libgstcutter.so
lib/gstreamer-%%VERSION%%/libgstdebug.so
lib/gstreamer-%%VERSION%%/libgstdeinterlace.so
+%%DTS%%lib/gstreamer-%%VERSION%%/libgstdtsdec.so
%%LIBDV%%lib/gstreamer-%%VERSION%%/libgstdvdec.so
%%LIBDVDNAV%%lib/gstreamer-%%VERSION%%/libgstdvdnavsrc.so
%%LIBDVDREAD%%lib/gstreamer-%%VERSION%%/libgstdvdreadsrc.so
@@ -93,7 +93,6 @@ lib/gstreamer-%%VERSION%%/libgstmatroska.so
lib/gstreamer-%%VERSION%%/libgstmedian.so
%%LIBMIKMOD%%lib/gstreamer-%%VERSION%%/libgstmikmod.so
lib/gstreamer-%%VERSION%%/libgstmixmatrix.so
-lib/gstreamer-%%VERSION%%/libgstmodplug.a
lib/gstreamer-%%VERSION%%/libgstmodplug.so
lib/gstreamer-%%VERSION%%/libgstmonoscope.so
lib/gstreamer-%%VERSION%%/libgstmp1videoparse.so
@@ -104,6 +103,7 @@ lib/gstreamer-%%VERSION%%/libgstmpegaudio.so
lib/gstreamer-%%VERSION%%/libgstmpegaudioparse.so
lib/gstreamer-%%VERSION%%/libgstmpegstream.so
lib/gstreamer-%%VERSION%%/libgstmulaw.so
+lib/gstreamer-%%VERSION%%/libgstmultipart.so
%%NAS%%lib/gstreamer-%%VERSION%%/libgstnassink.so
lib/gstreamer-%%VERSION%%/libgstnavigationtest.so
%%OGG%%lib/gstreamer-%%VERSION%%/libgstogg.so
@@ -147,10 +147,13 @@ lib/gstreamer-%%VERSION%%/libgstudp.so
lib/gstreamer-%%VERSION%%/libgstvbidec.so
lib/gstreamer-%%VERSION%%/libgstvideo.so
lib/gstreamer-%%VERSION%%/libgstvideobalance.so
+lib/gstreamer-%%VERSION%%/libgstvideobox.so
lib/gstreamer-%%VERSION%%/libgstvideocrop.so
lib/gstreamer-%%VERSION%%/libgstvideodrop.so
lib/gstreamer-%%VERSION%%/libgstvideofilter.so
lib/gstreamer-%%VERSION%%/libgstvideoflip.so
+lib/gstreamer-%%VERSION%%/libgstvideomixer.so
+lib/gstreamer-%%VERSION%%/libgstvideorate.so
lib/gstreamer-%%VERSION%%/libgstvideoscale.so
lib/gstreamer-%%VERSION%%/libgstvideotestsrc.so
lib/gstreamer-%%VERSION%%/libgstvolenv.so
@@ -184,9 +187,11 @@ libdata/pkgconfig/gstreamer-play-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-plugins-%%VERSION%%.pc
share/locale/af/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/az/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
+share/locale/en_GB/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/nl/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/sr/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/sv/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
+share/locale/uk/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@unexec rmdir %D/lib/gstreamer-%%VERSION%% 2>/dev/null || true
@dirrm include/gstreamer-%%VERSION%%/gst/xwindowlistener
@dirrm include/gstreamer-%%VERSION%%/gst/xoverlay
@@ -204,12 +209,6 @@ share/locale/sv/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@dirrm include/gstreamer-%%VERSION%%/gst/floatcast
@dirrm include/gstreamer-%%VERSION%%/gst/colorbalance
@dirrm include/gstreamer-%%VERSION%%/gst/audio
-@dirrm etc/gconf/gconf.xml.defaults/system/gstreamer/%%VERSION%%/default
-@dirrm etc/gconf/gconf.xml.defaults/system/gstreamer/%%VERSION%%
-@dirrm etc/gconf/gconf.xml.defaults/system/gstreamer
-@dirrm etc/gconf/gconf.xml.defaults/schemas/system/gstreamer/%%VERSION%%/default
-@dirrm etc/gconf/gconf.xml.defaults/schemas/system/gstreamer/%%VERSION%%
-@dirrm etc/gconf/gconf.xml.defaults/schemas/system/gstreamer
@unexec rmdir %D/include/gstreamer-%%VERSION%%/gst 2>/dev/null || true
@unexec rmdir %D/include/gstreamer-%%VERSION%% 2>/dev/null || true
@exec %%X11BASE%%/bin/gst-register-%%VERSION%% 2>/dev/null || true
diff --git a/multimedia/gstreamer-plugins80/Makefile b/multimedia/gstreamer-plugins80/Makefile
index e15b0f6b448..c38577efdb8 100644
--- a/multimedia/gstreamer-plugins80/Makefile
+++ b/multimedia/gstreamer-plugins80/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.8.1
-PORTREVISION= 2
+PORTVERSION= 0.8.2
CATEGORIES= multimedia audio
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://gstreamer.freedesktop.org/src/gst-plugins/
@@ -142,6 +141,11 @@ WITH_ARTS=yes
WITH_CDPARANOIA=yes
.endif
+# dts
+.if exists(${LOCALBASE}/lib/libdts_pic.a)
+WITH_DTS=yes
+.endif
+
# esound
.if (${HAVE_GNOME:Mesound}!="")
WITH_ESOUND=yes
@@ -384,6 +388,16 @@ LIB_DEPENDS+= cdda_interface.0:${PORTSDIR}/audio/cdparanoia
PLIST_SUB+= CDPARANOIA=""
.endif
+# dts
+.ifndef(WITH_DTS)
+CONFIGURE_ARGS+= --disable-dts
+PLIST_SUB+= DTS="@comment "
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libdts_pic.a:${PORTSDIR}/multimedia/libdts
+RUN_DEPENDS+= ${LOCALBASE}/lib/libdts_pic.a:${PORTSDIR}/multimedia/libdts
+PLIST_SUB+= DTS=""
+.endif
+
# esound
.ifndef(WITH_ESOUND)
CONFIGURE_ARGS+= --disable-esd \
@@ -817,6 +831,10 @@ pre-everything::
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_CDPARANOIA to enable cdparanoia Audio plugin'
.endif
+.ifndef(WITH_DTS)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_DTS to enable DTS decoding support'
+.endif
.ifndef(WITH_ESOUND)
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_ESOUND to enable esound Audio plugin'
diff --git a/multimedia/gstreamer-plugins80/distinfo b/multimedia/gstreamer-plugins80/distinfo
index dbd2cea1535..2ab790307c7 100644
--- a/multimedia/gstreamer-plugins80/distinfo
+++ b/multimedia/gstreamer-plugins80/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gst-plugins-0.8.1.tar.bz2) = c08c21df02857a11875295935d0442a1
-SIZE (gnome2/gst-plugins-0.8.1.tar.bz2) = 1809789
+MD5 (gnome2/gst-plugins-0.8.2.tar.bz2) = 1f46e3aa765659818f309ed5b64c9b88
+SIZE (gnome2/gst-plugins-0.8.2.tar.bz2) = 1978467
diff --git a/multimedia/gstreamer-plugins80/files/patch-configure b/multimedia/gstreamer-plugins80/files/patch-configure
index e2987f9821a..92b1deb51a6 100644
--- a/multimedia/gstreamer-plugins80/files/patch-configure
+++ b/multimedia/gstreamer-plugins80/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Tue Mar 16 20:32:36 2004
-+++ configure Tue Mar 16 20:41:00 2004
-@@ -41192,7 +41192,8 @@
+--- configure.orig Wed Jun 23 21:30:24 2004
++++ configure Wed Jun 23 21:30:25 2004
+@@ -46068,7 +46068,8 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
@@ -8,14 +8,5 @@
+#xxx fix the non x case is er niet...
+LIBS="-laudio -lm -lXt $X_LIBS $LIBS"
cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
- /* confdefs.h. */
-@@ -44483,7 +44484,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-ltheora $LIBS"
-+LIBS="-ltheora -logg $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
/* confdefs.h. */
+ _ACEOF
diff --git a/multimedia/gstreamer-plugins80/files/patch-ext_gnomevfs_gstgnomevfssink.c b/multimedia/gstreamer-plugins80/files/patch-ext_gnomevfs_gstgnomevfssink.c
deleted file mode 100644
index 592acc2e8ce..00000000000
--- a/multimedia/gstreamer-plugins80/files/patch-ext_gnomevfs_gstgnomevfssink.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ext/gnomevfs/gstgnomevfssink.c.orig Wed Apr 28 17:16:05 2004
-+++ ext/gnomevfs/gstgnomevfssink.c Wed Apr 28 17:16:20 2004
-@@ -347,7 +347,7 @@
- }
- sink->own_handle = TRUE;
- } else if (!sink->handle) {
-- GST_ELEMENT_ERROR (sink, RESOURCE, FAILED, (_("No filename given")), NULL);
-+ GST_ELEMENT_ERROR (sink, RESOURCE, FAILED, (_("No filename given")), (NULL));
- return FALSE;
- }
-
diff --git a/multimedia/gstreamer-plugins80/files/patch-ext_vorbis_vorbisparse.c b/multimedia/gstreamer-plugins80/files/patch-ext_vorbis_vorbisparse.c
new file mode 100644
index 00000000000..aeab67f4132
--- /dev/null
+++ b/multimedia/gstreamer-plugins80/files/patch-ext_vorbis_vorbisparse.c
@@ -0,0 +1,23 @@
+--- ext/vorbis/vorbisparse.c.orig Wed Jun 23 23:49:17 2004
++++ ext/vorbis/vorbisparse.c Wed Jun 23 23:50:16 2004
+@@ -103,6 +103,9 @@
+ vorbis_parse_set_header_on_caps (GstVorbisParse * parse, GstCaps * caps)
+ {
+ GstBuffer *buf1, *buf2, *buf3;
++ GstStructure *structure;
++ GValue list = { 0 };
++ GValue value = { 0 };
+
+ g_assert (parse);
+ g_assert (parse->streamheader);
+@@ -115,9 +118,7 @@
+ buf3 = parse->streamheader->next->next->data;
+ g_assert (buf3);
+
+- GstStructure *structure = gst_caps_get_structure (caps, 0);
+- GValue list = { 0 };
+- GValue value = { 0 };
++ structure = gst_caps_get_structure (caps, 0);
+
+ /* mark buffers */
+ GST_BUFFER_FLAG_SET (buf1, GST_BUFFER_IN_CAPS);
diff --git a/multimedia/gstreamer-plugins80/files/patch-gst_ffmpegcolorspace_gstffmpegcolorspace.c b/multimedia/gstreamer-plugins80/files/patch-gst_ffmpegcolorspace_gstffmpegcolorspace.c
deleted file mode 100644
index a6e501c8c66..00000000000
--- a/multimedia/gstreamer-plugins80/files/patch-gst_ffmpegcolorspace_gstffmpegcolorspace.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- gst/ffmpegcolorspace/gstffmpegcolorspace.c.orig Wed Apr 28 15:10:45 2004
-+++ gst/ffmpegcolorspace/gstffmpegcolorspace.c Wed Apr 28 15:11:00 2004
-@@ -306,7 +306,7 @@
- g_return_if_fail (GST_IS_FFMPEGCOLORSPACE (space));
-
- if (space->from_pixfmt == PIX_FMT_NB || space->to_pixfmt == PIX_FMT_NB) {
-- GST_ELEMENT_ERROR (space, CORE, NOT_IMPLEMENTED, NULL,
-+ GST_ELEMENT_ERROR (space, CORE, NOT_IMPLEMENTED, (NULL),
- ("attempting to convert colorspaces between unknown formats"));
- gst_buffer_unref (inbuf);
- return;
diff --git a/multimedia/gstreamer-plugins80/files/patch-gst_tcp_gsttcpclientsrc.h b/multimedia/gstreamer-plugins80/files/patch-gst_tcp_gsttcpclientsrc.h
new file mode 100644
index 00000000000..9d4414eb68d
--- /dev/null
+++ b/multimedia/gstreamer-plugins80/files/patch-gst_tcp_gsttcpclientsrc.h
@@ -0,0 +1,11 @@
+--- gst/tcp/gsttcpclientsrc.h.orig Wed Jun 23 23:44:07 2004
++++ gst/tcp/gsttcpclientsrc.h Wed Jun 23 23:44:26 2004
+@@ -29,6 +29,8 @@
+ #endif /* __cplusplus */
+
+ #include <netdb.h> /* sockaddr_in */
++#include <sys/types.h>
++#include <sys/socket.h>
+ #include <netinet/in.h> /* sockaddr_in */
+ #include <unistd.h>
+ #include "gsttcp.h"
diff --git a/multimedia/gstreamer-plugins80/files/patch-sys_oss_gstosselement.c b/multimedia/gstreamer-plugins80/files/patch-sys_oss_gstosselement.c
deleted file mode 100644
index 3f645e9dfc7..00000000000
--- a/multimedia/gstreamer-plugins80/files/patch-sys_oss_gstosselement.c
+++ /dev/null
@@ -1,25 +0,0 @@
-===================================================================
-RCS file: /cvs/gstreamer/gst-plugins/sys/oss/gstosselement.c,v
-retrieving revision 1.35
-retrieving revision 1.36
-diff -u -r1.35 -r1.36
---- sys/oss/gstosselement.c 2004/04/18 20:14:36 1.35
-+++ sys/oss/gstosselement.c 2004/04/29 23:45:03 1.36
-@@ -1168,6 +1168,17 @@
- probe->min = gst_osselement_rate_check_rate (probe, 1000);
- n_checks++;
- probe->max = gst_osselement_rate_check_rate (probe, 100000);
-+ /* a little bug workaround */
-+ {
-+ int max;
-+
-+ max = gst_osselement_rate_check_rate (probe, 48000);
-+ if (max > probe->max) {
-+ GST_ERROR
-+ ("Driver bug recognized (driver does not round rates correctly). Please file a bug report.");
-+ probe->max = max;
-+ }
-+ }
- n_checks++;
- if (probe->min == -1 || probe->max == -1) {
- GST_DEBUG ("unexpected check_rate error");
diff --git a/multimedia/gstreamer-plugins80/files/patch-sys_ximage_ximagesink.h b/multimedia/gstreamer-plugins80/files/patch-sys_ximage_ximagesink.h
deleted file mode 100644
index 07b125bfee8..00000000000
--- a/multimedia/gstreamer-plugins80/files/patch-sys_ximage_ximagesink.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- sys/ximage/ximagesink.h.orig Tue Mar 16 22:51:03 2004
-+++ sys/ximage/ximagesink.h Tue Mar 16 23:06:44 2004
-@@ -23,6 +23,7 @@
- #include <gst/video/videosink.h>
-
- #ifdef HAVE_XSHM
-+#include <sys/types.h>
- #include <sys/ipc.h>
- #include <sys/shm.h>
- #endif /* HAVE_XSHM */
diff --git a/multimedia/gstreamer-plugins80/files/patch-sys_xvimage_xvimagesink.h b/multimedia/gstreamer-plugins80/files/patch-sys_xvimage_xvimagesink.h
deleted file mode 100644
index ddb0d1f0050..00000000000
--- a/multimedia/gstreamer-plugins80/files/patch-sys_xvimage_xvimagesink.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- sys/xvimage/xvimagesink.h.orig Tue Mar 16 22:51:04 2004
-+++ sys/xvimage/xvimagesink.h Tue Mar 16 23:07:39 2004
-@@ -23,6 +23,7 @@
- #include <gst/video/videosink.h>
-
- #ifdef HAVE_XSHM
-+#include <sys/types.h>
- #include <sys/ipc.h>
- #include <sys/shm.h>
- #endif /* HAVE_XSHM */
diff --git a/multimedia/gstreamer-plugins80/pkg-plist b/multimedia/gstreamer-plugins80/pkg-plist
index 9ac5e4851cb..da2d3a74eeb 100644
--- a/multimedia/gstreamer-plugins80/pkg-plist
+++ b/multimedia/gstreamer-plugins80/pkg-plist
@@ -1,12 +1,8 @@
bin/gst-launch-ext-%%VERSION%%
bin/gst-visualise-%%VERSION%%
-etc/gconf/gconf.xml.defaults/schemas/system/gstreamer/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/system/gstreamer/%%VERSION%%/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/system/gstreamer/%%VERSION%%/default/%gconf.xml
-etc/gconf/gconf.xml.defaults/system/gstreamer/%gconf.xml
-etc/gconf/gconf.xml.defaults/system/gstreamer/%%VERSION%%/%gconf.xml
-etc/gconf/gconf.xml.defaults/system/gstreamer/%%VERSION%%/default/%gconf.xml
+@unexec GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/gstreamer-%%VERSION%%.schemas > /dev/null || /usr/bin/true
etc/gconf/schemas/gstreamer-%%VERSION%%.schemas
+@exec GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/gstreamer-%%VERSION%%.schemas > /dev/null || /usr/bin/true
include/gstreamer-%%VERSION%%/gst/audio/gstaudiofilter.h
include/gstreamer-%%VERSION%%/gst/audio/audioclock.h
include/gstreamer-%%VERSION%%/gst/audio/audio.h
@@ -19,6 +15,7 @@ include/gstreamer-%%VERSION%%/gst/idct/idct.h
include/gstreamer-%%VERSION%%/gst/media-info/media-info.h
include/gstreamer-%%VERSION%%/gst/mixer/mixer-enumtypes.h
include/gstreamer-%%VERSION%%/gst/mixer/mixer.h
+include/gstreamer-%%VERSION%%/gst/mixer/mixeroptions.h
include/gstreamer-%%VERSION%%/gst/mixer/mixertrack.h
include/gstreamer-%%VERSION%%/gst/navigation/navigation.h
include/gstreamer-%%VERSION%%/gst/play/play-enumtypes.h
@@ -42,10 +39,12 @@ include/gstreamer-%%VERSION%%/gst/xwindowlistener/xwindowlistener.h
lib/gstreamer-%%VERSION%%/libgstac3parse.so
lib/gstreamer-%%VERSION%%/libgstadder.so
lib/gstreamer-%%VERSION%%/libgstalaw.so
+lib/gstreamer-%%VERSION%%/libgstalpha.so
%%ARTS%%lib/gstreamer-%%VERSION%%/libgstartsdsink.so
lib/gstreamer-%%VERSION%%/libgstasf.so
lib/gstreamer-%%VERSION%%/libgstaudioconvert.so
lib/gstreamer-%%VERSION%%/libgstaudiofilter.so
+lib/gstreamer-%%VERSION%%/libgstaudiorate.so
lib/gstreamer-%%VERSION%%/libgstaudio.so
%%LIBAUDIOFILE%%lib/gstreamer-%%VERSION%%/libgstaudiofile.so
lib/gstreamer-%%VERSION%%/libgstaudioscale.so
@@ -60,6 +59,7 @@ lib/gstreamer-%%VERSION%%/libgstchart.so
lib/gstreamer-%%VERSION%%/libgstcutter.so
lib/gstreamer-%%VERSION%%/libgstdebug.so
lib/gstreamer-%%VERSION%%/libgstdeinterlace.so
+%%DTS%%lib/gstreamer-%%VERSION%%/libgstdtsdec.so
%%LIBDV%%lib/gstreamer-%%VERSION%%/libgstdvdec.so
%%LIBDVDNAV%%lib/gstreamer-%%VERSION%%/libgstdvdnavsrc.so
%%LIBDVDREAD%%lib/gstreamer-%%VERSION%%/libgstdvdreadsrc.so
@@ -93,7 +93,6 @@ lib/gstreamer-%%VERSION%%/libgstmatroska.so
lib/gstreamer-%%VERSION%%/libgstmedian.so
%%LIBMIKMOD%%lib/gstreamer-%%VERSION%%/libgstmikmod.so
lib/gstreamer-%%VERSION%%/libgstmixmatrix.so
-lib/gstreamer-%%VERSION%%/libgstmodplug.a
lib/gstreamer-%%VERSION%%/libgstmodplug.so
lib/gstreamer-%%VERSION%%/libgstmonoscope.so
lib/gstreamer-%%VERSION%%/libgstmp1videoparse.so
@@ -104,6 +103,7 @@ lib/gstreamer-%%VERSION%%/libgstmpegaudio.so
lib/gstreamer-%%VERSION%%/libgstmpegaudioparse.so
lib/gstreamer-%%VERSION%%/libgstmpegstream.so
lib/gstreamer-%%VERSION%%/libgstmulaw.so
+lib/gstreamer-%%VERSION%%/libgstmultipart.so
%%NAS%%lib/gstreamer-%%VERSION%%/libgstnassink.so
lib/gstreamer-%%VERSION%%/libgstnavigationtest.so
%%OGG%%lib/gstreamer-%%VERSION%%/libgstogg.so
@@ -147,10 +147,13 @@ lib/gstreamer-%%VERSION%%/libgstudp.so
lib/gstreamer-%%VERSION%%/libgstvbidec.so
lib/gstreamer-%%VERSION%%/libgstvideo.so
lib/gstreamer-%%VERSION%%/libgstvideobalance.so
+lib/gstreamer-%%VERSION%%/libgstvideobox.so
lib/gstreamer-%%VERSION%%/libgstvideocrop.so
lib/gstreamer-%%VERSION%%/libgstvideodrop.so
lib/gstreamer-%%VERSION%%/libgstvideofilter.so
lib/gstreamer-%%VERSION%%/libgstvideoflip.so
+lib/gstreamer-%%VERSION%%/libgstvideomixer.so
+lib/gstreamer-%%VERSION%%/libgstvideorate.so
lib/gstreamer-%%VERSION%%/libgstvideoscale.so
lib/gstreamer-%%VERSION%%/libgstvideotestsrc.so
lib/gstreamer-%%VERSION%%/libgstvolenv.so
@@ -184,9 +187,11 @@ libdata/pkgconfig/gstreamer-play-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-plugins-%%VERSION%%.pc
share/locale/af/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/az/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
+share/locale/en_GB/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/nl/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/sr/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/sv/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
+share/locale/uk/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@unexec rmdir %D/lib/gstreamer-%%VERSION%% 2>/dev/null || true
@dirrm include/gstreamer-%%VERSION%%/gst/xwindowlistener
@dirrm include/gstreamer-%%VERSION%%/gst/xoverlay
@@ -204,12 +209,6 @@ share/locale/sv/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@dirrm include/gstreamer-%%VERSION%%/gst/floatcast
@dirrm include/gstreamer-%%VERSION%%/gst/colorbalance
@dirrm include/gstreamer-%%VERSION%%/gst/audio
-@dirrm etc/gconf/gconf.xml.defaults/system/gstreamer/%%VERSION%%/default
-@dirrm etc/gconf/gconf.xml.defaults/system/gstreamer/%%VERSION%%
-@dirrm etc/gconf/gconf.xml.defaults/system/gstreamer
-@dirrm etc/gconf/gconf.xml.defaults/schemas/system/gstreamer/%%VERSION%%/default
-@dirrm etc/gconf/gconf.xml.defaults/schemas/system/gstreamer/%%VERSION%%
-@dirrm etc/gconf/gconf.xml.defaults/schemas/system/gstreamer
@unexec rmdir %D/include/gstreamer-%%VERSION%%/gst 2>/dev/null || true
@unexec rmdir %D/include/gstreamer-%%VERSION%% 2>/dev/null || true
@exec %%X11BASE%%/bin/gst-register-%%VERSION%% 2>/dev/null || true