aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorcmt <cmt@FreeBSD.org>2018-03-29 02:35:43 +0800
committercmt <cmt@FreeBSD.org>2018-03-29 02:35:43 +0800
commit763c04064466ef5af5b1b1e4b94b1fba42b8db69 (patch)
tree6ada972794dcf5a834ea737a6b47417b0ce446a6 /net-mgmt
parent7bac136d6914b09c19e5c4575d92d79f768dfef1 (diff)
downloadfreebsd-ports-graphics-763c04064466ef5af5b1b1e4b94b1fba42b8db69.tar.gz
freebsd-ports-graphics-763c04064466ef5af5b1b1e4b94b1fba42b8db69.tar.zst
freebsd-ports-graphics-763c04064466ef5af5b1b1e4b94b1fba42b8db69.zip
new port: check_ssl_cert
nagios/icinga check for testing ssl certificates and ssl servers
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/check_ssl_cert/Makefile30
-rw-r--r--net-mgmt/check_ssl_cert/distinfo3
-rw-r--r--net-mgmt/check_ssl_cert/pkg-descr6
4 files changed, 40 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 0b9d00bd093..51ccdaca94a 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -43,6 +43,7 @@
SUBDIR += check_logfiles
SUBDIR += check_multi
SUBDIR += check_mysql_health
+ SUBDIR += check_ssl_cert
SUBDIR += chillispot
SUBDIR += choparp
SUBDIR += cidr
diff --git a/net-mgmt/check_ssl_cert/Makefile b/net-mgmt/check_ssl_cert/Makefile
new file mode 100644
index 00000000000..721b337fdf7
--- /dev/null
+++ b/net-mgmt/check_ssl_cert/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= check_ssl_cert
+PORTVERSION= 1.63.0
+DISTVERSIONPREFIX= v
+CATEGORIES= net-mgmt
+
+MAINTAINER= cmt@FreeBSD.org
+COMMENT= Nagios/Icinga plugin for checking SSL/TLS certificates
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= expect:lang/expect \
+ p5-TimeDate>=0:devel/p5-TimeDate
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= matteocorti
+GV_PROJECT= check_ssl_cert
+PLIST_FILES= libexec/nagios/check_ssl_cert \
+ ${MANPREFIX}/man/man1/check_ssl_cert.1.gz
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/nagios
+ ${INSTALL_SCRIPT} ${WRKSRC}/check_ssl_cert ${STAGEDIR}${PREFIX}/libexec/nagios/
+ ${INSTALL_MAN} ${WRKSRC}/check_ssl_cert.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/check_ssl_cert/distinfo b/net-mgmt/check_ssl_cert/distinfo
new file mode 100644
index 00000000000..8f755e1a986
--- /dev/null
+++ b/net-mgmt/check_ssl_cert/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522260616
+SHA256 (matteocorti-check_ssl_cert-v1.63.0_GH0.tar.gz) = 681d83d8dc9f482871f25bdaf711cfff37c5a5cdf156b361b1647be0e3a1fbf5
+SIZE (matteocorti-check_ssl_cert-v1.63.0_GH0.tar.gz) = 188126
diff --git a/net-mgmt/check_ssl_cert/pkg-descr b/net-mgmt/check_ssl_cert/pkg-descr
new file mode 100644
index 00000000000..e4cebacb5ed
--- /dev/null
+++ b/net-mgmt/check_ssl_cert/pkg-descr
@@ -0,0 +1,6 @@
+A Nagios/Icinga plugin for checking X.509 certificates.
+Functionality includes checks for certificate validity, issuing
+Certificate Authority, certificate attributes, state of TLS servers
+and checks agains SSL Labs' assesment service.
+
+WWW: https://matteocorti.github.io/check_ssl_cert/