aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-07-14 05:02:10 +0800
committerpawel <pawel@FreeBSD.org>2016-07-14 05:02:10 +0800
commit191b071fd2db1984c13438c2af1f76b421e9aa17 (patch)
tree145a3ee1e4754a235cb068c57ad6e44155edb863 /net-mgmt
parent2742d142fd2d1338d7f0c157ef5c7ecb9f00335f (diff)
downloadfreebsd-ports-graphics-191b071fd2db1984c13438c2af1f76b421e9aa17.tar.gz
freebsd-ports-graphics-191b071fd2db1984c13438c2af1f76b421e9aa17.tar.zst
freebsd-ports-graphics-191b071fd2db1984c13438c2af1f76b421e9aa17.zip
OnionLauncher is a launcher for Tor written in Python and PyQt5.
WWW: https://www.github.com/neelchauhan/OnionLauncher PR: 210743 Submitted by: Neel Chauhan <neel@neelc.org>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/onionlauncher/Makefile27
-rw-r--r--net-mgmt/onionlauncher/distinfo3
-rw-r--r--net-mgmt/onionlauncher/pkg-descr3
4 files changed, 34 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 0dd60a18296..da1f1eb506d 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -189,6 +189,7 @@
SUBDIR += ocsinventory-agent
SUBDIR += ocsinventory-ng
SUBDIR += omping
+ SUBDIR += onionlauncher
SUBDIR += openlldp
SUBDIR += openvmps
SUBDIR += p0f
diff --git a/net-mgmt/onionlauncher/Makefile b/net-mgmt/onionlauncher/Makefile
new file mode 100644
index 00000000000..76345ab8397
--- /dev/null
+++ b/net-mgmt/onionlauncher/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= onionlauncher
+PORTVERSION= 0.0.1
+DISTVERSIONPREFIX= v
+CATEGORIES= net-mgmt
+
+MAINTAINER= neel@neelc.org
+COMMENT= Launcher for Tor
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}stem>=0.18:security/py-stem \
+ tor:security/tor
+
+USE_GITHUB= yes
+GH_ACCOUNT= neelchauhan
+GH_PROJECT= OnionLauncher
+
+USES= pyqt:5 python
+USE_PYTHON= autoplist distutils
+USE_PYQT= core_run gui_run widgets_run
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/onionlauncher/distinfo b/net-mgmt/onionlauncher/distinfo
new file mode 100644
index 00000000000..a4b0545b554
--- /dev/null
+++ b/net-mgmt/onionlauncher/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1467378000
+SHA256 (neelchauhan-OnionLauncher-v0.0.1_GH0.tar.gz) = facafe8549c47bd7f5ad1e7228acbd8633363e0bd0f9c4bf99e679b92112b971
+SIZE (neelchauhan-OnionLauncher-v0.0.1_GH0.tar.gz) = 18545
diff --git a/net-mgmt/onionlauncher/pkg-descr b/net-mgmt/onionlauncher/pkg-descr
new file mode 100644
index 00000000000..85f60802f26
--- /dev/null
+++ b/net-mgmt/onionlauncher/pkg-descr
@@ -0,0 +1,3 @@
+OnionLauncher is a launcher for Tor written in Python and PyQt5.
+
+WWW: https://www.github.com/neelchauhan/OnionLauncher