aboutsummaryrefslogtreecommitdiffstats
path: root/net/libunpipc
diff options
context:
space:
mode:
authordan <dan@FreeBSD.org>1999-10-03 03:17:58 +0800
committerdan <dan@FreeBSD.org>1999-10-03 03:17:58 +0800
commit3617d1df498880d4218f3f57a161c2b3af0f90c1 (patch)
treeca3887e2db899fb77a31fb05bfe2b60f928d8796 /net/libunpipc
parentc95a5e231b32c8e5704b732de39134e55b39ea0a (diff)
downloadfreebsd-ports-graphics-3617d1df498880d4218f3f57a161c2b3af0f90c1.tar.gz
freebsd-ports-graphics-3617d1df498880d4218f3f57a161c2b3af0f90c1.tar.zst
freebsd-ports-graphics-3617d1df498880d4218f3f57a161c2b3af0f90c1.zip
libunp is the library used in W. Richard Steven's book "UNIX Network
Programming Volume 2, 2nd Edition". It contains the library and headers used in the examples as well as all programs from the text that compile on FreeBSD systems. For more information on the book, see http://www.phptr.com/ptrbooks/ptr_013490012X.html For more info on W. Richard Stevens, see http://www.kohala.com/~rstevens/ PR: ports/14058 Submitted by: James FitzGibbon <james@targetnet.com>
Diffstat (limited to 'net/libunpipc')
-rw-r--r--net/libunpipc/Makefile30
-rw-r--r--net/libunpipc/distinfo1
-rw-r--r--net/libunpipc/files/patch-aa18
-rw-r--r--net/libunpipc/files/patch-ab13
-rw-r--r--net/libunpipc/files/patch-ac11
-rw-r--r--net/libunpipc/files/patch-ad11
-rw-r--r--net/libunpipc/files/patch-ae38
-rw-r--r--net/libunpipc/pkg-comment1
-rw-r--r--net/libunpipc/pkg-descr12
-rw-r--r--net/libunpipc/pkg-plist3
10 files changed, 138 insertions, 0 deletions
diff --git a/net/libunpipc/Makefile b/net/libunpipc/Makefile
new file mode 100644
index 00000000000..024ca5b7499
--- /dev/null
+++ b/net/libunpipc/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: libunpipc
+# Version required: 1.0
+# Date created: Sept 28, 1999
+# Whom: james@targetnet.com
+#
+# $FreeBSD$
+#
+
+DISTNAME= unpv22e
+PKGNAME= libunpipc-1.0
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.kohala.com/pub/rstevens/ \
+ http://compass.net.edu.cn:8000/programming/
+
+MAINTAINER= james@targetnet.com
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.pre.mk>
+
+post-configure:
+ ln -s ${WRKSRC}/config.h ${WRKSRC}/unpipc_config.h
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libunpipc.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/lib/unpipc.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/config.h ${PREFIX}/include/unpipc_config.h
+
+.include <bsd.port.post.mk>
diff --git a/net/libunpipc/distinfo b/net/libunpipc/distinfo
new file mode 100644
index 00000000000..2c839bdba14
--- /dev/null
+++ b/net/libunpipc/distinfo
@@ -0,0 +1 @@
+MD5 (unpv22e.tar.gz) = 668fdb55452859c13b44a7049a40071a
diff --git a/net/libunpipc/files/patch-aa b/net/libunpipc/files/patch-aa
new file mode 100644
index 00000000000..e69a3263797
--- /dev/null
+++ b/net/libunpipc/files/patch-aa
@@ -0,0 +1,18 @@
+--- Makefile.in.orig Fri Apr 11 18:42:26 1997
++++ Makefile.in Thu Sep 30 10:24:12 1999
+@@ -1,8 +1,13 @@
+ include ./Make.defines
+
++SUBDIRS = lib
++
+ all:
+- @echo "Nothing to make in this directory"
+- @echo "Please read the README file"
++ PWD=`pwd`; \
++ for dir in $(SUBDIRS) ; \
++ do \
++ cd $$PWD/$$dir && $(MAKE) && cd .. ;\
++ done
+
+ clean:
+ rm -f $(CLEANFILES)
diff --git a/net/libunpipc/files/patch-ab b/net/libunpipc/files/patch-ab
new file mode 100644
index 00000000000..f9dacef263a
--- /dev/null
+++ b/net/libunpipc/files/patch-ab
@@ -0,0 +1,13 @@
+--- configure.orig Tue Sep 28 11:52:17 1999
++++ configure Tue Sep 28 11:52:24 1999
+@@ -2894,10 +2894,6 @@
+ LIB_OBJS="$LIB_OBJS signal.o"
+ LIB_OBJS="$LIB_OBJS signal_intr.o"
+ LIB_OBJS="$LIB_OBJS sleep_us.o"
+-if test $ac_cv_have_siginfo_t_struct = yes ; then
+- LIB_OBJS="$LIB_OBJS signal_rt.o"
+- LIB_OBJS="$LIB_OBJS signal_rt_intr.o"
+-fi
+ if test "$ac_cv_func_snprintf" = no ; then
+ LIB_OBJS="$LIB_OBJS snprintf.o"
+ fi
diff --git a/net/libunpipc/files/patch-ac b/net/libunpipc/files/patch-ac
new file mode 100644
index 00000000000..50453b6f7b7
--- /dev/null
+++ b/net/libunpipc/files/patch-ac
@@ -0,0 +1,11 @@
+--- lib/unpipc.h.orig Wed Aug 5 14:20:32 1998
++++ lib/unpipc.h Thu Sep 30 10:23:56 1999
+@@ -4,7 +4,7 @@
+ #ifndef __unpipc_h
+ #define __unpipc_h
+
+-#include "../config.h" /* configuration options for current OS */
++#include <unpipc_config.h> /* configuration options for current OS */
+ /* "../config.h" is generated by configure */
+
+ /* If anything changes in the following list of #includes, must change
diff --git a/net/libunpipc/files/patch-ad b/net/libunpipc/files/patch-ad
new file mode 100644
index 00000000000..9cbe815a923
--- /dev/null
+++ b/net/libunpipc/files/patch-ad
@@ -0,0 +1,11 @@
+--- lib/Makefile.orig Thu Sep 30 10:33:02 1999
++++ lib/Makefile Thu Sep 30 10:33:09 1999
+@@ -1,7 +1,7 @@
+ include ../Make.defines
+
+ # Following required by Solaris 2.x for Posix version of sigwait().
+-CFLAGS += -D_POSIX_PTHREAD_SEMANTICS
++CFLAGS += -D_POSIX_PTHREAD_SEMANTICS -I..
+
+ all: ${LIB_OBJS}
+ ar rv ${LIBUNPIPC_NAME} $?
diff --git a/net/libunpipc/files/patch-ae b/net/libunpipc/files/patch-ae
new file mode 100644
index 00000000000..2368fc7b066
--- /dev/null
+++ b/net/libunpipc/files/patch-ae
@@ -0,0 +1,38 @@
+--- lib/wrappthread.c.orig Thu Sep 30 11:03:00 1999
++++ lib/wrappthread.c Thu Sep 30 11:04:50 1999
+@@ -83,17 +83,6 @@
+ }
+
+ void
+-Pthread_kill(pthread_t tid, int signo)
+-{
+- int n;
+-
+- if ( (n = pthread_kill(tid, signo)) == 0)
+- return;
+- errno = n;
+- err_sys("pthread_kill error");
+-}
+-
+-void
+ Pthread_mutexattr_init(pthread_mutexattr_t *attr)
+ {
+ int n;
+@@ -274,17 +263,6 @@
+ return;
+ errno = n;
+ err_sys("pthread_key_create error");
+-}
+-
+-void
+-Pthread_setcancelstate(int state, int *oldstate)
+-{
+- int n;
+-
+- if ( (n = pthread_setcancelstate(state, oldstate)) == 0)
+- return;
+- errno = n;
+- err_sys("pthread_setcancelstate error");
+ }
+
+ void
diff --git a/net/libunpipc/pkg-comment b/net/libunpipc/pkg-comment
new file mode 100644
index 00000000000..f7978b93cff
--- /dev/null
+++ b/net/libunpipc/pkg-comment
@@ -0,0 +1 @@
+The networking library used in UNIX Network Programming Volume 2 2e
diff --git a/net/libunpipc/pkg-descr b/net/libunpipc/pkg-descr
new file mode 100644
index 00000000000..a4515a02bb8
--- /dev/null
+++ b/net/libunpipc/pkg-descr
@@ -0,0 +1,12 @@
+libunp is the library used in W. Richard Steven's book "UNIX Network
+Programming Volume 2, 2nd Edition". It contains the library and headers
+used in the examples as well as all programs from the text that compile on
+FreeBSD systems.
+
+For more information on the book, see
+
+http://www.phptr.com/ptrbooks/ptr_013490012X.html
+
+For more info on W. Richard Stevens, see
+
+http://www.kohala.com/~rstevens/
diff --git a/net/libunpipc/pkg-plist b/net/libunpipc/pkg-plist
new file mode 100644
index 00000000000..784055b4a02
--- /dev/null
+++ b/net/libunpipc/pkg-plist
@@ -0,0 +1,3 @@
+include/unpipc.h
+include/unpipc_config.h
+lib/libunpipc.a