aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormfechner <mfechner@FreeBSD.org>2018-04-13 14:15:09 +0800
committermfechner <mfechner@FreeBSD.org>2018-04-13 14:15:09 +0800
commit1981c693bb3358d46af37cc9e0e0721d4608c6ac (patch)
treeed787a69fe81f1e9deffc0b912e8cfaf063270ba /net
parentca5246eb0f1e4cd66c049155942f030ed6d44ed1 (diff)
downloadfreebsd-ports-graphics-1981c693bb3358d46af37cc9e0e0721d4608c6ac.tar.gz
freebsd-ports-graphics-1981c693bb3358d46af37cc9e0e0721d4608c6ac.tar.zst
freebsd-ports-graphics-1981c693bb3358d46af37cc9e0e0721d4608c6ac.zip
Added new ports required for gitlab 10.6.x.
Reviewed by: mat, swills (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D15032
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-gitaly-proto088/Makefile24
-rw-r--r--net/rubygem-gitaly-proto088/distinfo3
-rw-r--r--net/rubygem-gitaly-proto088/pkg-descr12
4 files changed, 40 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b275cb13ef7..d8d601f9727 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1254,6 +1254,7 @@
SUBDIR += rubygem-gitaly-proto
SUBDIR += rubygem-gitaly-proto083
SUBDIR += rubygem-gitaly-proto084
+ SUBDIR += rubygem-gitaly-proto088
SUBDIR += rubygem-gitlab_omniauth-ldap
SUBDIR += rubygem-gitlab_omniauth-ldap1
SUBDIR += rubygem-grpc
diff --git a/net/rubygem-gitaly-proto088/Makefile b/net/rubygem-gitaly-proto088/Makefile
new file mode 100644
index 00000000000..7b651d55e50
--- /dev/null
+++ b/net/rubygem-gitaly-proto088/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gitaly-proto
+PORTVERSION= 0.88.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 088
+
+MAINTAINER= idefix@fechner.net
+COMMENT= Protobuf specifications and client libraries for Gitaly
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-google-protobuf>=3.1:devel/rubygem-google-protobuf \
+ rubygem-grpc>=1.0:net/rubygem-grpc
+
+USES= gem
+NO_ARCH= yes
+USE_RUBY= yes
+
+PORTSCOUT= limit:^0\.88\.
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-gitaly-proto088/distinfo b/net/rubygem-gitaly-proto088/distinfo
new file mode 100644
index 00000000000..03ccd6b4eb9
--- /dev/null
+++ b/net/rubygem-gitaly-proto088/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520006039
+SHA256 (rubygem/gitaly-proto-0.88.0.gem) = f1e81bc10494fa95d50db227919dd81e5e7c0a78d82e21e1936da02d30afe232
+SIZE (rubygem/gitaly-proto-0.88.0.gem) = 15872
diff --git a/net/rubygem-gitaly-proto088/pkg-descr b/net/rubygem-gitaly-proto088/pkg-descr
new file mode 100644
index 00000000000..2886a66d5b6
--- /dev/null
+++ b/net/rubygem-gitaly-proto088/pkg-descr
@@ -0,0 +1,12 @@
+Gitaly is part of GitLab. It is a server application that uses its own gRPC
+protocol to communicate with its clients. This repository contains the protocol
+definition and automatically generated wrapper code for Go and Ruby.
+
+The .proto files define the remote procedure calls for interacting with Gitaly.
+We keep auto-generated client libraries for Ruby and Go in their respective
+subdirectories.
+
+Use the make generate script from the root of the repository to regenerate the
+client libraries after updating .proto files.
+
+WWW: https://gitlab.com/gitlab-org/gitaly-proto