aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-16 00:47:45 +0800
committeradamw <adamw@FreeBSD.org>2014-07-16 00:47:45 +0800
commit862e7f12d35568afef67e31a27a38bb3de64fbe7 (patch)
tree46fa5b652d3bdcba86fda4163acf6997cd8e4928 /news
parentfc663a6275e8b22ea2b106470db0d66f5ff43e1b (diff)
downloadfreebsd-ports-graphics-862e7f12d35568afef67e31a27a38bb3de64fbe7.tar.gz
freebsd-ports-graphics-862e7f12d35568afef67e31a27a38bb3de64fbe7.tar.zst
freebsd-ports-graphics-862e7f12d35568afef67e31a27a38bb3de64fbe7.zip
Add DOCS to OPTIONS_DEFINE to ports that check for PORT_OPTIONS:MDOCS.
Diffstat (limited to 'news')
-rw-r--r--news/golded+/Makefile2
-rw-r--r--news/leafnode/Makefile2
-rw-r--r--news/newsstar/Makefile2
-rw-r--r--news/sabnzbdplus/Makefile2
4 files changed, 6 insertions, 2 deletions
diff --git a/news/golded+/Makefile b/news/golded+/Makefile
index f07877c70fa..54f8e8bd9e7 100644
--- a/news/golded+/Makefile
+++ b/news/golded+/Makefile
@@ -22,6 +22,8 @@ DOCS= copying copying.lib license.txt notework.txt rusfaq.txt\
PORTDOCS= ${DOCS} gold_ref.txt gold_usr.txt
SUB_FILES= pkg-message
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/news/leafnode/Makefile b/news/leafnode/Makefile
index 9bca210b69c..58a5508acca 100644
--- a/news/leafnode/Makefile
+++ b/news/leafnode/Makefile
@@ -18,6 +18,8 @@ GNU_CONFIGURE= yes
CONFLICTS= newsx-1* s-news-0*
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
# TODO: remove this auto-selection, and tell users through UPDATING to
diff --git a/news/newsstar/Makefile b/news/newsstar/Makefile
index 16b53d8dcd4..cc9d1c411e1 100644
--- a/news/newsstar/Makefile
+++ b/news/newsstar/Makefile
@@ -20,7 +20,7 @@ GNU_CONFIGURE= yes
USES= iconv perl5 shebangfix
SHEBANG_FILES= newsstar.in
-OPTIONS_DEFINE= SSL
+OPTIONS_DEFINE= SSL DOCS EXAMPLES
OPTIONS_DEFAULT= SSL
CONFIGURE_ARGS+=--disable-chown \
diff --git a/news/sabnzbdplus/Makefile b/news/sabnzbdplus/Makefile
index 40a02b26b24..5c31c86864e 100644
--- a/news/sabnzbdplus/Makefile
+++ b/news/sabnzbdplus/Makefile
@@ -84,7 +84,7 @@ PORTDOCS= ABOUT.txt \
USERS= _sabnzbd
GROUPS= _sabnzbd
-OPTIONS_DEFINE= PAR2CMDLINE UNRAR FEEDPARSER YENC OPENSSL
+OPTIONS_DEFINE= PAR2CMDLINE UNRAR FEEDPARSER YENC OPENSSL DOCS
OPTIONS_DEFAULT= PAR2CMDLINE UNRAR FEEDPARSER YENC OPENSSL
PAR2CMDLINE_DESC= Required for postprocessing of par files
UNRAR_DESC= Often required for unpacking many downloads