aboutsummaryrefslogtreecommitdiffstats
path: root/polish
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-09-13 21:53:09 +0800
committerbapt <bapt@FreeBSD.org>2015-09-13 21:53:09 +0800
commitb2a336a263688f5e88d1bea655fe8595c5e52153 (patch)
treeccd1c1127dfdbf333583d4776872eace2046d6fc /polish
parent0c5704cbd21fff7470be9ae1776ed54869a5372c (diff)
downloadfreebsd-ports-graphics-b2a336a263688f5e88d1bea655fe8595c5e52153.tar.gz
freebsd-ports-graphics-b2a336a263688f5e88d1bea655fe8595c5e52153.tar.zst
freebsd-ports-graphics-b2a336a263688f5e88d1bea655fe8595c5e52153.zip
Remove the autodetect option
Convert to options helpers
Diffstat (limited to 'polish')
-rw-r--r--polish/gnugadu2/Makefile119
-rw-r--r--polish/gnugadu2/pkg-plist16
2 files changed, 34 insertions, 101 deletions
diff --git a/polish/gnugadu2/Makefile b/polish/gnugadu2/Makefile
index ddd479fdbce..58cf2d6727a 100644
--- a/polish/gnugadu2/Makefile
+++ b/polish/gnugadu2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnugadu2
PORTVERSION= 2.3.0
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= polish net-im
MASTER_SITES= SF/ggadu/gg2/${PORTVERSION}
DISTNAME= gg2-${PORTVERSION}
@@ -44,105 +44,39 @@ CONFIGURE_ARGS= --disable-esdtest \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= AUTODETECT DBUS DOCKAPP DOCKLET ESOUND \
+OPTIONS_DEFINE= DBUS DOCKAPP DOCKLET ESOUND \
GTKSPELL JABBER TLEN XOSD
OPTIONS_DEFAULT=DOCKLET
+OPTIONS_SUB= yes
-AUTODETECT_DESC=Autodetect plugins
DOCKLET_DESC= Enable fd.o docklet plugin
DOCKAPP_DESC= Enable WindowMaker dockapp plugin
GTKSPELL_DESC= Enable GTKSpell checker
TLEN_DESC= Enable Tlen.pl network plugin
XOSD_DESC= Enable On-Screen-Display messages
-#.if ${${HAVE_GNOME:Mesound}!="" && empty(PORT_OPTIONS:MESOUND)
-
-.include <bsd.port.pre.mk> # can't change this untile HAVE_GNOME has been fixed
-
-.if ${PORT_OPTIONS:MAUTODETECT}
-#detect dbus - only works with old versions
-.if exists(${LOCALBASE}/lib/libdbus-1.so) && !${PORT_OPTIONS:MDBUS}
-PORT_OPTIONS+= DBUS
-.endif
-#detect esound
-.if ${HAVE_GNOME:Mesound}!="" && !${PORT_OPTIONS:MESOUND}
-PORT_OPTIONS+= ESOUND
-.endif
-#detect gtkspell
-.if exists(${LOCALBASE}/lib/libgtkspell.so) && !${PORT_OPTIONS:MGTKSPELL}
-PORT_OPTIONS+= GTKSPELL
-.endif
-.endif
-
-.if ${PORT_OPTIONS:MTLEN}
-LIB_DEPENDS+= libtlen.so:${PORTSDIR}/polish/libtlen
-CONFIGURE_ARGS+= --with-tlen
-PLIST_SUB+= TLEN:=""
-.else
-CONFIGURE_ARGS+= --without-tlen
-PLIST_SUB+= TLEN:="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MJABBER}
-LIB_DEPENDS+= libloudmouth-1.so:${PORTSDIR}/net-im/loudmouth
-CONFIGURE_ARGS+= --with-jabber
-PLIST_SUB+= JABBER:=""
-.else
-CONFIGURE_ARGS+= --without-jabber
-PLIST_SUB+= JABBER:="@comment "
-.endif
-
-.if !${PORT_OPTIONS:MDOCKLET}
-CONFIGURE_ARGS+= --without-docklet-system-tray
-PLIST_SUB+= DOCKLET:="@comment "
-.else
-CONFIGURE_ARGS+= --with-docklet-system-tray
-PLIST_SUB+= DOCKLET:=""
-.endif
-
-.if ${PORT_OPTIONS:MDOCKAPP}
-CONFIGURE_ARGS+= --with-docklet_dockapp
-PLIST_SUB+= DOCKAPP:=""
-.else
-CONFIGURE_ARGS+= --without-docklet_dockapp
-PLIST_SUB+= DOCKAPP:="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MGTKSPELL}
-LIB_DEPENDS+= libgtkspell.so:${PORTSDIR}/textproc/gtkspell
-CONFIGURE_ARGS+= --with-gtkspell
-.else
-CONFIGURE_ARGS+= --without-gtkspell
-.endif
-
-.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= libdbus-1.so:${PORTSDIR}/devel/dbus
-CONFIGURE_ARGS+= --with-dbus \
- --with-dbus-dir=${PREFIX}/share/dbus-1/services
-PLIST_SUB+= DBUS:=""
-.else
-CONFIGURE_ARGS+= --without-dbus
-PLIST_SUB+= DBUS:="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MESOUND}
-PKGNAMESUFFIX= -esound
-USE_GNOME+= esound
-CONFIGURE_ARGS+= --with-esd
-PLIST_SUB+= ESOUND:=""
-.else
-CONFIGURE_ARGS+= --without-esd
-PLIST_SUB+= ESOUND:="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MXOSD}
-LIB_DEPENDS+= libxosd.so:${PORTSDIR}/misc/xosd
-CONFIGURE_ARGS+= --with-xosd
-PLIST_SUB+= XOSD:=""
-.else
-CONFIGURE_ARGS+= --without-xosd
-PLIST_SUB+= XOSD:="@comment "
-.endif
+TLEN_LIB_DEPENDS= libtlen.so:${PORTSDIR}/polish/libtlen
+TLEN_CONFIGURE_WITH= tlen
+
+JABBER_LIB_DEPENDS= libloudmouth-1.so:${PORTSDIR}/net-im/loudmouth
+JABBER_CONFIGURE_WITH= jabber
+
+DOCKLET_CONFIGURE_WITH= docklet-system-tray
+
+DOCKAPP_CONFIGURE_WITH= docklet_dockapp
+
+GTKSPELL_LIB_DEPENDS= libgtkspell.so:${PORTSDIR}/textproc/gtkspell
+GTKSPELL_CONFIGURE_WITH= gtkspell
+
+DBUS_LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
+DBUS_CONFIGURE_WITH= dbus
+DBUS_CONFIGURE_ON= --with-dbus-dir=${PREFIX}/share/dbus-1/services
+
+ESOUND_USE= GNOME=esound
+ESOUND_CONFIGURE_WITH= esd
+
+XOSD_LIB_DEPENDS= libxosd.so:${PORTSDIR}/misc/xosd
+XOSD_CONFIGURE_WITH= xosd
post-patch:
@${REINPLACE_CMD} -e 's,=.*},=${PREFIX},' ${WRKSRC}/src/plugins/dbus/org.freedesktop.im.GG.service
@@ -153,5 +87,4 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/gg2.desktop ${STAGEDIR}${PREFIX}/share/applications/
-# vim: set ts=8 sw=8:
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/polish/gnugadu2/pkg-plist b/polish/gnugadu2/pkg-plist
index d58b0056af2..76003f55ca9 100644
--- a/polish/gnugadu2/pkg-plist
+++ b/polish/gnugadu2/pkg-plist
@@ -3,25 +3,25 @@ bin/gghist
include/gg2_core.h
lib/gg2/libGUI_plugin.so
lib/gg2/libaaway_plugin.so
-%%DBUS:%%lib/gg2/libdbus_plugin.so
-%%DOCKAPP:%%lib/gg2/libdocklet_dockapp_plugin.so
-%%DOCKLET:%%lib/gg2/libdocklet_system_tray_plugin.so
+%%DBUS%%lib/gg2/libdbus_plugin.so
+%%DOCKAPP%%lib/gg2/libdocklet_dockapp_plugin.so
+%%DOCKLET%%lib/gg2/libdocklet_system_tray_plugin.so
lib/gg2/libgadu_gadu_plugin.so
lib/gg2/libhistory_external_plugin.so
lib/gg2/libignore_main_plugin.so
-%%JABBER:%%lib/gg2/libjabber_plugin.so
+%%JABBER%%lib/gg2/libjabber_plugin.so
lib/gg2/libsms_plugin.so
-%%ESOUND:%%lib/gg2/libsound_esd_plugin.so
+%%ESOUND%%lib/gg2/libsound_esd_plugin.so
lib/gg2/libsound_external_plugin.so
lib/gg2/libsound_oss_plugin.so
-%%TLEN:%%lib/gg2/libtlen_plugin.so
+%%TLEN%%lib/gg2/libtlen_plugin.so
lib/gg2/libupdate_plugin.so
-%%XOSD:%%lib/gg2/libxosd_plugin.so
+%%XOSD%%lib/gg2/libxosd_plugin.so
lib/libgg2_core.so
lib/libgg2_core.so.2
lib/libgg2_core.so.2.0.2
libdata/pkgconfig/gg2_core.pc
-%%DBUS:%%share/dbus-1/services/org.freedesktop.im.GG.service
+%%DBUS%%share/dbus-1/services/org.freedesktop.im.GG.service
share/applications/gg2.desktop
share/gg2/pixmaps/arrow.png
share/gg2/pixmaps/away.png