aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-05-22 21:15:13 +0800
committermat <mat@FreeBSD.org>2018-05-22 21:15:13 +0800
commitcff6da1b7fcbd896785c044bbdfe462c9fb1a74c (patch)
treec832b87b776a5db072088687b910601d961726da /science
parent9304895709a6f8eba3df00bc5410b6f5dbe8382f (diff)
downloadfreebsd-ports-graphics-cff6da1b7fcbd896785c044bbdfe462c9fb1a74c.tar.gz
freebsd-ports-graphics-cff6da1b7fcbd896785c044bbdfe462c9fb1a74c.tar.zst
freebsd-ports-graphics-cff6da1b7fcbd896785c044bbdfe462c9fb1a74c.zip
Add PY_FLAVOR to Python module dependencies.
Sponsored by: Absolight
Diffstat (limited to 'science')
-rw-r--r--science/dlib-cpp/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/science/dlib-cpp/Makefile b/science/dlib-cpp/Makefile
index 63cbe25c7f9..1380fb146db 100644
--- a/science/dlib-cpp/Makefile
+++ b/science/dlib-cpp/Makefile
@@ -43,7 +43,7 @@ BLASLAPACK_CMAKE_OFF= -DDLIB_USE_BLAS=0 -DDLIB_USE_LAPACK=0 -DDLIB_USE_MKL_FFT=0
# for PYTHON_PKGNAMEPREFIX
PYTHON_USES= python
-PYTHON_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dlib>=0:science/py-dlib
+PYTHON_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dlib>=0:science/py-dlib@${PY_FLAVOR}
PYTHON_NO_DEPENDS= yes
AVX_CMAKE_BOOL= USE_AVX_INSTRUCTIONS