aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2018-05-25 01:26:25 +0800
committerantoine <antoine@FreeBSD.org>2018-05-25 01:26:25 +0800
commit39415d28cbf32ae39232bcfaefff5f9decdc8374 (patch)
tree66f46d50eebedddb2a4df2872ab0c66794006777 /security
parente28970c3097856afdd8e941c1db832c4e2a4fbe8 (diff)
downloadfreebsd-ports-graphics-39415d28cbf32ae39232bcfaefff5f9decdc8374.tar.gz
freebsd-ports-graphics-39415d28cbf32ae39232bcfaefff5f9decdc8374.tar.zst
freebsd-ports-graphics-39415d28cbf32ae39232bcfaefff5f9decdc8374.zip
Update to 1.7.2rc1
Diffstat (limited to 'security')
-rw-r--r--security/py-rekall-core/Makefile42
-rw-r--r--security/py-rekall-core/distinfo6
-rw-r--r--security/py-rekall-core/files/patch-rekall_plugins_renderers_xls.py6
-rw-r--r--security/py-rekall-core/files/patch-setup.py80
-rw-r--r--security/py-rekall-core/pkg-message3
5 files changed, 70 insertions, 67 deletions
diff --git a/security/py-rekall-core/Makefile b/security/py-rekall-core/Makefile
index c003d41c4ee..38912cd237d 100644
--- a/security/py-rekall-core/Makefile
+++ b/security/py-rekall-core/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rekall-core
-PORTVERSION= 1.6.0
+DISTVERSION= 1.7.2rc1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,27 +13,29 @@ COMMENT= CORE component of the Rekall framework
LICENSE= GPLv2
RUN_DEPENDS= cabextract:archivers/cabextract \
- ${PYTHON_PKGNAMEPREFIX}artifacts>=20160114:security/py-artifacts@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyaff4>=0.24.p1:security/py-pyaff4@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}acora>=2.0:textproc/py-acora@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}arrow>=0.7.0:devel/py-arrow@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}efilter>=1.3,1:devel/py-efilter@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}intervaltree>=2.1.0:devel/py-intervaltree@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.6.1:security/py-pycrypto@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyelftools>=0.24:devel/py-pyelftools@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyparsing>=2.1.5:devel/py-pyparsing@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytz>=2016.4,1:devel/py-pytz@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}psutil>=4.0:sysutils/py-psutil@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}capstone>=3.0.4:devel/py-capstone@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}yara>=3.4.0:security/py-yara@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sortedcontainers>=1.4.4:devel/py-sortedcontainers@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytsk>=20160721:sysutils/py-pytsk@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}ipaddr>=2.1.11:devel/py-ipaddr@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}dateutil>=2.5.3:devel/py-dateutil@${FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}acora>=2.0:textproc/py-acora@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}arrow>=0.10.0:devel/py-arrow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}artifacts>=20170909:security/py-artifacts@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}future>=0:devel/py-future@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}intervaltree>=2.1.0:devel/py-intervaltree@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ipaddr>=2.2.0:devel/py-ipaddr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}parsedatetime>=2.4:devel/py-parsedatetime@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psutil>=5.0:sysutils/py-psutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyaff4>=0.25:security/py-pyaff4@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycryptodome>=3.4.7:security/py-pycryptodome@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyelftools>=0.24:devel/py-pyelftools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyparsing>=2.1.5:devel/py-pyparsing@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=2.6.1:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytsk>=20170802:sysutils/py-pytsk@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=2017.3,1:devel/py-pytz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}capstone>=3.0.4:devel/py-capstone@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rekall-efilter>=1.6:devel/py-rekall-efilter@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rekall_lib>=0:security/py-rekall_lib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yara>=3.6:security/py-yara@${PY_FLAVOR}
NO_ARCH= yes
-USES= python:2.7 zip
+USES= python zip
USE_PYTHON= distutils autoplist
.include <bsd.port.pre.mk>
diff --git a/security/py-rekall-core/distinfo b/security/py-rekall-core/distinfo
index 0372d8ca163..aa1811a3e18 100644
--- a/security/py-rekall-core/distinfo
+++ b/security/py-rekall-core/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1478284762
-SHA256 (rekall-core-1.6.0.zip) = 5428a100d218053c5a09391c94a09757e1c4db2ae46cf41da25e3c970f3e7745
-SIZE (rekall-core-1.6.0.zip) = 1065943
+TIMESTAMP = 1517734180
+SHA256 (rekall-core-1.7.2rc1.zip) = e85f994a6ef54003d3a5465a38d4dc72b7ab5c7057f69fbd93af4d683f682109
+SIZE (rekall-core-1.7.2rc1.zip) = 1294996
diff --git a/security/py-rekall-core/files/patch-rekall_plugins_renderers_xls.py b/security/py-rekall-core/files/patch-rekall_plugins_renderers_xls.py
index e83ba67079e..037942755a2 100644
--- a/security/py-rekall-core/files/patch-rekall_plugins_renderers_xls.py
+++ b/security/py-rekall-core/files/patch-rekall_plugins_renderers_xls.py
@@ -1,6 +1,6 @@
---- rekall/plugins/renderers/xls.py.orig 2015-10-23 12:57:00 UTC
+--- rekall/plugins/renderers/xls.py.orig 2017-11-05 21:24:44 UTC
+++ rekall/plugins/renderers/xls.py
-@@ -37,11 +37,11 @@ from rekall.ui import text
+@@ -44,11 +44,11 @@ if six.PY3:
# pylint: disable=unexpected-keyword-arg,no-value-for-parameter
# pylint: disable=redefined-outer-name
@@ -15,7 +15,7 @@
alignment=styles.Alignment(vertical="top", wrap_text=False))
-@@ -291,7 +291,7 @@ class XLSNoneObjectRenderer(XLSObjectRen
+@@ -299,7 +299,7 @@ class XLSNoneObjectRenderer(XLSObjectRen
class XLSDateTimeRenderer(XLSObjectRenderer):
"""Renders timestamps as python datetime objects."""
renders_type = "UnixTimeStamp"
diff --git a/security/py-rekall-core/files/patch-setup.py b/security/py-rekall-core/files/patch-setup.py
index 545c5568396..892dac7b4bb 100644
--- a/security/py-rekall-core/files/patch-setup.py
+++ b/security/py-rekall-core/files/patch-setup.py
@@ -1,48 +1,46 @@
---- setup.py.orig 2016-11-03 22:17:38 UTC
+--- setup.py.orig 2017-12-05 23:44:52 UTC
+++ setup.py
-@@ -51,27 +51,27 @@ def find_data_files(source):
+@@ -52,28 +52,28 @@ def find_data_files(source):
# approach ensures that any Rekall version will always work as tested - even
# when external packages are upgraded in an incompatible way.
install_requires = [
-- "artifacts == 20160114",
-- "pyaff4 >= 0.24, < 0.30",
-- "PyYAML == 3.11",
-- "acora == 2.0",
-- "arrow == 0.7.0",
-- "efilter == 1!1.3",
-- "intervaltree == 2.1.0",
-- "pycrypto == 2.6.1",
-- "pyelftools == 0.24",
-- "pyparsing==2.1.5",
-- "pytz == 2016.4",
-- "psutil >= 4.0, < 5.0",
-- "rekall-capstone == 3.0.4.post2",
-- "rekall-yara == 3.4.0.1",
-- "sortedcontainers == 1.4.4",
-- "pytsk3 == 20160721",
-- "ipaddr==2.1.11",
-+ "artifacts >= 20160114",
-+ "pyaff4 >= 0.24",
-+ "PyYAML >= 3.11",
-+ "acora >= 2.0",
-+ "arrow >= 0.7.0",
-+ "efilter >= 1!1.3",
-+ "intervaltree >= 2.1.0",
-+ "pycrypto >= 2.6.1",
-+ "pyelftools >= 0.24",
-+ "pyparsing>=2.1.5",
-+ "pytz >= 2016.4",
-+ "psutil >= 4.0",
-+ "capstone >= 3.0.4",
-+ "yara-python >= 3.4.0",
-+ "sortedcontainers >= 1.4.4",
-+ "pytsk3 >= 20160721",
-+ "ipaddr>=2.1.11",
+- 'PyYAML==3.12',
+- 'acora==2.0',
+- 'arrow==0.10.0',
+- 'artifacts==20170909',
++ 'PyYAML>=3.11',
++ 'acora>=2.0',
++ 'arrow>=0.10.0',
++ 'artifacts>=20170909',
+ 'future',
+- 'intervaltree==2.1.0',
+- 'ipaddr==2.2.0',
+- 'parsedatetime==2.4',
++ 'intervaltree>=2.1.0',
++ 'ipaddr>=2.2.0',
++ 'parsedatetime>=2.4',
+ "psutil >= 5.0, < 6.0",
+ 'pyaff4 >= 0.26, < 0.30',
+- 'pycryptodome==3.4.7',
+- 'pyelftools==0.24',
+- 'pyparsing==2.1.5',
+- 'python-dateutil==2.6.1',
+- 'pytsk3==20170802',
+- 'pytz==2017.3',
+- 'rekall-capstone==3.0.5.post2',
++ 'pycryptodome>=3.4.7',
++ 'pyelftools>=0.24',
++ 'pyparsing>=2.1.5',
++ 'python-dateutil>=2.6.1',
++ 'pytsk3>=20170802',
++ 'pytz>=2017.3',
++ 'capstone>=3.0.4',
+ "rekall-efilter >= 1.6, < 1.7",
- # Version 2.5.0 is broken with pyinstaller.
- # https://github.com/pyinstaller/pyinstaller/issues/1848
-- "python-dateutil == 2.5.3",
-+ "python-dateutil >= 2.5.3",
+ # Should match exactly the version of this package.
+ 'rekall-lib',
+- 'rekall-yara==3.6.3.1',
++ 'yara-python>=3.6.3.1',
]
- if "VIRTUAL_ENV" not in os.environ:
+
diff --git a/security/py-rekall-core/pkg-message b/security/py-rekall-core/pkg-message
new file mode 100644
index 00000000000..85a58717ddd
--- /dev/null
+++ b/security/py-rekall-core/pkg-message
@@ -0,0 +1,3 @@
+If you want to use online profile repositories using https, make sure that root
+certificates from certificate authorities are installed (via ca_root_nss for
+instance).