aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2018-05-14 23:59:03 +0800
committermiwi <miwi@FreeBSD.org>2018-05-14 23:59:03 +0800
commit59b49f8f4020b9191f846c5c0def4c87642d7b04 (patch)
treef32f4d7e49a18d637444a7efa264b8da410ed3d2 /security
parent3afe8928e4315e45e8280e693f23dc2f9e4ca545 (diff)
downloadfreebsd-ports-graphics-59b49f8f4020b9191f846c5c0def4c87642d7b04.tar.gz
freebsd-ports-graphics-59b49f8f4020b9191f846c5c0def4c87642d7b04.tar.zst
freebsd-ports-graphics-59b49f8f4020b9191f846c5c0def4c87642d7b04.zip
GSSAPI Negotiate HTTP authentication for Flask routes.
WWW: https://github.com/mkomitee/flask-kerberos PR: 225199 Submitted by: John W. O'Brien <john@saltant.com> Sponsored by: iXsystems Inc.
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-flask-kerberos/Makefile23
-rw-r--r--security/py-flask-kerberos/distinfo3
-rw-r--r--security/py-flask-kerberos/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 8cbb212a69e..297a6525f01 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -934,6 +934,7 @@
SUBDIR += py-fchksum
SUBDIR += py-first-server
SUBDIR += py-flask-httpauth
+ SUBDIR += py-flask-kerberos
SUBDIR += py-gixy
SUBDIR += py-gnupg
SUBDIR += py-gnutls
diff --git a/security/py-flask-kerberos/Makefile b/security/py-flask-kerberos/Makefile
new file mode 100644
index 00000000000..23a3bc83fbd
--- /dev/null
+++ b/security/py-flask-kerberos/Makefile
@@ -0,0 +1,23 @@
+# Created by: John W. O'Brien <john@saltant.com>
+# $FreeBSD$
+
+PORTNAME= Flask-Kerberos
+PORTVERSION= 1.0.4
+CATEGORIES= security www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= john@saltant.com
+COMMENT= GSSAPI Negotiate HTTP authentication for Flask routes
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>0:www/py-flask@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}kerberos>1.1.1:security/py-kerberos@${FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-flask-kerberos/distinfo b/security/py-flask-kerberos/distinfo
new file mode 100644
index 00000000000..d629dd6b3cc
--- /dev/null
+++ b/security/py-flask-kerberos/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1516061296
+SHA256 (Flask-Kerberos-1.0.4.tar.gz) = 6f641f2f534e2194f67a0a15155f9b492e173175f8785e57c373f8754f27ea75
+SIZE (Flask-Kerberos-1.0.4.tar.gz) = 4683
diff --git a/security/py-flask-kerberos/pkg-descr b/security/py-flask-kerberos/pkg-descr
new file mode 100644
index 00000000000..4e4ba44aaa8
--- /dev/null
+++ b/security/py-flask-kerberos/pkg-descr
@@ -0,0 +1,3 @@
+GSSAPI Negotiate HTTP authentication for Flask routes.
+
+WWW: https://github.com/mkomitee/flask-kerberos