aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2018-05-02 01:15:42 +0800
committerkrion <krion@FreeBSD.org>2018-05-02 01:15:42 +0800
commit6d20bb273f27a095f0c9f2831cbdea17401ab3ff (patch)
tree40673ab34a1179a2be2f0cf10b2ebf7c9ffe4a23 /security
parent051638480945a7b16d8658433cd78cb185bd8b1b (diff)
downloadfreebsd-ports-graphics-6d20bb273f27a095f0c9f2831cbdea17401ab3ff.tar.gz
freebsd-ports-graphics-6d20bb273f27a095f0c9f2831cbdea17401ab3ff.tar.zst
freebsd-ports-graphics-6d20bb273f27a095f0c9f2831cbdea17401ab3ff.zip
gopass is a rewrite of the pass password manager in Go with the aim
of making it cross-platform and adding additional features. PR: 227845 Submitted by: Sascha Holzleiter <sascha@root-login.org>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/gopass/Makefile38
-rw-r--r--security/gopass/distinfo3
-rw-r--r--security/gopass/pkg-descr6
4 files changed, 48 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index b1fb0e72cbb..aaaf9a2943a 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -186,6 +186,7 @@
SUBDIR += gnutls
SUBDIR += go-cve-dictionary
SUBDIR += go.crypto
+ SUBDIR += gopass
SUBDIR += goptlib
SUBDIR += gorilla
SUBDIR += govpn
diff --git a/security/gopass/Makefile b/security/gopass/Makefile
new file mode 100644
index 00000000000..5f4de5c48ed
--- /dev/null
+++ b/security/gopass/Makefile
@@ -0,0 +1,38 @@
+# Created by: Sascha Holzleiter <sascha@root-login.org>
+# $FreeBSD$
+
+PORTNAME= gopass
+PORTVERSION= 1.6.11
+DISTVERSIONPREFIX= v
+CATEGORIES= security
+
+MAINTAINER= sascha@root-login.org
+COMMENT= Gopass is a rewrite of the pass password manager in Go
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= gpg2:security/gnupg
+
+USES= go
+
+USE_GITHUB= yes
+GH_ACCOUNT= justwatchcom
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+
+PLIST_FILES= bin/gopass \
+ etc/bash_completion.d/gopass.sh \
+ share/zsh/site-functions/_gopass
+
+post-install:
+ @${STAGEDIR}${PREFIX}/bin/gopass completion bash > ${WRKDIR}/gopass.comp.sh
+ @${STAGEDIR}${PREFIX}/bin/gopass completion zsh > ${WRKDIR}/gopass.comp.zsh
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
+ ${INSTALL_DATA} ${WRKDIR}/gopass.comp.sh \
+ ${STAGEDIR}${PREFIX}/etc/bash_completion.d/gopass.sh
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions
+ ${INSTALL_DATA} ${WRKDIR}/gopass.comp.zsh \
+ ${STAGEDIR}${PREFIX}/share/zsh/site-functions/_gopass
+
+.include <bsd.port.mk>
diff --git a/security/gopass/distinfo b/security/gopass/distinfo
new file mode 100644
index 00000000000..103a7fce6e5
--- /dev/null
+++ b/security/gopass/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1524939284
+SHA256 (justwatchcom-gopass-v1.6.11_GH0.tar.gz) = 2199532b6a5f51960e6b3412ea196efb5e2d187b7cb436ecbbcff1a0ec4f9fc1
+SIZE (justwatchcom-gopass-v1.6.11_GH0.tar.gz) = 3988480
diff --git a/security/gopass/pkg-descr b/security/gopass/pkg-descr
new file mode 100644
index 00000000000..0c2db8c44f3
--- /dev/null
+++ b/security/gopass/pkg-descr
@@ -0,0 +1,6 @@
+The slightly more awesome Standard Unix Password Manager for teams.
+
+gopass is a rewrite of the pass password manager in Go with the aim
+of making it cross-platform and adding additional features.
+
+WWW: https://www.justwatch.com/gopass