aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2018-05-12 02:55:38 +0800
committerpi <pi@FreeBSD.org>2018-05-12 02:55:38 +0800
commite93e0668016a4207745b2a828ebdd05e57ab9f0c (patch)
tree87cd576b1003aa2883f618df427b201f8d6d1117 /security
parente2f7c92d77165d2623e585634b3fed7b58d286a1 (diff)
downloadfreebsd-ports-graphics-e93e0668016a4207745b2a828ebdd05e57ab9f0c.tar.gz
freebsd-ports-graphics-e93e0668016a4207745b2a828ebdd05e57ab9f0c.tar.zst
freebsd-ports-graphics-e93e0668016a4207745b2a828ebdd05e57ab9f0c.zip
New port: security/py-winrm
Python library for Windows Remote Management (WinRM) WWW: https://github.com/diyan/pywinrm PR: 226450 Submitted by: rozhuk.im@gmail.com
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-winrm/Makefile25
-rw-r--r--security/py-winrm/distinfo3
-rw-r--r--security/py-winrm/pkg-descr3
4 files changed, 32 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 7889c51a774..eacb32e07e8 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1027,6 +1027,7 @@
SUBDIR += py-virustotal-api
SUBDIR += py-volatility
SUBDIR += py-vulndb
+ SUBDIR += py-winrm
SUBDIR += py-yara
SUBDIR += py-yubioath-desktop
SUBDIR += py-yubikey-manager
diff --git a/security/py-winrm/Makefile b/security/py-winrm/Makefile
new file mode 100644
index 00000000000..b592266148e
--- /dev/null
+++ b/security/py-winrm/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= pywinrm
+PORTVERSION= 0.3.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rozhuk.im@gmail.com
+COMMENT= Python library for Windows Remote Management (WinRM)
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xmltodict>0:devel/py-xmltodict@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.9.1:www/py-requests@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests_ntlm>=0.3.0:www/py-requests_ntlm@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests-kerberos>=0.10.0:security/py-requests-kerberos@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests-credssp>=0.0.1:security/py-requests-credssp@${FLAVOR}
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/security/py-winrm/distinfo b/security/py-winrm/distinfo
new file mode 100644
index 00000000000..68d231800b6
--- /dev/null
+++ b/security/py-winrm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520511165
+SHA256 (pywinrm-0.3.0.tar.gz) = 799fc3e33fec8684443adf5778860388289102ea4fa1458f1bf307d167855573
+SIZE (pywinrm-0.3.0.tar.gz) = 25175
diff --git a/security/py-winrm/pkg-descr b/security/py-winrm/pkg-descr
new file mode 100644
index 00000000000..e4d8bf15d7c
--- /dev/null
+++ b/security/py-winrm/pkg-descr
@@ -0,0 +1,3 @@
+Python library for Windows Remote Management (WinRM)
+
+WWW: https://github.com/diyan/pywinrm