aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-09 22:03:00 +0800
committermiwi <miwi@FreeBSD.org>2013-02-09 22:03:00 +0800
commit274824141c382063940f5ccb4d395f7b49439233 (patch)
tree50b1f0f1d6ee8235e5ab3dc9a6bf4da0b6b8b75f /security
parent86ffba70f99e784f8c620b213168883ebbc098d3 (diff)
downloadfreebsd-ports-graphics-274824141c382063940f5ccb4d395f7b49439233.tar.gz
freebsd-ports-graphics-274824141c382063940f5ccb4d395f7b49439233.tar.zst
freebsd-ports-graphics-274824141c382063940f5ccb4d395f7b49439233.zip
- Update to 20121229
PR: 175103 Submitted by: maintainer
Diffstat (limited to 'security')
-rw-r--r--security/unhide/Makefile14
-rw-r--r--security/unhide/distinfo4
-rw-r--r--security/unhide/files/patch-Makefile16
3 files changed, 20 insertions, 14 deletions
diff --git a/security/unhide/Makefile b/security/unhide/Makefile
index dfcac9dfa54..bb49f05f5ce 100644
--- a/security/unhide/Makefile
+++ b/security/unhide/Makefile
@@ -6,15 +6,16 @@
#
PORTNAME= unhide
-PORTVERSION= 20110113
+PORTVERSION= 20121229
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}
+DISTNAME= ${PORTNAME}_${DISTVERSION}
EXTRACT_SUFX= .tgz
-MAINTAINER= ntarmos@cs.uoi.gr
+MAINTAINER= ntarmos@ceid.upatras.gr
COMMENT= A forensic tool to find hidden processes and TCP/UDP ports
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+NO_WRKSUBDIR= true
PLIST_FILES= sbin/unhide sbin/unhide-tcp
MAN8= unhide.8 unhide-tcp.8
MANCOMPRESSED= yes
@@ -22,8 +23,9 @@ MANCOMPRESSED= yes
.include <bsd.port.pre.mk>
pre-configure:
- @${REINPLACE_CMD} -e 's/-eLf/-axH/g' -e 's/$$2/$$1/g' ${WRKSRC}/unhide.c
- @${REINPLACE_CMD} -e 's/-t/-p tcp -/g' -e 's/-u/-p udp -/g' \
- ${WRKSRC}/unhide-tcp.c
+ @${REINPLACE_CMD} -e 's/-eLf/-axH/g' -e 's/$$2/$$1/g' ${WRKDIR}/unhide-posix.c
+ @${REINPLACE_CMD} -e 's/linux\/limits/limits/g' ${WRKDIR}/unhide-output.c
+ @${REINPLACE_CMD} -e 's/-tan/-p tcp -an/g' -e 's/-uan/-p udp -an/g' \
+ -e 's/use_ss = 1/use_ss = 0/g' ${WRKDIR}/unhide-tcp.c
.include <bsd.port.post.mk>
diff --git a/security/unhide/distinfo b/security/unhide/distinfo
index 3a64d4de132..2c983ef8849 100644
--- a/security/unhide/distinfo
+++ b/security/unhide/distinfo
@@ -1,2 +1,2 @@
-SHA256 (unhide-20110113.tgz) = 21ef6128232d02bba981acdf20f92b92258189f0660c4dac9a8d2dfdcc83e6ab
-SIZE (unhide-20110113.tgz) = 34207
+SHA256 (unhide_20121229.tgz) = fa2d1b4a7e9eb8dc987317566fac2c62a6b42e7bbd91f14a69efb26e3dde6b76
+SIZE (unhide_20121229.tgz) = 54700
diff --git a/security/unhide/files/patch-Makefile b/security/unhide/files/patch-Makefile
index 8f0b65d78b3..744f5b1d7d1 100644
--- a/security/unhide/files/patch-Makefile
+++ b/security/unhide/files/patch-Makefile
@@ -1,6 +1,6 @@
---- /dev/null 2009-02-26 16:27:00.000000000 +0200
-+++ Makefile 2009-02-26 16:26:45.000000000 +0200
-@@ -0,0 +1,19 @@
+--- /dev/null 2013-01-06 20:26:43.000000000 +0200
++++ Makefile 2013-01-06 20:26:46.000000000 +0200
+@@ -0,0 +1,23 @@
+DESTDIR := ${PREFIX}
+MANDIR := ${DESTDIR}/man
+INSTALL_PROGRAM := /usr/bin/install -s -m 0700
@@ -8,9 +8,13 @@
+GZIP_CMD := /usr/bin/gzip -9
+MKDIR_CMD := /bin/mkdir -p
+
-+all:
-+ gcc unhide.c -o unhide
-+ gcc unhide-tcp.c -o unhide-tcp
++all: unhide unhide-tcp
++
++unhide: unhide-posix.c
++ gcc -Wall -O2 --static unhide-posix.c -o unhide
++
++unhide-tcp: unhide-tcp.c unhide-tcp-fast.c unhide-output.c
++ gcc -Wall -O2 --static unhide-tcp.c unhide-tcp-fast.c unhide-output.c -o unhide-tcp
+
+install: all
+ ${MKDIR_CMD} ${DESTDIR}/sbin ${MANDIR}/man8