aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2011-11-29 22:56:21 +0800
committerscheidell <scheidell@FreeBSD.org>2011-11-29 22:56:21 +0800
commite555c7cb7ab5dee259255d15af7ca34694c6598c (patch)
tree7ce82ab5ced695393099de7f8d688aae9ff6c1df /security
parenta74b10edc6829b9a688e7fac0617b15b1d2b279a (diff)
downloadfreebsd-ports-graphics-e555c7cb7ab5dee259255d15af7ca34694c6598c.tar.gz
freebsd-ports-graphics-e555c7cb7ab5dee259255d15af7ca34694c6598c.tar.zst
freebsd-ports-graphics-e555c7cb7ab5dee259255d15af7ca34694c6598c.zip
- Submitter is now Maintainer
- There's one more commit after version 0.2 on github. After that, the software discontinued. This version is adopted by Debian - added alocal/automake - Committed with changed (added IGNORE for FreeBSD < 8.x since libusb 1.0 is needed, see libfprint) PR: 161225 Submitted by: Zhihao Yuan <lichray@gmail.com> Approved by: ports (maintainer timeout) gabor (mentor) Feature safe: yes
Diffstat (limited to 'security')
-rw-r--r--security/pam_fprint/Makefile25
-rw-r--r--security/pam_fprint/distinfo4
-rw-r--r--security/pam_fprint/files/patch-src_Makefile.am11
-rw-r--r--security/pam_fprint/files/patch-src_Makefile.in20
-rw-r--r--security/pam_fprint/files/patch-src_pam__fprint__enroll.c11
-rw-r--r--security/pam_fprint/files/patch-src_pam_fprint.c60
-rw-r--r--security/pam_fprint/files/pkg-message.in22
7 files changed, 100 insertions, 53 deletions
diff --git a/security/pam_fprint/Makefile b/security/pam_fprint/Makefile
index d9933ed6b29..b66f46e53fb 100644
--- a/security/pam_fprint/Makefile
+++ b/security/pam_fprint/Makefile
@@ -6,28 +6,41 @@
#
PORTNAME= pam_fprint
-PORTVERSION= 0.2
-PORTREVISION= 4
+PORTVERSION= 20080330
CATEGORIES= security
-MASTER_SITES= SF/fprint/${PORTNAME}/v${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_DEBIAN}
+MASTER_SITE_SUBDIR= pool/main/p/${PORTNAME:C/_/-/}
+DISTNAME= ${PORTNAME:C/_/-/}_${PORTVERSION}+git.orig
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= lichray@gmail.com
COMMENT= PAM module offering finger print authentication using libfprint
LIB_DEPENDS= fprint:${PORTSDIR}/security/libfprint
+USE_AUTOTOOLS= autoconf automake
+AUTOMAKE_ARGS= -a
CONFIGURE_ENV+= FPRINT_CFLAGS=-I${LOCALBASE}/include
GNU_CONFIGURE= yes
-USE_BZIP2= yes
USE_GNOME= pkgconfig
+WRKSRC= ${WRKDIR}
+
PLIST_FILES+= bin/pam_fprint_enroll \
lib/pam_fprint.so
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+IGNORE= dependency libfprint will not compile on FreeBsd < 8
+.endif
+
+pre-configure:
+ cd ${WRKDIR} && ${ACLOCAL}
+
post-install:
@${ECHO}
@${ECHO} =========================================================================
@@ -37,4 +50,4 @@ post-install:
@${ECHO} =========================================================================
@${ECHO}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/pam_fprint/distinfo b/security/pam_fprint/distinfo
index 8131e5daf04..b0a2d8fed6a 100644
--- a/security/pam_fprint/distinfo
+++ b/security/pam_fprint/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pam_fprint-0.2.tar.bz2) = 57cba8a951d4127e5be4c3b2ced0c1c6fac0201a08c833f1644f0ea2e3fa8a72
-SIZE (pam_fprint-0.2.tar.bz2) = 72781
+SHA256 (pam-fprint_20080330+git.orig.tar.gz) = c8204f47f49d0d931bef8226c8d3c6b7c72c31e20bbf59039c4e2ec7660805f3
+SIZE (pam-fprint_20080330+git.orig.tar.gz) = 16000
diff --git a/security/pam_fprint/files/patch-src_Makefile.am b/security/pam_fprint/files/patch-src_Makefile.am
new file mode 100644
index 00000000000..c8b3c85cc6e
--- /dev/null
+++ b/security/pam_fprint/files/patch-src_Makefile.am
@@ -0,0 +1,11 @@
+--- src/Makefile.am~ 2009-01-08 15:31:21.000000000 -0600
++++ src/Makefile.am 2011-10-02 01:51:52.845401986 -0500
+@@ -1,7 +1,6 @@
+-noinst_PROGRAMS = pamtest
+ bin_PROGRAMS = pam_fprint_enroll
+ pammod_PROGRAMS = pam_fprint.so
+-pammoddir=/lib/security
++pammoddir=$(PREFIX)/lib
+
+ pam_fprint_so_SOURCES = pam_fprint.c
+ pam_fprint_so_CFLAGS = -fPIC $(FPRINT_CFLAGS)
diff --git a/security/pam_fprint/files/patch-src_Makefile.in b/security/pam_fprint/files/patch-src_Makefile.in
deleted file mode 100644
index 54e5dd1891a..00000000000
--- a/security/pam_fprint/files/patch-src_Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/Makefile.in.orig 2007-11-19 20:15:11.000000000 +0100
-+++ src/Makefile.in 2008-04-12 18:44:55.000000000 +0200
-@@ -30,7 +30,7 @@
- NORMAL_UNINSTALL = :
- PRE_UNINSTALL = :
- POST_UNINSTALL = :
--noinst_PROGRAMS = pamtest$(EXEEXT)
-+noinst_PROGRAMS =
- bin_PROGRAMS = pam_fprint_enroll$(EXEEXT)
- pammod_PROGRAMS = pam_fprint.so$(EXEEXT)
- subdir = src
-@@ -163,7 +163,7 @@
- target_alias = @target_alias@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
--pammoddir = /lib/security
-+pammoddir = ${PREFIX}/lib
- pam_fprint_so_SOURCES = pam_fprint.c
- pam_fprint_so_CFLAGS = -fPIC $(FPRINT_CFLAGS)
- pam_fprint_so_LDFLAGS = -shared
diff --git a/security/pam_fprint/files/patch-src_pam__fprint__enroll.c b/security/pam_fprint/files/patch-src_pam__fprint__enroll.c
new file mode 100644
index 00000000000..6c4fccc4b6d
--- /dev/null
+++ b/security/pam_fprint/files/patch-src_pam__fprint__enroll.c
@@ -0,0 +1,11 @@
+--- src/pam_fprint_enroll.c~ 2009-01-08 15:31:21.000000000 -0600
++++ src/pam_fprint_enroll.c 2011-11-13 02:15:43.976691333 -0600
+@@ -47,7 +47,7 @@ static struct fp_dscv_dev *discover_devi
+ struct fp_dscv_dev *ddev = NULL;
+ int i;
+
+- for (i = 0; ddev = discovered_devs[i]; i++) {
++ for (i = 0; (ddev = discovered_devs[i]); i++) {
+ struct fp_driver *drv = fp_dscv_dev_get_driver(ddev);
+ printf("Found device claimed by %s driver\n",
+ fp_driver_get_full_name(drv));
diff --git a/security/pam_fprint/files/patch-src_pam_fprint.c b/security/pam_fprint/files/patch-src_pam_fprint.c
index 8601cae8565..12db7e3615f 100644
--- a/security/pam_fprint/files/patch-src_pam_fprint.c
+++ b/security/pam_fprint/files/patch-src_pam_fprint.c
@@ -1,6 +1,12 @@
---- src/pam_fprint.c.orig 2008-04-12 18:33:50.000000000 +0200
-+++ src/pam_fprint.c 2008-04-12 18:34:31.000000000 +0200
-@@ -23,7 +23,7 @@
+--- src/pam_fprint.c.orig 2009-01-08 15:31:21.000000000 -0600
++++ src/pam_fprint.c 2011-11-13 02:14:44.221692989 -0600
+@@ -18,15 +18,17 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <unistd.h>
+ #include <sys/types.h>
#include <pwd.h>
#include <string.h>
@@ -9,3 +15,51 @@
#define PAM_SM_AUTH
#include <security/pam_modules.h>
++#include <security/pam_appl.h>
+
+ static int send_info_msg(pam_handle_t *pamh, char *msg)
+ {
+@@ -41,10 +43,10 @@ static int send_info_msg(pam_handle_t *p
+
+ r = pam_get_item(pamh, PAM_CONV, (const void **) &pc);
+ if (r != PAM_SUCCESS)
+- return;
++ return r;
+
+ if (!pc || !pc->conv)
+- return;
++ return PAM_BUF_ERR;
+
+ return pc->conv(1, &msgp, &resp, pc->appdata_ptr);
+ }
+@@ -62,10 +64,10 @@ static int send_err_msg(pam_handle_t *pa
+
+ r = pam_get_item(pamh, PAM_CONV, (const void **) &pc);
+ if (r != PAM_SUCCESS)
+- return;
++ return r;
+
+ if (!pc || !pc->conv)
+- return;
++ return PAM_BUF_ERR;
+
+ return pc->conv(1, &msgp, &resp, pc->appdata_ptr);
+ }
+@@ -102,7 +104,7 @@ static struct fp_print_data **find_dev_a
+ struct fp_print_data **gallery;
+
+ /* TODO: add device selection */
+- while (print = prints[i++]) {
++ while ((print = prints[i++])) {
+ if (!ddev) {
+ ddev = fp_dscv_dev_for_dscv_print(ddevs, print);
+ driver_id = fp_dscv_print_get_driver_id(print);
+@@ -133,7 +135,7 @@ static struct fp_print_data **find_dev_a
+ }
+
+ i = 0, j = 0;
+- while (print = prints[i++]) {
++ while ((print = prints[i++])) {
+ driver_id_cur = fp_dscv_print_get_driver_id(print);
+ if (driver_id_cur == driver_id) {
+ err = fp_print_data_from_dscv_print(print, & (gallery[j]));
diff --git a/security/pam_fprint/files/pkg-message.in b/security/pam_fprint/files/pkg-message.in
index 587223f6759..65b776e6a82 100644
--- a/security/pam_fprint/files/pkg-message.in
+++ b/security/pam_fprint/files/pkg-message.in
@@ -1,25 +1,3 @@
-In order to enroll new finger prints, you must have r/w access to the
-usb device node(s) of your finger print reader (i.e., /dev/{ugen, usb*})
-(tested with UPEK finger print reader as found in Lenovo T61).
-
-It is recommended to use devfs.rules(5) and a dedicated group to manage
-access to your finger print reader.
-
-You can use `usbdevs -v' to see if your sensor is accessible.
-
-Example configuration:
-- /etc/rc.conf:
-devfs_system_ruleset="localrules"
-
-- /etc/devfs.rules:
-[localrules=10]
-add path 'ugen0*' mode 0660 group operator
-add path 'usb0*' mode 0660 group operator
-
-# /etc/rc.d/devfs restart
-
-Read `pam_fprint_enroll --help' to learn about enrolling fingers.
-
The security/fprint_demo port contains the graphical `fprint_demo'
application that allows you to manage your finger prints in a comfortable
way.