aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormmokhi <mmokhi@FreeBSD.org>2018-02-12 20:33:16 +0800
committermmokhi <mmokhi@FreeBSD.org>2018-02-12 20:33:16 +0800
commit7ffce65ff9db414d1bd9905a67b47c6cc9613b79 (patch)
tree3879e342ee3dc2071a61eae19643eb783e6363d0 /www
parentad901404ad2f0f873d226ad4e1ce5c7fc18540bf (diff)
downloadfreebsd-ports-graphics-7ffce65ff9db414d1bd9905a67b47c6cc9613b79.tar.gz
freebsd-ports-graphics-7ffce65ff9db414d1bd9905a67b47c6cc9613b79.tar.zst
freebsd-ports-graphics-7ffce65ff9db414d1bd9905a67b47c6cc9613b79.zip
www/mod_pagespeed: Fix undefined symbol error while loading module in apache24
tl;dr, The error is caused by the build-system in "apache24" case can not detect that FreeBSD supports "posix-sharedmem" in the pthread/libthr. Reported by: Marcarian Alexandru <marcarianalexandru@gmail.com> Sponsored by: Netzkommune GmbH
Diffstat (limited to 'www')
-rw-r--r--www/mod_pagespeed/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/www/mod_pagespeed/Makefile b/www/mod_pagespeed/Makefile
index 47b25620f49..dcdfa6592cd 100644
--- a/www/mod_pagespeed/Makefile
+++ b/www/mod_pagespeed/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mod_pagespeed
PORTVERSION= 1.12.34.2
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= www devel
MASTER_SITES= LOCAL/mmokhi:boringssl,chromium_base,chromium_build,googleurl,gflags_arch,gflags_src,libjpeg_turbo_src,yasm_patched,libwebp,modpb64 \
@@ -33,7 +33,7 @@ LIB_DEPENDS= libpng.so:graphics/png \
USES= compiler:c++14-lang gperf jpeg gmake localbase pkgconfig \
python shebangfix ssl tar:xz
-USE_APACHE= 24
+USE_APACHE= 22+
SHEBANG_GLOB= *.gyp *.gypi *.py *.sh
SHEBANG_FILES= build/fix_proto_and_invoke_protoc
@@ -48,6 +48,7 @@ BUILDTYPE= Release
MAKE_ENV+= BUILDTYPE=${BUILDTYPE}
CLR_VERSION= 20161024
GYP_DEFINES+= os_posix=1 \
+ support_posix_shared_mem=1 \
use_system_libs=1 \
use_system_protobuf=1 \
use_system_openssl=1 \