aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-04-30 01:37:48 +0800
committertcberner <tcberner@FreeBSD.org>2018-04-30 01:37:48 +0800
commitf7d0db247828c88831ee93a9e7d23faa6199d017 (patch)
treefe4663a4ea1fb85c2b3c59494003c28b241817b3 /x11-toolkits
parent8837b37adcdc364c0fa8b073cd7f14723f92109d (diff)
downloadfreebsd-ports-graphics-f7d0db247828c88831ee93a9e7d23faa6199d017.tar.gz
freebsd-ports-graphics-f7d0db247828c88831ee93a9e7d23faa6199d017.tar.zst
freebsd-ports-graphics-f7d0db247828c88831ee93a9e7d23faa6199d017.zip
New port: x11-toolkits/qml-box2d
* A QML plugin to write physics based software in QML.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/qml-box2d/Makefile18
-rw-r--r--x11-toolkits/qml-box2d/distinfo3
-rw-r--r--x11-toolkits/qml-box2d/pkg-descr8
-rw-r--r--x11-toolkits/qml-box2d/pkg-plist2
5 files changed, 32 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index dc481500e81..43992436744 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -222,6 +222,7 @@
SUBDIR += py-wxPython30
SUBDIR += py-xlib
SUBDIR += pypy-tkinter
+ SUBDIR += qml-box2d
SUBDIR += qt4-declarative
SUBDIR += qt4-gui
SUBDIR += qt4pas
diff --git a/x11-toolkits/qml-box2d/Makefile b/x11-toolkits/qml-box2d/Makefile
new file mode 100644
index 00000000000..a0e0846ec6f
--- /dev/null
+++ b/x11-toolkits/qml-box2d/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= qml-box2d
+DISTVERSION= 2.0.20180109
+CATEGORIES= x11-toolkits
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= QML Box2D plugin
+
+USES= qmake:outsource
+USE_GITHUB= yes
+GH_TAGNAME= 21e57f
+USE_GL= gl
+USE_QT5= core gui network qml quick \
+ buildtools_build qmake_build
+USE_LDCONFIG= ${QT_QMLDIR}/Box2D.2.0/
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/qml-box2d/distinfo b/x11-toolkits/qml-box2d/distinfo
new file mode 100644
index 00000000000..f5a504e49fb
--- /dev/null
+++ b/x11-toolkits/qml-box2d/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518295822
+SHA256 (qml-box2d-qml-box2d-2.0.20180109-21e57f_GH0.tar.gz) = 71b72949dd5a46fc1ba42c4de218d56c308733fa65ffb1319316503e41250f2f
+SIZE (qml-box2d-qml-box2d-2.0.20180109-21e57f_GH0.tar.gz) = 7768436
diff --git a/x11-toolkits/qml-box2d/pkg-descr b/x11-toolkits/qml-box2d/pkg-descr
new file mode 100644
index 00000000000..ef71b3c81f7
--- /dev/null
+++ b/x11-toolkits/qml-box2d/pkg-descr
@@ -0,0 +1,8 @@
+The goal of the qml-box2d plugin is to expose the functionality of Box2D (C++)
+as a QML plugin in order to make it easier to write physics based software in
+QML.
+
+This plugin is meant to be installed to your Qt/imports directory, or shipped
+in a directory of which the parent is added as import path.
+
+WWW: https://github.com/qml-box2d/qml-box2d
diff --git a/x11-toolkits/qml-box2d/pkg-plist b/x11-toolkits/qml-box2d/pkg-plist
new file mode 100644
index 00000000000..0e2d62e6a36
--- /dev/null
+++ b/x11-toolkits/qml-box2d/pkg-plist
@@ -0,0 +1,2 @@
+%%QT_QMLDIR%%/Box2D.2.0/libBox2D.so
+%%QT_QMLDIR%%/Box2D.2.0/qmldir