aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2016-11-22 20:04:48 +0800
committerdanfe <danfe@FreeBSD.org>2016-11-22 20:04:48 +0800
commit39e851fc4a1d69ef1db190ee5e008df9ab70a347 (patch)
tree988e8eb90eafe8cda3ba98a69885b0b95e641441 /x11-toolkits
parentb6a7dcb68c0e4ddb7d3703ae7c8fb5206b45ac6c (diff)
downloadfreebsd-ports-graphics-39e851fc4a1d69ef1db190ee5e008df9ab70a347.tar.gz
freebsd-ports-graphics-39e851fc4a1d69ef1db190ee5e008df9ab70a347.tar.zst
freebsd-ports-graphics-39e851fc4a1d69ef1db190ee5e008df9ab70a347.zip
x11-toolkits/fltk: ensure that binary packages have complete feature support
Previously, binary packages would miss Xinerama and Xcursor dependencies and thus were giving some odd behaviors as e.g. reported in the PR. While here, switch to USES+=localbase instead of manually amending CPPFLAGS and LDFLAGS. PR: 213294
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fltk/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index 0f4d6bb6c71..982c66139c4 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fltk
PORTVERSION= 1.3.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits
MASTER_SITES= http://fltk.org/pub/${PORTNAME}/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -15,8 +15,8 @@ LICENSE= LGPL20
LIB_DEPENDS= libpng.so:graphics/png
-USES= jpeg pkgconfig
-USE_XORG= xft
+USES= jpeg localbase pkgconfig
+USE_XORG= x11 xcursor xext xfixes xft xinerama
USE_GL= glu
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -24,9 +24,6 @@ CONFIGURE_ARGS= --enable-shared
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
PORTEXAMPLES= *
OPTIONS_DEFINE= EXAMPLES