aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-04 22:24:06 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-04 22:24:06 +0800
commitb38d55b829c4b5dd037165529f86aa0c44c127b4 (patch)
tree46339e1bce0140ec8f2811482e38fe9c99d9776e /x11-toolkits
parent7d4bc82a2876e7cfdd631d795a98a5071e75a08f (diff)
downloadfreebsd-ports-graphics-b38d55b829c4b5dd037165529f86aa0c44c127b4.tar.gz
freebsd-ports-graphics-b38d55b829c4b5dd037165529f86aa0c44c127b4.tar.zst
freebsd-ports-graphics-b38d55b829c4b5dd037165529f86aa0c44c127b4.zip
x11-toolkits/nucleo: oops, restore size check after r425305
PR: 207547
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/nucleo/Makefile2
-rw-r--r--x11-toolkits/nucleo/files/patch-nucleo__plugins__ffmpeg__ffmpegImageSink.cxx2
2 files changed, 2 insertions, 2 deletions
diff --git a/x11-toolkits/nucleo/Makefile b/x11-toolkits/nucleo/Makefile
index ca6d9e866d6..f23d6dff202 100644
--- a/x11-toolkits/nucleo/Makefile
+++ b/x11-toolkits/nucleo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nucleo
PORTVERSION= 0.7.6
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= x11-toolkits
MASTER_SITES= http://insitu.lri.fr/metisse/download/nucleo/
diff --git a/x11-toolkits/nucleo/files/patch-nucleo__plugins__ffmpeg__ffmpegImageSink.cxx b/x11-toolkits/nucleo/files/patch-nucleo__plugins__ffmpeg__ffmpegImageSink.cxx
index 36e8cf30cda..d88edcaf7f7 100644
--- a/x11-toolkits/nucleo/files/patch-nucleo__plugins__ffmpeg__ffmpegImageSink.cxx
+++ b/x11-toolkits/nucleo/files/patch-nucleo__plugins__ffmpeg__ffmpegImageSink.cxx
@@ -152,7 +152,7 @@
+
+ int got_packet = 0 ;
+ int ret = avcodec_encode_video2(cctx, &pkt, picture, &got_packet) ;
-+ if (ret) {
++ if (ret < 0 || !got_packet || pkt.size <= 0) {
+ std::cerr << "ffmpegImageSink: avcodec_encode_video2 failed" << std::endl ;
stop() ;
return false ;