aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-10-19 20:50:37 +0800
committerdanfe <danfe@FreeBSD.org>2015-10-19 20:50:37 +0800
commitd586f02ca6a8386f223bd4ab7c5ff4183630f5a7 (patch)
tree4482e97878fac4cdd8fdac1d66c6f8687ccaf2e6 /x11-wm
parent900158c82e8b436c38a1994d9239d19af5952b71 (diff)
downloadfreebsd-ports-graphics-d586f02ca6a8386f223bd4ab7c5ff4183630f5a7.tar.gz
freebsd-ports-graphics-d586f02ca6a8386f223bd4ab7c5ff4183630f5a7.tar.zst
freebsd-ports-graphics-d586f02ca6a8386f223bd4ab7c5ff4183630f5a7.zip
- Attempt to unbreak on PowerPC (verified) and SPARC (not verified)
- Use option helpers, GC no longer needed WANT_GNOME, sort USES, and include b.p.m. bits just once at the end - Drop explicit "support" for ia64: the port is marked broken on it, while the architecture itself was never a first-class citizen in FreeBSD and official killed in -CURRENT for a while now
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/golem/Makefile41
-rw-r--r--x11-wm/golem/files/patch-configure10
2 files changed, 21 insertions, 30 deletions
diff --git a/x11-wm/golem/Makefile b/x11-wm/golem/Makefile
index 1471652938a..98c10fd55b0 100644
--- a/x11-wm/golem/Makefile
+++ b/x11-wm/golem/Makefile
@@ -12,42 +12,31 @@ COMMENT= Small window manager with themes and plugins
LICENSE= BSD3CLAUSE
-OPTIONS_DEFINE= ESOUND XINERAMA
-OPTIONS_DEFAULT= XINERAMA
-
-USES= perl5 gmake tar:bzip2
+USES= gmake perl5 tar:bzip2
USE_PERL5= build
USE_XORG= xpm
-WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-i18n
MAKE_ARGS= DEVEL=1
-.include <bsd.port.pre.mk>
+CFLAGS_amd64= -fPIC
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
-CFLAGS+= -fPIC
-.endif
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
+OPTIONS_DEFINE= ESOUND XINERAMA
+OPTIONS_DEFAULT= XINERAMA
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MESOUND}
-USE_GNOME+= esound
-CONFIGURE_ARGS+=--enable-sound
-PLIST_SUB+= ESOUND=""
-.else
-PLIST_SUB+= ESOUND="@comment "
-.endif
+ESOUND_USE= GNOME=esound
+ESOUND_CONFIGURE_ON= --enable-sound
-.if ${PORT_OPTIONS:MXINERAMA}
-USE_XORG+= xinerama
-CONFIGURE_ARGS+=--enable-xinerama
-.endif
+XINERAMA_USE= XORG=xinerama
+XINERAMA_CONFIGURE_ON= --enable-xinerama
post-patch:
- @${REINPLACE_CMD} -e \
- '/cl_thread.c/d' ${WRKSRC}/complib/user/Makefile
+ @${REINPLACE_CMD} -e '/cl_thread\.c/d' ${WRKSRC}/complib/user/Makefile
+ @${REINPLACE_CMD} -e 's,^#include.*,typedef struct { \
+ int counter; } atomic_t;,' \
+ ${WRKSRC}/complib/asm-generic/cl_atomic_asm.h \
+ ${WRKSRC}/complib/asm-ppc/cl_atomic_asm.h
# avoid using standard MAKE_ENV
do-build:
@@ -60,4 +49,4 @@ do-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/golem
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/golem/plugins/*.so
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/golem/files/patch-configure b/x11-wm/golem/files/patch-configure
index a2376d3ea4e..89a43e15255 100644
--- a/x11-wm/golem/files/patch-configure
+++ b/x11-wm/golem/files/patch-configure
@@ -1,10 +1,12 @@
---- configure.orig 2006-03-02 03:59:55.000000000 +0900
-+++ configure 2011-08-13 07:46:25.000000000 +0900
-@@ -5669,6 +5669,7 @@
+--- configure.orig 2006-03-01 18:59:55 UTC
++++ configure
+@@ -5669,7 +5669,8 @@ test -n "$target_alias" &&
COMPLIB_ARCH=CONFIG_GENERIC
case "$target" in
i386* | i486* | i686* ) COMPLIB_ARCH=CONFIG_X86;;
+-ppc* ) COMPLIB_ARCH=CONFIG_PPC;;
+amd64* ) COMPLIB_ARCH=CONFIG_X86_64;;
- ppc* ) COMPLIB_ARCH=CONFIG_PPC;;
++powerpc* ) COMPLIB_ARCH=CONFIG_PPC;;
esac
+