aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-11-25 06:12:52 +0800
committeryuri <yuri@FreeBSD.org>2017-11-25 06:12:52 +0800
commitc267b30243b06000f1ffa7d8b8dde7c8bbcfe6b4 (patch)
treefd7d7ee0dfb81a90d419c9d5f4f4b5285c98c885 /x11
parent280ebad7d5131a372362b5169b62c72cc1cf3b1f (diff)
downloadfreebsd-ports-graphics-c267b30243b06000f1ffa7d8b8dde7c8bbcfe6b4.tar.gz
freebsd-ports-graphics-c267b30243b06000f1ffa7d8b8dde7c8bbcfe6b4.tar.zst
freebsd-ports-graphics-c267b30243b06000f1ffa7d8b8dde7c8bbcfe6b4.zip
New port: x11/xcape: Configure modifier keys to act as other keys when pressed on their own
PR: 222602 Submitted by: Greg V <greg@unrelenting.technology> Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13165
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xcape/Makefile28
-rw-r--r--x11/xcape/distinfo3
-rw-r--r--x11/xcape/pkg-descr5
4 files changed, 37 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 931d1615929..528902b6e57 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -368,6 +368,7 @@
SUBDIR += xbrightness
SUBDIR += xcalc
SUBDIR += xcalib
+ SUBDIR += xcape
SUBDIR += xcb
SUBDIR += xcb-proto
SUBDIR += xcb-util
diff --git a/x11/xcape/Makefile b/x11/xcape/Makefile
new file mode 100644
index 00000000000..3e95e819ef7
--- /dev/null
+++ b/x11/xcape/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= xcape
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2-9
+DISTVERSIONSUFFIX= -g6ded5b4
+CATEGORIES= x11
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= Configure modifier keys to act as other keys when pressed on their own
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= alols
+
+USES= pkgconfig
+USE_XORG= x11 xtst
+
+MAKE_ARGS= PREFIX=${PREFIX} MANDIR=/man/man1
+
+PLIST_FILES= bin/xcape man/man1/xcape.1.gz
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/xcape
+
+.include <bsd.port.mk>
diff --git a/x11/xcape/distinfo b/x11/xcape/distinfo
new file mode 100644
index 00000000000..535b4c54aa3
--- /dev/null
+++ b/x11/xcape/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1511147599
+SHA256 (alols-xcape-v1.2-9-g6ded5b4_GH0.tar.gz) = 81793950033972a799d8701e6cc579ad75b22a02fe00db603170caa874a1e80c
+SIZE (alols-xcape-v1.2-9-g6ded5b4_GH0.tar.gz) = 18904
diff --git a/x11/xcape/pkg-descr b/x11/xcape/pkg-descr
new file mode 100644
index 00000000000..895c357f664
--- /dev/null
+++ b/x11/xcape/pkg-descr
@@ -0,0 +1,5 @@
+xcape allows you to use a modifier key as another key when pressed and released
+on its own. The default behaviour is to generate the Escape key when Left
+Control is pressed and released on its own.
+
+WWW: https://github.com/alols/xcape