aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2017-05-27 11:16:40 +0800
committerdanfe <danfe@FreeBSD.org>2017-05-27 11:16:40 +0800
commitd37079d243d7fb726fa30db6c8e4565721f069fe (patch)
treed4b3a3431a0af76699fa805a8c9f6024dec01887 /x11
parent926c4f78a1bdc9089fa9293b821198efcc629a24 (diff)
downloadfreebsd-ports-graphics-d37079d243d7fb726fa30db6c8e4565721f069fe.tar.gz
freebsd-ports-graphics-d37079d243d7fb726fa30db6c8e4565721f069fe.tar.zst
freebsd-ports-graphics-d37079d243d7fb726fa30db6c8e4565721f069fe.zip
Add another GTK+ 2.0 based X11 keyboard layout indicator and switcher.
WWW: http://sourceforge.net/projects/gxkb/ TIMESTAMP (gxkb-0.7.9.tar.gz) = 1490048003
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/gxkb/Makefile32
-rw-r--r--x11/gxkb/distinfo3
-rw-r--r--x11/gxkb/pkg-descr9
-rw-r--r--x11/gxkb/pkg-plist37
5 files changed, 82 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 2ad40254a8b..a42e6380931 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -99,6 +99,7 @@
SUBDIR += gtkchtheme
SUBDIR += gtkterm2
SUBDIR += guake
+ SUBDIR += gxkb
SUBDIR += hs-X11
SUBDIR += hs-X11-xft
SUBDIR += hs-xmobar
diff --git a/x11/gxkb/Makefile b/x11/gxkb/Makefile
new file mode 100644
index 00000000000..91be4a873ad
--- /dev/null
+++ b/x11/gxkb/Makefile
@@ -0,0 +1,32 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gxkb
+PORTVERSION= 0.7.9
+CATEGORIES= x11
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= X11 keyboard layout indicator and switcher
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libxklavier.so:x11/libxklavier \
+ libwnck-1.so:x11-toolkits/libwnck
+
+USES= pkgconfig
+GNU_CONFIGURE= yes
+USE_GNOME= gdkpixbuf2 glib20 gtk20
+
+PORTDOCS= AUTHORS NEWS
+
+OPTIONS_DEFINE= DOCS
+
+post-patch-DOCS-on:
+ @${REINPLACE_CMD} -e '/^doc_DATA/s, C[^ ]*,,g' \
+ ${WRKSRC}/doc/Makefile.in
+
+post-patch-DOCS-off:
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s, doc,,' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/x11/gxkb/distinfo b/x11/gxkb/distinfo
new file mode 100644
index 00000000000..f20af0ea0c3
--- /dev/null
+++ b/x11/gxkb/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1490048003
+SHA256 (gxkb-0.7.9.tar.gz) = 63a980403417eab83de7175beeece1544ebe1f49e5dd812fb55148a22cf7f035
+SIZE (gxkb-0.7.9.tar.gz) = 172819
diff --git a/x11/gxkb/pkg-descr b/x11/gxkb/pkg-descr
new file mode 100644
index 00000000000..2e7a68776ea
--- /dev/null
+++ b/x11/gxkb/pkg-descr
@@ -0,0 +1,9 @@
+gxkb is a little indicator applet which allows one to quickly switch
+between different keyboard layouts in X11. A flag corresponding to
+the country of the active layout is shown in the indicator area.
+
+The applet is written in C and uses GTK+ 2.0 library (and therefore
+does not depend on any GNOME components) and can maintain separate
+per-window or per-window layouts.
+
+WWW: http://sourceforge.net/projects/gxkb/
diff --git a/x11/gxkb/pkg-plist b/x11/gxkb/pkg-plist
new file mode 100644
index 00000000000..35cf1aab598
--- /dev/null
+++ b/x11/gxkb/pkg-plist
@@ -0,0 +1,37 @@
+bin/gxkb
+man/man1/gxkb.1.gz
+share/applications/gxkb.desktop
+%%DATADIR%%/flags/am.png
+%%DATADIR%%/flags/bg.png
+%%DATADIR%%/flags/by.png
+%%DATADIR%%/flags/cz.png
+%%DATADIR%%/flags/de.png
+%%DATADIR%%/flags/ee.png
+%%DATADIR%%/flags/es.png
+%%DATADIR%%/flags/fi.png
+%%DATADIR%%/flags/fr.png
+%%DATADIR%%/flags/gb.png
+%%DATADIR%%/flags/ge.png
+%%DATADIR%%/flags/gr.png
+%%DATADIR%%/flags/hr.png
+%%DATADIR%%/flags/hu.png
+%%DATADIR%%/flags/is.png
+%%DATADIR%%/flags/it.png
+%%DATADIR%%/flags/kz.png
+%%DATADIR%%/flags/lt.png
+%%DATADIR%%/flags/lv.png
+%%DATADIR%%/flags/no.png
+%%DATADIR%%/flags/pl.png
+%%DATADIR%%/flags/pt.png
+%%DATADIR%%/flags/ro.png
+%%DATADIR%%/flags/ru.png
+%%DATADIR%%/flags/se.png
+%%DATADIR%%/flags/si.png
+%%DATADIR%%/flags/sk.png
+%%DATADIR%%/flags/sr.png
+%%DATADIR%%/flags/ua.png
+%%DATADIR%%/flags/us.png
+%%DATADIR%%/flags/uz.png
+%%DATADIR%%/flags/zz.png
+%%DATADIR%%/logo.png
+share/pixmaps/gxkb.xpm