aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES9
-rw-r--r--Mk/bsd.port.mk9
2 files changed, 17 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 9193e34427a..bd8462e49b4 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,15 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20130422:
+AUTHOR: bdrewery@FreeBSD.org
+
+ * The entry for 20120830 to change CCACHE_DIR was not fully supported
+ by all ports. There is now a CCACHE_DIR variable that can be used
+ in /etc/make.conf for more complete coverage:
+
+ CCACHE_DIR=/var/cache/ccache
+
20130323:
AUTHOR: bapt@FreeBSD.org
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 52329004546..e315b1e1231 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -940,6 +940,8 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
#
# WITH_CCACHE_BUILD
# - Enable CCACHE support (devel/ccache). User settable.
+# CCACHE_DIR
+# - Which directory to use for ccache (default: $HOME/.ccache)
# NO_CCACHE
# - Disable CCACHE support for example for certain ports if
# CCACHE is enabled. User settable.
@@ -2245,7 +2247,12 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/ccache:${PORTSDIR}/devel/ccache
. endif
# Prepend the ccache dir into the PATH and setup ccache env
-MAKE_ENV+= PATH=${LOCALBASE}/libexec/ccache:${PATH}
+MAKE_ENV+= PATH=${LOCALBASE}/libexec/ccache:${PATH}
+CONFIGURE_ENV+= PATH=${LOCALBASE}/libexec/ccache:${PATH}
+. if defined(CCACHE_DIR)
+MAKE_ENV+= CCACHE_DIR="${CCACHE_DIR}"
+CONFIGURE_ENV+= CCACHE_DIR="${CCACHE_DIR}"
+. endif
.endif
PTHREAD_CFLAGS?=