aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/firebird25-server/Makefile28
-rw-r--r--databases/firebird25-server/files/patch-builds_posix_make.defaults (renamed from databases/firebird25-server/files/patch-builds-posix_make.defaults)21
-rw-r--r--databases/firebird25-server/files/patch-builds_posix_make.rules11
3 files changed, 43 insertions, 17 deletions
diff --git a/databases/firebird25-server/Makefile b/databases/firebird25-server/Makefile
index 87e2e0a74ab..b595dfba199 100644
--- a/databases/firebird25-server/Makefile
+++ b/databases/firebird25-server/Makefile
@@ -3,6 +3,7 @@
PORTNAME= firebird
PORTVERSION= 2.5.4
+PORTREVISION= 1
CATEGORIES?= databases
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:S/.0//}-Release/
PKGNAMESUFFIX?= ${PORTVERSION:R:S/.//}-server
@@ -12,6 +13,15 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT?= Firebird-2 relational database (server)
+LICENSE= IDPL IPL
+LICENSE_COMB= multi
+LICENSE_NAME_IDPL= Initial Developer's Public License
+LICENSE_NAME_IPL= InterBase Public License
+LICENSE_FILE_IDPL= ${WRKSRC}/builds/install/misc/IDPLicense.txt
+LICENSE_FILE_IPL= ${WRKSRC}/builds/install/misc/IPLicense.txt
+LICENSE_PERMS_IDPL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_PERMS_IPL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
CONFLICTS?= ${PORTNAME}20-client-* \
${PORTNAME}21-client-* \
${PORTNAME}20-server-* \
@@ -19,7 +29,7 @@ CONFLICTS?= ${PORTNAME}20-client-* \
LIB_DEPENDS= libicuuc.so:${PORTSDIR}/devel/icu
-USES= bison tar:bzip2 gmake
+USES= gmake pkgconfig tar:bzip2
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
@@ -37,10 +47,10 @@ CONFIGURE_ARGS= --with-system-editline \
--with-fbsbin=${PREFIX}/sbin \
--with-fbsecure-db=${LOCALSTATEDIR} \
--with-fbudf=${LIBEXECDIR}/UDF
-CONFIGURE_ENV+= PTHREAD_LIBS="-lpthread"
-
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= PTHREAD_LIBS="-lpthread" \
+ ac_cv_header_atomic_ops_h="no" \
+ ac_cv_lib_atomic_ops_main="no" \
+ ac_cv_lib_edit_readline="yes"
LOCALSTATEDIR= /var/db/firebird
CONFDIR= etc/firebird
@@ -69,6 +79,7 @@ IGNORE= your system does not support sysvipc
.if !defined(CLIENT_ONLY)
# Server part stuff
+BUILD_DEPENDS= ${LOCALBASE}/lib/libedit.so:${PORTSDIR}/devel/libedit
LIB_DEPENDS+= libfbembed.so:${PORTSDIR}/databases/firebird25-client
CONFIGURE_ARGS+=--enable-superserver
@@ -87,11 +98,11 @@ UDF_SQL= src/extlib/ib_udf2.sql src/extlib/fbudf/fbudf.sql
PKGINSTALL?= ${PKGDIR}/pkg-install-server
.else
# Client part stuff
+LIB_DEPENDS+= libedit.so.0:${PORTSDIR}/devel/libedit
+
ALL_TARGET= firebird_basic libfbembed libfbclient embed_isql embed_gpre \
embed_gdef embed_qli extlib
-USES+= libedit
-
USE_LDCONFIG= yes
CLIENT_BIN= gpre isql-fb qli
@@ -107,9 +118,6 @@ FB_DOCS_DIRS= sql.extensions license upgrade
MAKE_ENV+= FIREBIRD_TMP="${WRKDIR}" FIREBIRD_LOCK="${WRKDIR}"
MAKE_ARGS+= PREFIX="${STAGEDIR}${PREFIX}"
-post-extract:
- @${RM} -rf ${WRKSRC}/extern/icu
-
post-patch:
${FIND} ${WRKSRC} -name "*.sh" -exec ${CHMOD} +x {} \+
${REINPLACE_CMD} -e \
diff --git a/databases/firebird25-server/files/patch-builds-posix_make.defaults b/databases/firebird25-server/files/patch-builds_posix_make.defaults
index 3ff86f6392c..9731eb9ceb4 100644
--- a/databases/firebird25-server/files/patch-builds-posix_make.defaults
+++ b/databases/firebird25-server/files/patch-builds_posix_make.defaults
@@ -1,6 +1,6 @@
---- builds/posix/make.defaults 2010-09-08 03:41:23.000000000 -0500
-+++ builds/posix/make.defaults 2010-12-18 20:25:29.000000000 -0500
-@@ -127,7 +127,7 @@
+--- builds/posix/make.defaults.orig 2015-03-27 13:46:38 UTC
++++ builds/posix/make.defaults
+@@ -126,7 +126,7 @@ RM_R= rm -rf
CHMOD= chmod
CHMOD_6= chmod 666
CHMOD_7= chmod 777
@@ -9,16 +9,23 @@
MV= mv -f
TOUCH= touch
CP= cp
-@@ -153,7 +153,7 @@
- STATICEXE_LINK:= @CXX@ $(GLOB_OPTIONS)
+@@ -152,7 +152,7 @@ EXE_LINK:= @CXX@ $(GLOB_OPTIONS) $(CXXFL
+ STATICEXE_LINK:= @CXX@ $(GLOB_OPTIONS) $(CXXFLAGS)
LINK_LIBS = @LIBS@
-ICU_LIBS = -licuuc -licudata -licui18n
-+ICU_LIBS = `icu-config --ldflags-libsonly` `icu-config --ldflags-searchpath`
++ICU_LIBS = $(shell icu-config --ldflags)
STATICLINK_LIBS = @LIBS@
SO_LINK_LIBS = @LIBS@
-@@ -230,10 +230,6 @@
+@@ -223,16 +223,12 @@ LIBFBSTATIC_A = $(LIB)/libfbstatic.a
+
+ ifeq ($(EDITLINE_FLG),Y)
+ ifeq ($(STD_EDITLINE), true)
+- LIBEDITLINE := -l$(READLINE)
++ LIBEDITLINE := $(shell pkgconf libedit --libs)
+ else
+ LIBEDITLINE := $(LIB)/libedit.a
endif
endif
diff --git a/databases/firebird25-server/files/patch-builds_posix_make.rules b/databases/firebird25-server/files/patch-builds_posix_make.rules
new file mode 100644
index 00000000000..979a901d39c
--- /dev/null
+++ b/databases/firebird25-server/files/patch-builds_posix_make.rules
@@ -0,0 +1,11 @@
+--- builds/posix/make.rules.orig 2015-03-27 13:46:38 UTC
++++ builds/posix/make.rules
+@@ -37,6 +37,8 @@ WFLAGS:=$(CPPFLAGS) -I$(SRC_ROOT)/includ
+
+ ifeq ($(STD_ICU),false)
+ WFLAGS:= $(WFLAGS) -I$(ROOT)/extern/icu/source/common -I$(ROOT)/extern/icu/source/i18n
++else
++ WFLAGS:= $(WFLAGS) $(shell icu-config --cppflags)
+ endif
+
+ ifeq ($(IsProdTypeBuild),Y)