aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--archivers/lzo/Makefile7
-rw-r--r--archivers/lzo/files/patch-util-check.sh11
2 files changed, 17 insertions, 1 deletions
diff --git a/archivers/lzo/Makefile b/archivers/lzo/Makefile
index 367aafb9efe..ca5138ff3dd 100644
--- a/archivers/lzo/Makefile
+++ b/archivers/lzo/Makefile
@@ -17,10 +17,15 @@ MAINTAINER= matthias.andree@gmx.de
COMMENT= Portable speedy, lossless data compression library
USE_AUTOTOOLS= libtool:15
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
USE_LDCONFIG= yes
+post-build:
+ @${ECHO_MSG} "===> Running self-tests for ${PKGNAME} (can take a few minutes)"
+ @# override MALLOC_OPTIONS, else tests take excessively long
+ cd ${WRKSRC} && ${SETENV} MALLOC_OPTIONS=jz ${MAKE} check test
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/archivers/lzo/files/patch-util-check.sh b/archivers/lzo/files/patch-util-check.sh
new file mode 100644
index 00000000000..d661772ff00
--- /dev/null
+++ b/archivers/lzo/files/patch-util-check.sh
@@ -0,0 +1,11 @@
+--- ./util/check.sh~ 2009-01-04 10:28:23.000000000 +0100
++++ ./util/check.sh 2009-01-04 10:33:34.000000000 +0100
+@@ -13,7 +13,7 @@
+ LTEST="ltest"
+ test -x ./ltest/ltest && LTEST="./ltest/ltest"
+ test -x ./ltest.exe && LTEST="./ltest.exe"
+-LFLAGS="-q -n2"
++LFLAGS="-Q -n2"
+
+ dir="${*-.}"
+