aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/9base/Makefile36
-rw-r--r--devel/9base/distinfo3
-rw-r--r--devel/9base/pkg-descr8
-rw-r--r--devel/9base/pkg-message8
-rw-r--r--devel/Makefile1
5 files changed, 56 insertions, 0 deletions
diff --git a/devel/9base/Makefile b/devel/9base/Makefile
new file mode 100644
index 00000000000..0fc9121294a
--- /dev/null
+++ b/devel/9base/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: 9base
+# Date created: 4 March 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= 9base
+DISTVERSION= b20060209
+CATEGORIES= devel
+MASTER_SITES= CSME
+#http://www.suckless.org/cgi-bin/hgwebdir.cgi/9base/
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Port of various original plan9 tools
+
+USE_BZIP2= yes
+CFLAGS+= -I. -c
+LDFLAGS+= -L.
+MANPREFIX= ${PREFIX}/9
+MAKE_ARGS= PREFIX="${PREFIX}/9" CC="${CC}" MANPREFIX="${MANPREFIX}/man" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+APPS= awk basename bc cat cleanname date dc echo grep ls mk rc read sed seq\
+ sleep sort tee test touch tr uniq yacc
+#MAN1= ${APPS:S|$|.1|}
+PLIST_FILES= ${APPS:S|^|9/bin/|} ${APPS:S|^|9/man/man1/|:S|$|.1|} 9/man/man7/regexp.7 9/etc/rcmain
+PLIST_DIRS= 9/bin 9/etc 9/man/man1 9/man/man7 9/man 9
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|PREFIX|"${PREFIX}/9"|' ${WRKSRC}/rc/plan9ish.c
+ @${REINPLACE_CMD} -e '/OBJTYPE!=/s|!=.*|=${ARCH:S,i386,386,:S,amd64,x86_64,:S,sparc64,sun4u,}|' ${WRKSRC}/lib9/Makefile
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/devel/9base/distinfo b/devel/9base/distinfo
new file mode 100644
index 00000000000..f875c8f45e4
--- /dev/null
+++ b/devel/9base/distinfo
@@ -0,0 +1,3 @@
+MD5 (9base-b20060209.tar.bz2) = 104599556fc8e2920b75d62058681047
+SHA256 (9base-b20060209.tar.bz2) = 23a939c76c2313d4eb8a1022f5adae99f0625569683da998a5bcdad436ca31ce
+SIZE (9base-b20060209.tar.bz2) = 245770
diff --git a/devel/9base/pkg-descr b/devel/9base/pkg-descr
new file mode 100644
index 00000000000..e38be9b6d2e
--- /dev/null
+++ b/devel/9base/pkg-descr
@@ -0,0 +1,8 @@
+This is a port of various original plan9 tools to Unix based on
+plan9ports [1], mk-with-libs.tgz [2] and wmii [3].
+
+[1] http://www.swtch.com/plan9port/
+[2] http://swtch.com/plan9port/unix/
+[3] http://www.suckless.org/wiki/wmii
+
+WWW: http://www.suckless.org/wiki/wmii/download
diff --git a/devel/9base/pkg-message b/devel/9base/pkg-message
new file mode 100644
index 00000000000..fe788013769
--- /dev/null
+++ b/devel/9base/pkg-message
@@ -0,0 +1,8 @@
+======================================================
+
+Some of 9base tools require fdescfs to be mounted.
+Place "fdescfs /dev/fd fdescfs rw 0 0" into your
+fstab(5) file and run "mount /dev/fd". See fdescfs(5)
+for more.
+
+======================================================
diff --git a/devel/Makefile b/devel/Makefile
index 44987823ae0..a7968353c92 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3,6 +3,7 @@
COMMENT = Development utilities
+ SUBDIR += 9base
SUBDIR += ElectricFence
SUBDIR += ORBit
SUBDIR += ORBit2
6cd1f77246e263e'>Update to 1.16.1. User-visible changes:naddy2006-12-145-161/+5 * Fix GNUTYPE_NAMES directory traversal vulnerability by not extractingnaddy2006-12-012-1/+17 * dirrmtry some directories which will be leftover on deinstall.tmclaugh2006-11-162-0/+5 * Update to 1.16. User-visible changes:naddy2006-11-1410-208/+175 * Fix build on 4.x.naddy2006-03-191-8/+19 * Fix a buffer overflow, caused by improper bounds checking of thenaddy2006-03-042-1/+125 * SHA256ifyedwin2006-01-221-0/+1 * Fix command line parsing.naddy2005-01-302-0/+18 * Update to 1.15.1. Notable changes:naddy2005-01-105-3/+47 * Remove USE_GETTEXTkrion2004-07-111-1/+0 * Support WITHOUT_NLSkrion2004-07-112-28/+36 * Update to 1.14, the first new official release in almost five years.naddy2004-05-153-5/+8 * Update to 1.13.94 and jettison private FreeBSD modifications.naddy2004-04-2914-561/+27 * Add size data, approved by maintainers.trevor2004-03-191-0/+1 * Add USE_GETTEXT and bump PORTREVISION.marcus2004-02-041-3/+2 * Now gettext 0.12.1 is gettext-old.trevor2004-01-241-1/+1 * introduce MASTER_SITE_GNU_ALPHAijliao2003-10-311-2/+2 * Bump the PORTREVISION for the ports directly affected by the gettext upgrade.marcus2003-08-271-1/+1 * Chase the libintl.so shared lib version.marcus2003-08-251-1/+1 * Utilize INFO and bump PORTREVISION.kris2003-08-162-4/+3 * IGNORE while this is identical to the base system tar.naddy2003-06-121-1/+7 * pkg-comment -> COMMENTnaddy2003-02-212-1/+1 * Removed stale master_site, informed maintainer.edwin2002-12-281-1/+0 * Fix a security bug that allows extracted filenames to contain ".." andkris2002-10-053-12/+44 * Chase shlib rev of devel/gettextade2002-08-021-1/+1 * Sync with src/contrib/tar - re-enable --same-owner for uid 0.sobomax2002-06-072-7/+6 * Sync with src/contrib/tar - don't assume that user with uid 0 doesn't reallysobomax2002-06-072-1/+29 * Unbroke on systems without <langinfo.h>.sobomax2002-06-041-7/+9 * Stage 1 of system GNU tar upgrade to a modern version:sobomax2002-06-0210-1/+417 * gettext upgrade uber-patch (stage 3)ade2002-04-131-1/+2 * Stage 1 of gettext update.ade2002-03-161-1/+1 * Update to 1.13.25:naddy2001-11-065-20/+5 * - Fix "gtar --version" segfault on -STABLE reported by Jason R. Mastaler.naddy2001-11-052-1/+16 * Update my MAINTAINER address.naddy2001-11-041-1/+1 * Update to 1.13.23petef2001-09-212-3/+4 * Update to 1.13.22.knu2001-09-117-36/+95 * change category to archivers.sf2001-02-091-1/+1 * o update to 1.13.19.sf2001-02-018-21/+40 * Changed maintainer to Christian Weisgerber <naddy@mips.inka.de>andreas2001-01-041-1/+1 * Changed maintainer to ports, I want to reduce my personal workload.andreas2001-01-041-1/+1 * my last commit didn't add patch-ab which is necessary for package buildingandreas2000-12-271-0/+11 * import more stuff from PR 23815andreas2000-12-272-1/+16 * explanation of previous committ, requested by Kris Kennaway:andreas2000-12-261-1/+1 * include two changes of PR 23815, the rest is in discussion with 'naddy'.andreas2000-12-262-1/+2 * update to version 1.13.18 as requested by David.andreas2000-12-254-33/+3 * - update port to last gtar releaseandreas2000-10-015-16/+54 * Corrrect whitespace introduced during PORTNAME conversion and portlintmharo2000-04-221-1/+1 * update port to version 1.13andreas2000-04-172-2/+2 * Update with the new PORTNAME/PORTVERSION variablecpiazza2000-04-101-2/+2 * FreeBSD.ORG -> FreeBSD.orgmharo1999-08-311-1/+1 * $Id$ -> $FreeBSD$peter1999-08-311-1/+1 * Remove the test to create ${PREFIX}/share/info/dir as it is nowmharo1999-06-062-7/+1 * ${MASTER_SITE_GNU} got rearranged in December; let's catch up.fenner1999-01-271-1/+2 * Create info/dir before trying to use it. Also, add install-info linesasami1998-12-252-1/+9 * No need to use += for variables defined only once.asami1998-06-081-2/+2