aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/AbiWord/Makefile25
-rw-r--r--editors/AbiWord/pkg-plist5
-rw-r--r--editors/AbiWord2/Makefile25
-rw-r--r--editors/AbiWord2/pkg-plist5
-rw-r--r--editors/abiword-devel/Makefile25
-rw-r--r--editors/abiword-devel/pkg-plist5
-rw-r--r--editors/abiword/Makefile25
-rw-r--r--editors/abiword/pkg-plist5
8 files changed, 112 insertions, 8 deletions
diff --git a/editors/AbiWord/Makefile b/editors/AbiWord/Makefile
index 33241a6631d..6d2104a598b 100644
--- a/editors/AbiWord/Makefile
+++ b/editors/AbiWord/Makefile
@@ -11,6 +11,7 @@
PORTNAME= AbiWord
PORTVERSION= 0.99.1
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.abisource.com/downloads/Version-${PORTVERSION}/lf/
@@ -30,10 +31,13 @@ DIST_SUBDIR= AbiWord
WRKSRC= ${WRKDIR}/abiword/abi
+USE_X_PREFIX= yes
USE_AUTOMAKE= yes
USE_GMAKE= yes
USE_GTK= yes
+WANT_GNOME= yes
AUTOMAKE= ${WRKSRC}/autogen.sh && ${FIXME}
+CONFIGURE_ARGS= --datadir=${PREFIX}/share
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgiconv"
MAKEFILE= GNUmakefile
@@ -41,6 +45,19 @@ FIXME= find ${WRKSRC} -name GNUmakefile.in | xargs ${PERL} -pi -e \
's|\$$\(libdir\)/\@PACKAGE\@|\$$\(datadir\)/\@PACKAGE\@|g ; \
s|\@DEFS\@|-I${WRKSRC}/../libiconv/include \@DEFS\@|g'
+.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
+.undef WITHOUT_GNOME
+.undef WITHOUT_ALL
+WITH_GNOME= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+CONFIGURE_ARGS+=--enable-gnome
+.endif
+
post-patch:
@giconv -f cp1251 -t koi8-u ${WRKSRC}/user/wp/strings/uk-UA.strings > \
${WRKDIR}/.uk-UA.strings
@@ -53,5 +70,11 @@ pre-configure:
post-install:
@${CAT} ${PKGMESSAGE}
+.if defined(HAVE_GNOME)
+ @${INSTALL_DATA} ${WRKSRC}/src/pkg/linux/rpm/data/abiword.desktop \
+ ${PREFIX}/share/gnome/apps/Applications/abiword.desktop
+ @${LN} -sf ${PREFIX}/share/AbiSuite/icons/abiword_48.png \
+ ${PREFIX}/share/gnome/pixmaps/abiword_48.png
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/AbiWord/pkg-plist b/editors/AbiWord/pkg-plist
index d49255a2544..94f101ab14e 100644
--- a/editors/AbiWord/pkg-plist
+++ b/editors/AbiWord/pkg-plist
@@ -1,6 +1,6 @@
bin/AbiWord
bin/AbiWord_d
-bin/AbiWord_s
+%%NOGNOME:%%bin/AbiWord_s
bin/abiword
bin/ttftool
share/AbiSuite/AbiWord/help/de-DE/about.html
@@ -570,7 +570,10 @@ share/AbiSuite/icons/abiword_16.xpm
share/AbiSuite/icons/abiword_48.png
share/AbiSuite/icons/abiword_48.tif
share/AbiSuite/icons/abiword_48.xpm
+%%GNOME:%%share/AbiSuite/icons/abiword_logo.xpm
share/AbiSuite/templates/normal.awt
+%%GNOME:%%share/gnome/apps/Applications/abiword.desktop
+%%GNOME:%%share/gnome/pixmaps/abiword_48.png
@dirrm share/AbiSuite/templates
@dirrm share/AbiSuite/icons
@dirrm share/AbiSuite/fonts
diff --git a/editors/AbiWord2/Makefile b/editors/AbiWord2/Makefile
index 33241a6631d..6d2104a598b 100644
--- a/editors/AbiWord2/Makefile
+++ b/editors/AbiWord2/Makefile
@@ -11,6 +11,7 @@
PORTNAME= AbiWord
PORTVERSION= 0.99.1
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.abisource.com/downloads/Version-${PORTVERSION}/lf/
@@ -30,10 +31,13 @@ DIST_SUBDIR= AbiWord
WRKSRC= ${WRKDIR}/abiword/abi
+USE_X_PREFIX= yes
USE_AUTOMAKE= yes
USE_GMAKE= yes
USE_GTK= yes
+WANT_GNOME= yes
AUTOMAKE= ${WRKSRC}/autogen.sh && ${FIXME}
+CONFIGURE_ARGS= --datadir=${PREFIX}/share
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgiconv"
MAKEFILE= GNUmakefile
@@ -41,6 +45,19 @@ FIXME= find ${WRKSRC} -name GNUmakefile.in | xargs ${PERL} -pi -e \
's|\$$\(libdir\)/\@PACKAGE\@|\$$\(datadir\)/\@PACKAGE\@|g ; \
s|\@DEFS\@|-I${WRKSRC}/../libiconv/include \@DEFS\@|g'
+.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
+.undef WITHOUT_GNOME
+.undef WITHOUT_ALL
+WITH_GNOME= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+CONFIGURE_ARGS+=--enable-gnome
+.endif
+
post-patch:
@giconv -f cp1251 -t koi8-u ${WRKSRC}/user/wp/strings/uk-UA.strings > \
${WRKDIR}/.uk-UA.strings
@@ -53,5 +70,11 @@ pre-configure:
post-install:
@${CAT} ${PKGMESSAGE}
+.if defined(HAVE_GNOME)
+ @${INSTALL_DATA} ${WRKSRC}/src/pkg/linux/rpm/data/abiword.desktop \
+ ${PREFIX}/share/gnome/apps/Applications/abiword.desktop
+ @${LN} -sf ${PREFIX}/share/AbiSuite/icons/abiword_48.png \
+ ${PREFIX}/share/gnome/pixmaps/abiword_48.png
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/AbiWord2/pkg-plist b/editors/AbiWord2/pkg-plist
index d49255a2544..94f101ab14e 100644
--- a/editors/AbiWord2/pkg-plist
+++ b/editors/AbiWord2/pkg-plist
@@ -1,6 +1,6 @@
bin/AbiWord
bin/AbiWord_d
-bin/AbiWord_s
+%%NOGNOME:%%bin/AbiWord_s
bin/abiword
bin/ttftool
share/AbiSuite/AbiWord/help/de-DE/about.html
@@ -570,7 +570,10 @@ share/AbiSuite/icons/abiword_16.xpm
share/AbiSuite/icons/abiword_48.png
share/AbiSuite/icons/abiword_48.tif
share/AbiSuite/icons/abiword_48.xpm
+%%GNOME:%%share/AbiSuite/icons/abiword_logo.xpm
share/AbiSuite/templates/normal.awt
+%%GNOME:%%share/gnome/apps/Applications/abiword.desktop
+%%GNOME:%%share/gnome/pixmaps/abiword_48.png
@dirrm share/AbiSuite/templates
@dirrm share/AbiSuite/icons
@dirrm share/AbiSuite/fonts
diff --git a/editors/abiword-devel/Makefile b/editors/abiword-devel/Makefile
index 33241a6631d..6d2104a598b 100644
--- a/editors/abiword-devel/Makefile
+++ b/editors/abiword-devel/Makefile
@@ -11,6 +11,7 @@
PORTNAME= AbiWord
PORTVERSION= 0.99.1
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.abisource.com/downloads/Version-${PORTVERSION}/lf/
@@ -30,10 +31,13 @@ DIST_SUBDIR= AbiWord
WRKSRC= ${WRKDIR}/abiword/abi
+USE_X_PREFIX= yes
USE_AUTOMAKE= yes
USE_GMAKE= yes
USE_GTK= yes
+WANT_GNOME= yes
AUTOMAKE= ${WRKSRC}/autogen.sh && ${FIXME}
+CONFIGURE_ARGS= --datadir=${PREFIX}/share
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgiconv"
MAKEFILE= GNUmakefile
@@ -41,6 +45,19 @@ FIXME= find ${WRKSRC} -name GNUmakefile.in | xargs ${PERL} -pi -e \
's|\$$\(libdir\)/\@PACKAGE\@|\$$\(datadir\)/\@PACKAGE\@|g ; \
s|\@DEFS\@|-I${WRKSRC}/../libiconv/include \@DEFS\@|g'
+.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
+.undef WITHOUT_GNOME
+.undef WITHOUT_ALL
+WITH_GNOME= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+CONFIGURE_ARGS+=--enable-gnome
+.endif
+
post-patch:
@giconv -f cp1251 -t koi8-u ${WRKSRC}/user/wp/strings/uk-UA.strings > \
${WRKDIR}/.uk-UA.strings
@@ -53,5 +70,11 @@ pre-configure:
post-install:
@${CAT} ${PKGMESSAGE}
+.if defined(HAVE_GNOME)
+ @${INSTALL_DATA} ${WRKSRC}/src/pkg/linux/rpm/data/abiword.desktop \
+ ${PREFIX}/share/gnome/apps/Applications/abiword.desktop
+ @${LN} -sf ${PREFIX}/share/AbiSuite/icons/abiword_48.png \
+ ${PREFIX}/share/gnome/pixmaps/abiword_48.png
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/abiword-devel/pkg-plist b/editors/abiword-devel/pkg-plist
index d49255a2544..94f101ab14e 100644
--- a/editors/abiword-devel/pkg-plist
+++ b/editors/abiword-devel/pkg-plist
@@ -1,6 +1,6 @@
bin/AbiWord
bin/AbiWord_d
-bin/AbiWord_s
+%%NOGNOME:%%bin/AbiWord_s
bin/abiword
bin/ttftool
share/AbiSuite/AbiWord/help/de-DE/about.html
@@ -570,7 +570,10 @@ share/AbiSuite/icons/abiword_16.xpm
share/AbiSuite/icons/abiword_48.png
share/AbiSuite/icons/abiword_48.tif
share/AbiSuite/icons/abiword_48.xpm
+%%GNOME:%%share/AbiSuite/icons/abiword_logo.xpm
share/AbiSuite/templates/normal.awt
+%%GNOME:%%share/gnome/apps/Applications/abiword.desktop
+%%GNOME:%%share/gnome/pixmaps/abiword_48.png
@dirrm share/AbiSuite/templates
@dirrm share/AbiSuite/icons
@dirrm share/AbiSuite/fonts
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index 33241a6631d..6d2104a598b 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -11,6 +11,7 @@
PORTNAME= AbiWord
PORTVERSION= 0.99.1
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.abisource.com/downloads/Version-${PORTVERSION}/lf/
@@ -30,10 +31,13 @@ DIST_SUBDIR= AbiWord
WRKSRC= ${WRKDIR}/abiword/abi
+USE_X_PREFIX= yes
USE_AUTOMAKE= yes
USE_GMAKE= yes
USE_GTK= yes
+WANT_GNOME= yes
AUTOMAKE= ${WRKSRC}/autogen.sh && ${FIXME}
+CONFIGURE_ARGS= --datadir=${PREFIX}/share
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgiconv"
MAKEFILE= GNUmakefile
@@ -41,6 +45,19 @@ FIXME= find ${WRKSRC} -name GNUmakefile.in | xargs ${PERL} -pi -e \
's|\$$\(libdir\)/\@PACKAGE\@|\$$\(datadir\)/\@PACKAGE\@|g ; \
s|\@DEFS\@|-I${WRKSRC}/../libiconv/include \@DEFS\@|g'
+.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
+.undef WITHOUT_GNOME
+.undef WITHOUT_ALL
+WITH_GNOME= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+CONFIGURE_ARGS+=--enable-gnome
+.endif
+
post-patch:
@giconv -f cp1251 -t koi8-u ${WRKSRC}/user/wp/strings/uk-UA.strings > \
${WRKDIR}/.uk-UA.strings
@@ -53,5 +70,11 @@ pre-configure:
post-install:
@${CAT} ${PKGMESSAGE}
+.if defined(HAVE_GNOME)
+ @${INSTALL_DATA} ${WRKSRC}/src/pkg/linux/rpm/data/abiword.desktop \
+ ${PREFIX}/share/gnome/apps/Applications/abiword.desktop
+ @${LN} -sf ${PREFIX}/share/AbiSuite/icons/abiword_48.png \
+ ${PREFIX}/share/gnome/pixmaps/abiword_48.png
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/abiword/pkg-plist b/editors/abiword/pkg-plist
index d49255a2544..94f101ab14e 100644
--- a/editors/abiword/pkg-plist
+++ b/editors/abiword/pkg-plist
@@ -1,6 +1,6 @@
bin/AbiWord
bin/AbiWord_d
-bin/AbiWord_s
+%%NOGNOME:%%bin/AbiWord_s
bin/abiword
bin/ttftool
share/AbiSuite/AbiWord/help/de-DE/about.html
@@ -570,7 +570,10 @@ share/AbiSuite/icons/abiword_16.xpm
share/AbiSuite/icons/abiword_48.png
share/AbiSuite/icons/abiword_48.tif
share/AbiSuite/icons/abiword_48.xpm
+%%GNOME:%%share/AbiSuite/icons/abiword_logo.xpm
share/AbiSuite/templates/normal.awt
+%%GNOME:%%share/gnome/apps/Applications/abiword.desktop
+%%GNOME:%%share/gnome/pixmaps/abiword_48.png
@dirrm share/AbiSuite/templates
@dirrm share/AbiSuite/icons
@dirrm share/AbiSuite/fonts