aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/cln/Makefile4
-rw-r--r--math/cln/files/patch-autoconf-ltmain.sh15
2 files changed, 17 insertions, 2 deletions
diff --git a/math/cln/Makefile b/math/cln/Makefile
index af6533dc642..07727e77553 100644
--- a/math/cln/Makefile
+++ b/math/cln/Makefile
@@ -18,9 +18,9 @@ LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
USE_BZIP2= yes
USE_GCC= 3.4
-USE_GNOME= gnomehack gnometarget lthack pkgconfig
+USE_GNOME= gnomehack gnometarget pkgconfig
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --infodir=${PREFIX}/info --mandir=${MANPREFIX}/man \
--with-gmp
diff --git a/math/cln/files/patch-autoconf-ltmain.sh b/math/cln/files/patch-autoconf-ltmain.sh
new file mode 100644
index 00000000000..5a3713d2b83
--- /dev/null
+++ b/math/cln/files/patch-autoconf-ltmain.sh
@@ -0,0 +1,15 @@
+--- autoconf/ltmain.sh.orig Tue Sep 7 04:46:35 2004
++++ autoconf/ltmain.sh Sat Jun 4 16:54:55 2005
+@@ -5547,10 +5547,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"