aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/openvpn-devel/Makefile45
-rw-r--r--security/openvpn-devel/distinfo4
-rw-r--r--security/openvpn-devel/files/pkg-message.in16
-rw-r--r--security/openvpn-devel/pkg-plist9
4 files changed, 43 insertions, 31 deletions
diff --git a/security/openvpn-devel/Makefile b/security/openvpn-devel/Makefile
index ed2f6dc0f5e..15a38a58b6e 100644
--- a/security/openvpn-devel/Makefile
+++ b/security/openvpn-devel/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: openvpn
-# Date created: 2010-02-19
-# Whom: Eric F Crist <ecrist@secure-computing.net>
-#
+# Created By: Eric F Crist <ecrist@secure-computing.net>
# $FreeBSD$
-#
PORTNAME= openvpn
-DISTVERSION= 201230
+DISTVERSION= 201237
CATEGORIES= security net
MASTER_SITES= ftp://ftp.secure-computing.net/pub/FreeBSD/ports/openvpn-devel/ \
ftp://ftp2.secure-computing.net/pub/FreeBSD/ports/openvpn-devel/
@@ -26,14 +22,14 @@ CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install mandir=${MANPREFIX}/man
-LIB_DEPENDS+= lzo2.2:${PORTSDIR}/archivers/lzo2
+LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
MAN8= openvpn.8
-OPTIONS= PW_SAVE "Interactive passwords may be read from a file" off \
- PKCS11 "Use security/pkcs11-helper" off \
- EXAMPLES "Install sample configs and scripts" off \
- POLARSSL "Build will PolarSSL instead of OpenSSL" off
+OPTIONS_DEFINE= PW_SAVE PKCS11 POLARSSL
+PW_SAVE_DESC= Interactive passwords may be read from a file
+PKCS11_DESC= Use security/pkcs11-helper
+POLARSSL_DESC= Build with PolarSSL instead of OpenSSL
USE_RC_SUBR= openvpn
USE_LDCONFIG= ${PREFIX}/lib
@@ -45,19 +41,20 @@ SUB_LIST+= OSVERSION=${OSVERSION}
WITHOUT_CHECK= yes
.endif
-.if defined (WITH_POLARSSL)
-BUILD_DEPENDS+= libpolarssl.so:${PORTSDIR}/security/polarssl
-CONFIGURE_ARGS+= --with-crypto-lib=polarssl
-.else
-USE_OPENSSL= yes
-.endif
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.ifdef (LOG_OPENVPN)
CFLAGS+= -DLOG_OPENVPN=${LOG_OPENVPN}
.endif
+.if ${PORT_OPTIONS:MPOLARSSL}
+LIB_DEPENDS+= polarssl:${PORTSDIR}/security/polarssl
+CONFIGURE_ARGS+= --with-crypto-library=polarssl
+WITHOUT_CHECK= yes
+.else
+USE_OPENSSL= yes
+.endif
+
pre-fetch:
.ifdef (LOG_OPENVPN)
@${ECHO} "Building with LOG_OPENVPN=${LOG_OPENVPN}"
@@ -70,12 +67,12 @@ pre-fetch:
@${ECHO} ""
.endif
-.if defined(WITH_PW_SAVE)
+.if ${PORT_OPTIONS:MPW_SAVE}
CONFIGURE_ARGS+= --enable-password-save
.endif
-.if defined(WITH_PKCS11)
-LIB_DEPENDS+= pkcs11-helper.1:${PORTSDIR}/security/pkcs11-helper
+.if ${PORT_OPTIONS:MPKCS11}
+LIB_DEPENDS+= pkcs11-helper:${PORTSDIR}/security/pkcs11-helper
.else
CONFIGURE_ARGS+= --disable-pkcs11
.endif
@@ -96,6 +93,8 @@ post-install:
${MKDIR} ${PREFIX}/lib
${INSTALL_LIB} ${WRKSRC}/src/plugins/down-root/.libs/openvpn-plugin-down-root.so ${PREFIX}/lib/
${INSTALL_LIB} ${WRKSRC}/src/plugins/auth-pam/.libs/openvpn-plugin-auth-pam.so ${PREFIX}/lib/
+ ${LN} -s ${WRKSRC}/src/plugins/down-root/.libs/openvpn-plugin-down-root.so ${PREFIX}/lib/openvpn-down-root.so
+ ${LN} -s ${WRKSRC}/src/plugins/down-root/.libs/openvpn-plugin-auth-pam.so ${PREFIX}/lib/openvpn-auth-pam.so
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for docs in AUTHORS COPYING COPYRIGHT.GPL ChangeLog INSTALL \
@@ -110,4 +109,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/openvpn-devel/distinfo b/security/openvpn-devel/distinfo
index d5eab733816..c5d23a66240 100644
--- a/security/openvpn-devel/distinfo
+++ b/security/openvpn-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openvpn-201230.tar.gz) = a92e577439bdadf149602f2059ab1d15a88c4db7f8784d8dd055bafd32d96c94
-SIZE (openvpn-201230.tar.gz) = 1519953
+SHA256 (openvpn-201237.tar.gz) = f6786994921acb6d207e0acdc410aa9c8096650390bcb0f36f7491cb7707a0a8
+SIZE (openvpn-201237.tar.gz) = 1519381
diff --git a/security/openvpn-devel/files/pkg-message.in b/security/openvpn-devel/files/pkg-message.in
index 68de324afdb..5954b638883 100644
--- a/security/openvpn-devel/files/pkg-message.in
+++ b/security/openvpn-devel/files/pkg-message.in
@@ -5,8 +5,18 @@
### For compatibility notes when interoperating with older OpenVPN
### versions, please, see <http://openvpn.net/relnotes.html>
### ------------------------------------------------------------------------
-### If you want to donate to OpenVPN: <http://openvpn.net/donate.html>
-### ------------------------------------------------------------------------
-### NOTE THIS IS AN UNSTABLE VERSION UNDER DEVELOPMENT!
+### NOTE THIS IS AN UNSTABLE BETA VERSION UNDER DEVELOPMENT!
### It may or may not be suitable for production. Use at your own risk.
### ------------------------------------------------------------------------
+###
+### PLUGIN LOCATION CHANGED!
+### The following plugin locations have changed. There is a symlink to the
+### new file for the duration of the 2.3 release. This will be removed in
+### OpenVPN 2.4+.
+### Old Location:
+### %%PREFIX%%/openvpn/plugins/openvpn-plugin-auth-pam.so
+### %%PREFIX%%/openvpn/plugins/openvpn-plugin-down-root.so
+###
+### New Location:
+### %%PREFIX%%/openvpn-plugin-auth-pam.so
+### %%PREFIX%%/openvpn-plugin-down-root.so
diff --git a/security/openvpn-devel/pkg-plist b/security/openvpn-devel/pkg-plist
index 488f8a402c0..9e2ee1188b6 100644
--- a/security/openvpn-devel/pkg-plist
+++ b/security/openvpn-devel/pkg-plist
@@ -4,6 +4,8 @@ lib/openvpn/plugins/openvpn-plugin-auth-pam.la
lib/openvpn/plugins/openvpn-plugin-down-root.so
lib/openvpn-plugin-down-root.so
lib/openvpn/plugins/openvpn-plugin-down-root.la
+lib/openvpn-auth-pam.so
+lib/openvpn-down-root.so
include/openvpn-plugin.h
sbin/openvpn
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
@@ -39,9 +41,10 @@ sbin/openvpn
%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/bridge-stop
%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/ucn.pl
%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/verify-cn
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample-scripts
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample-config-files
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry %%PORTDOCS%%%%DOCSDIR%%/openvpn
+@dirrmtry %%PORTDOCS%%%%DOCSDIR%%/sample-scripts
+@dirrmtry %%PORTDOCS%%%%DOCSDIR%%/sample-config-files
+@dirrmtry %%PORTDOCS%%%%DOCSDIR%%/sample
+@dirrmtry %%PORTDOCS%%%%DOCSDIR%%
@dirrmtry lib/openvpn/plugins
@dirrmtry lib/openvpn