aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/openoffice-1.0/Makefile2
-rw-r--r--editors/openoffice.org-1.0/Makefile2
-rw-r--r--editors/openoffice/Makefile2
3 files changed, 6 insertions, 0 deletions
diff --git a/editors/openoffice-1.0/Makefile b/editors/openoffice-1.0/Makefile
index b18e237095a..d98eda3309e 100644
--- a/editors/openoffice-1.0/Makefile
+++ b/editors/openoffice-1.0/Makefile
@@ -76,8 +76,10 @@ CONFIGURE_ARGS+= --with-lang=${LANG_CONFIGURE_ARG},ENUS
USE_LANG= en_US.ISO8859-15
LANG_LIST= en_US.ISO8859-15 en_US.ISO8859-1 US-ASCII
.else
+.if !defined(USE_LANG)
USE_LANG= ${LANG}
.endif
+.endif
LANG_SORTED= `${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
diff --git a/editors/openoffice.org-1.0/Makefile b/editors/openoffice.org-1.0/Makefile
index b18e237095a..d98eda3309e 100644
--- a/editors/openoffice.org-1.0/Makefile
+++ b/editors/openoffice.org-1.0/Makefile
@@ -76,8 +76,10 @@ CONFIGURE_ARGS+= --with-lang=${LANG_CONFIGURE_ARG},ENUS
USE_LANG= en_US.ISO8859-15
LANG_LIST= en_US.ISO8859-15 en_US.ISO8859-1 US-ASCII
.else
+.if !defined(USE_LANG)
USE_LANG= ${LANG}
.endif
+.endif
LANG_SORTED= `${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
diff --git a/editors/openoffice/Makefile b/editors/openoffice/Makefile
index b18e237095a..d98eda3309e 100644
--- a/editors/openoffice/Makefile
+++ b/editors/openoffice/Makefile
@@ -76,8 +76,10 @@ CONFIGURE_ARGS+= --with-lang=${LANG_CONFIGURE_ARG},ENUS
USE_LANG= en_US.ISO8859-15
LANG_LIST= en_US.ISO8859-15 en_US.ISO8859-1 US-ASCII
.else
+.if !defined(USE_LANG)
USE_LANG= ${LANG}
.endif
+.endif
LANG_SORTED= `${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`