aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/gcalcli/Makefile2
-rw-r--r--deskutils/gcalcli/files/patch-gcalcli33
2 files changed, 34 insertions, 1 deletions
diff --git a/deskutils/gcalcli/Makefile b/deskutils/gcalcli/Makefile
index 9f23ab5119e..a74ae578629 100644
--- a/deskutils/gcalcli/Makefile
+++ b/deskutils/gcalcli/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gcalcli
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
EXTRACT_SUFX= .tgz
diff --git a/deskutils/gcalcli/files/patch-gcalcli b/deskutils/gcalcli/files/patch-gcalcli
new file mode 100644
index 00000000000..0773bb55b81
--- /dev/null
+++ b/deskutils/gcalcli/files/patch-gcalcli
@@ -0,0 +1,33 @@
+--- gcalcli.orig 2008-07-06 12:29:27.000000000 +0800
++++ gcalcli 2008-07-06 12:31:38.000000000 +0800
+@@ -195,25 +195,25 @@
+ def PrintErrMsg(msg):
+ if CLR.useColor:
+ sys.stdout.write(str(CLR_BRRED()))
+- sys.stdout.write(msg)
++ sys.stdout.write(unicode(msg, 'UTF-8'))
+ sys.stdout.write(str(CLR_NRM()))
+ else:
+- sys.stdout.write(msg)
++ sys.stdout.write(unicode(msg, 'UTF-8'))
+
+
+ def PrintMsg(color, msg):
+ if CLR.useColor:
+ sys.stdout.write(str(color))
+- sys.stdout.write(msg)
++ sys.stdout.write(unicode(msg, 'UTF-8'))
+ sys.stdout.write(str(CLR_NRM()))
+ else:
+- sys.stdout.write(msg)
++ sys.stdout.write(unicode(msg, 'UTF-8'))
+
+
+ def DebugPrint(msg):
+ return
+ sys.stdout.write(str(CLR_YLW()))
+- sys.stdout.write(msg)
++ sys.stdout.write(unicode(msg, 'UTF-8'))
+ sys.stdout.write(str(CLR_NRM()))
+
+