aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-fonts/roboto-fonts-ttf/Makefile26
-rw-r--r--x11-fonts/roboto-fonts-ttf/distinfo4
-rw-r--r--x11-fonts/roboto-fonts-ttf/pkg-descr2
-rw-r--r--x11-fonts/roboto-fonts-ttf/pkg-plist13
4 files changed, 25 insertions, 20 deletions
diff --git a/x11-fonts/roboto-fonts-ttf/Makefile b/x11-fonts/roboto-fonts-ttf/Makefile
index 3b03f4a16f8..99a0e3cf24e 100644
--- a/x11-fonts/roboto-fonts-ttf/Makefile
+++ b/x11-fonts/roboto-fonts-ttf/Makefile
@@ -2,20 +2,24 @@
# $FreeBSD$
PORTNAME= roboto-fonts-ttf
-PORTVERSION= 20111129
+PORTVERSION= 1.2
+PORTEPOCH= 1
CATEGORIES= x11-fonts
-MASTER_SITES= http://developer.android.com/design/static/download/
-DISTNAME= Roboto_Hinted_${PORTVERSION}
+MASTER_SITES= http://developer.android.com/downloads/design/
+DISTNAME= roboto-${PORTVERSION}
-MAINTAINER= winstonw@lavabit.com
+MAINTAINER= winston@ml1.net
COMMENT= The Roboto typeface family
LICENSE= APACHE20
BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
- mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
+ mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale \
+ fc-cache:${PORTSDIR}/x11-fonts/fontconfig
+RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
USE_ZIP= yes
+WRKSRC= ${WRKDIR}/Roboto_v${PORTVERSION}
FONTDIR= lib/X11/fonts/Roboto
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -23,17 +27,15 @@ PLIST_SUB= FONTDIR=${FONTDIR}
SUB_FILES= pkg-message
SUB_LIST= FONTDIR=${FONTDIR}
-NO_STAGE= yes
do-build:
- @cd ${WRKSRC}/ && \
+ @${MV} ${WRKSRC}/Roboto/*.ttf ${WRKSRC}/RobotoCondensed/*.ttf ${WRKSRC}
+ @cd ${WRKSRC} && \
${LOCALBASE}/bin/mkfontscale && \
${LOCALBASE}/bin/mkfontdir
do-install:
- ${MKDIR} ${PREFIX}/${FONTDIR}/
- cd ${WRKSRC}/ && ${INSTALL_DATA} *.ttf fonts.* ${PREFIX}/${FONTDIR}/
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${FONTDIR}
+ cd ${WRKSRC}/ && ${INSTALL_DATA} *.ttf fonts.dir fonts.scale \
+ ${STAGEDIR}${PREFIX}/${FONTDIR}
.include <bsd.port.mk>
diff --git a/x11-fonts/roboto-fonts-ttf/distinfo b/x11-fonts/roboto-fonts-ttf/distinfo
index b6ec66361fc..5b8c589e40a 100644
--- a/x11-fonts/roboto-fonts-ttf/distinfo
+++ b/x11-fonts/roboto-fonts-ttf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Roboto_Hinted_20111129.zip) = 99e865226391af3ac922f476c20d3e82fb471e7cece512486f92438b6d37dfcf
-SIZE (Roboto_Hinted_20111129.zip) = 1505533
+SHA256 (roboto-1.2.zip) = 5101b5bdb3b7b14cc922a771ba068bfcae8634467c1f446bc89bc2b4f8b4f1b5
+SIZE (roboto-1.2.zip) = 2641284
diff --git a/x11-fonts/roboto-fonts-ttf/pkg-descr b/x11-fonts/roboto-fonts-ttf/pkg-descr
index f9c91cc5a89..c4c0ec991f8 100644
--- a/x11-fonts/roboto-fonts-ttf/pkg-descr
+++ b/x11-fonts/roboto-fonts-ttf/pkg-descr
@@ -3,4 +3,4 @@ emotional. It was introduced as the font used for Android 4.0 "Ice
Cream Sandwich". This typeface is designed for high resolution mobile
devices so it includes several typefaces for text in different sizes.
-WWW: http://developer.android.com/design/style/typography.html
+WWW: http://developer.android.com/design/style/typography.html
diff --git a/x11-fonts/roboto-fonts-ttf/pkg-plist b/x11-fonts/roboto-fonts-ttf/pkg-plist
index a26e70c45de..2c1b092f83f 100644
--- a/x11-fonts/roboto-fonts-ttf/pkg-plist
+++ b/x11-fonts/roboto-fonts-ttf/pkg-plist
@@ -1,11 +1,7 @@
%%FONTDIR%%/Roboto-Black.ttf
%%FONTDIR%%/Roboto-BlackItalic.ttf
%%FONTDIR%%/Roboto-Bold.ttf
-%%FONTDIR%%/Roboto-BoldCondensed.ttf
-%%FONTDIR%%/Roboto-BoldCondensedItalic.ttf
%%FONTDIR%%/Roboto-BoldItalic.ttf
-%%FONTDIR%%/Roboto-Condensed.ttf
-%%FONTDIR%%/Roboto-CondensedItalic.ttf
%%FONTDIR%%/Roboto-Italic.ttf
%%FONTDIR%%/Roboto-Light.ttf
%%FONTDIR%%/Roboto-LightItalic.ttf
@@ -14,7 +10,14 @@
%%FONTDIR%%/Roboto-Regular.ttf
%%FONTDIR%%/Roboto-Thin.ttf
%%FONTDIR%%/Roboto-ThinItalic.ttf
+%%FONTDIR%%/RobotoCondensed-Bold.ttf
+%%FONTDIR%%/RobotoCondensed-BoldItalic.ttf
+%%FONTDIR%%/RobotoCondensed-Italic.ttf
+%%FONTDIR%%/RobotoCondensed-Light.ttf
+%%FONTDIR%%/RobotoCondensed-LightItalic.ttf
+%%FONTDIR%%/RobotoCondensed-Regular.ttf
%%FONTDIR%%/fonts.dir
%%FONTDIR%%/fonts.scale
-@unexec rm %D/%%FONTDIR%%/fonts.cache-1 2>/dev/null || true
+@unexec /bin/rm %D/%%FONTDIR%%/fonts.cache-1 2>/dev/null || /usr/bin/true
@dirrm %%FONTDIR%%
+@exec %%LOCALBASE%%/bin/fc-cache -f -v %D/%%FONTDIR%% 2>/dev/null || /usr/bin/true