aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--science/abinit/Makefile2
-rw-r--r--science/afni/Makefile2
-rw-r--r--science/fvcom-mpi/Makefile2
-rw-r--r--science/fvcom/Makefile2
-rw-r--r--science/netcdf-fortran/Makefile24
-rw-r--r--science/netcdf-fortran/distinfo4
-rw-r--r--science/netcdf-fortran/files/patch-man4-netcdf-f77.texi10
-rw-r--r--science/netcdf-fortran/files/patch-man4-netcdf-f90.texi19
-rw-r--r--science/netcdf-fortran/pkg-plist16
9 files changed, 31 insertions, 50 deletions
diff --git a/science/abinit/Makefile b/science/abinit/Makefile
index 780bf72903e..8f0a2734c55 100644
--- a/science/abinit/Makefile
+++ b/science/abinit/Makefile
@@ -3,7 +3,7 @@
PORTNAME= abinit
PORTVERSION= 5.7.3
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= science
MASTER_SITES= ftp://ftp.abinit.org/pub/abinitio/ABINIT_v${PORTVERSION}/
diff --git a/science/afni/Makefile b/science/afni/Makefile
index 8401d311e03..b8d3958fb52 100644
--- a/science/afni/Makefile
+++ b/science/afni/Makefile
@@ -11,7 +11,7 @@
PORTNAME= afni
PORTVERSION= 2012.04.17.2129
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= science biology graphics
MASTER_SITES= http://personalpages.tds.net/~jwbacon/Ports/distfiles/AFNI/${PORTVERSION}/ \
http://www.acadix.biz/Ports/distfiles/AFNI/${PORTVERSION}/
diff --git a/science/fvcom-mpi/Makefile b/science/fvcom-mpi/Makefile
index ddff6ccf940..b8d64aff9e5 100644
--- a/science/fvcom-mpi/Makefile
+++ b/science/fvcom-mpi/Makefile
@@ -1,7 +1,7 @@
# Created by: Jason Bacon <jwbacon@tds.net>
# $FreeBSD$
-PORTREVISION= 3
+PORTREVISION= 4
PKGNAMESUFFIX= -openmpi
MPIPREFIX= mpi/openmpi/
diff --git a/science/fvcom/Makefile b/science/fvcom/Makefile
index 109bd684340..39745088f27 100644
--- a/science/fvcom/Makefile
+++ b/science/fvcom/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fvcom
PORTVERSION= 2.7.1
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES= science
MASTER_SITES= http://fvcom.smast.umassd.edu/FVCOM/index.html/
DISTNAME= sourcecode1
diff --git a/science/netcdf-fortran/Makefile b/science/netcdf-fortran/Makefile
index 3c1a17e859c..c5aa8e2cad8 100644
--- a/science/netcdf-fortran/Makefile
+++ b/science/netcdf-fortran/Makefile
@@ -2,11 +2,8 @@
# $FreeBSD$
PORTNAME= netcdf-fortran
-PORTVERSION= 4.2
-PORTREVISION= 3
+PORTVERSION= 4.4.0
CATEGORIES= science
-MASTER_SITES= https://github.com/Unidata/${PORTNAME}/archive/ \
- LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Fortran library for machine-independent, array-oriented data access
@@ -20,19 +17,24 @@ GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= MAKEINFOFLAGS=--no-split
MAKE_JOBS_UNSAFE= yes
-USE_AUTOTOOLS= aclocal autoconf autoheader automake libtoolize
+#USE_AUTOTOOLS= aclocal autoconf autoheader automake libtoolize
USE_LDCONFIG= yes
USES= fortran libtool makeinfo pathfix
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-${PORTVERSION}
-INFO= netcdf-f77 netcdf-f90
+#INFO= netcdf-f77 netcdf-f90
-AUTOMAKE_ARGS= --add-missing
-LIBTOOLIZE_ARGS=--copy --force --install
-PATHFIX_MAKEFILEIN= Makefile.am
+#AUTOMAKE_ARGS= --add-missing
+#LIBTOOLIZE_ARGS=--copy --force --install
+#PATHFIX_MAKEFILEIN= Makefile.am
+
+USE_GITHUB= yes
+GH_ACCOUNT= Unidata
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= ccd65b4
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libnetcdff.so.5
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libnetcdff.so.6
regression-test test: build
cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
diff --git a/science/netcdf-fortran/distinfo b/science/netcdf-fortran/distinfo
index 242c93b22d9..92b53d65fbe 100644
--- a/science/netcdf-fortran/distinfo
+++ b/science/netcdf-fortran/distinfo
@@ -1,2 +1,2 @@
-SHA256 (netcdf-fortran-4.2.tar.gz) = ab82c5edbb305d9ae6568eb0ac129b64bd8aca68fad4fa221ba8def399363bbb
-SIZE (netcdf-fortran-4.2.tar.gz) = 454043
+SHA256 (netcdf-fortran-4.4.0.tar.gz) = c7cfda7bc875ae76c285e22f8a6327bbff74e36b042149cd15248da4f637af8f
+SIZE (netcdf-fortran-4.4.0.tar.gz) = 1219408
diff --git a/science/netcdf-fortran/files/patch-man4-netcdf-f77.texi b/science/netcdf-fortran/files/patch-man4-netcdf-f77.texi
deleted file mode 100644
index 4046d85567e..00000000000
--- a/science/netcdf-fortran/files/patch-man4-netcdf-f77.texi
+++ /dev/null
@@ -1,10 +0,0 @@
---- man4/netcdf-f77.texi.orig 2012-02-29 06:03:05.000000000 +0800
-+++ man4/netcdf-f77.texi 2014-05-04 21:56:03.359920958 +0800
-@@ -2570,7 +2570,6 @@
- The name of the
- group will be copied to this character array. The name will be less
- than NF_MAX_NAME in length.
--@item
-
- @end table
-
diff --git a/science/netcdf-fortran/files/patch-man4-netcdf-f90.texi b/science/netcdf-fortran/files/patch-man4-netcdf-f90.texi
deleted file mode 100644
index 723182d730e..00000000000
--- a/science/netcdf-fortran/files/patch-man4-netcdf-f90.texi
+++ /dev/null
@@ -1,19 +0,0 @@
---- man4/netcdf-f90.texi.orig 2012-02-29 06:03:05.000000000 +0800
-+++ man4/netcdf-f90.texi 2014-05-04 21:57:31.569914537 +0800
-@@ -2082,7 +2082,6 @@
- The name of the
- group will be copied to this character array. The name will be less
- than NF90_MAX_NAME in length.
--@item
-
- @end table
-
-@@ -6979,7 +6978,7 @@
- @node FORTRAN 77 to Fortran 90 Transition Guide, Combined Index, Summary of Fortran 90 Interface, Top
- @appendix Appendix B - FORTRAN 77 to Fortran 90 Transition Guide
-
--@unnumberedsubsec The new Fortran 90 interface
-+@unnumberedsec The new Fortran 90 interface
-
- The Fortran 90 interface to the netCDF library closely follows the
- FORTRAN 77 interface. In most cases, function and constant names and
diff --git a/science/netcdf-fortran/pkg-plist b/science/netcdf-fortran/pkg-plist
index b897bc0a214..7a541a2665e 100644
--- a/science/netcdf-fortran/pkg-plist
+++ b/science/netcdf-fortran/pkg-plist
@@ -1,11 +1,19 @@
bin/nf-config
include/netcdf.inc
include/netcdf.mod
+include/netcdf4_f03.mod
+include/netcdf4_nc_interfaces.mod
+include/netcdf4_nf_interfaces.mod
+include/netcdf_f03.mod
+include/netcdf_fortv2_c_interfaces.mod
+include/netcdf_nc_data.mod
+include/netcdf_nc_interfaces.mod
+include/netcdf_nf_data.mod
+include/netcdf_nf_interfaces.mod
include/typesizes.mod
lib/libnetcdff.a
lib/libnetcdff.so
-lib/libnetcdff.so.5
-lib/libnetcdff.so.5.3.1
+lib/libnetcdff.so.6
+lib/libnetcdff.so.6.0.1
libdata/pkgconfig/netcdf-fortran.pc
-man/man3/netcdf_f77.3.gz
-man/man3/netcdf_f90.3.gz
+man/man3/netcdf_fortran.3.gz