aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.python.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 757b6c50430..2c9fbfa2679 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -671,10 +671,9 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twis
# This in turn might cause it to link against version X while using the
# includes of version Y, leading to a broken port.
# Enforce a certain Python version by using PYTHON_VER for cmake.
-.if defined(USE_CMAKE)
+
CMAKE_ARGS+= -DPythonLibs_FIND_VERSION:STRING="${PYTHON_VER}" \
-DPythonInterp_FIND_VERSION:STRING="${PYTHON_VER}"
-.endif
.endif # !defined(_POSTMKINCLUDED) && !defined(Python_Pre_Include)