aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/gnome-pim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnome-pim/Makefile')
-rw-r--r--deskutils/gnome-pim/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/deskutils/gnome-pim/Makefile b/deskutils/gnome-pim/Makefile
index 97587191e04..cafdfe23a1a 100644
--- a/deskutils/gnome-pim/Makefile
+++ b/deskutils/gnome-pim/Makefile
@@ -41,6 +41,13 @@ pre-extract:
@${ECHO} "You can add gnomepilot support by defining WITH_GNOMEPILOT"
.endif
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.if defined(WITH_GNOMEPILOT)
post-install:
@${CAT} ${PKGDIR}/PLIST.pilot >> ${TMPPLIST}